LINUX.ORG.RU

[KDE4.4] KDM не запускает KDE.


0

0

Собственно сабж. После ввода имени пользователя и пароля, моргает черный экран и затем KDM возвращается в исходное положение. Пробовал сносить все старые настройки кед и даже переустанавливал кеды, не помогло. Не могу понять в чем может быть проблема. Гугление не дало результатов. Ваши варианты?

P.S.Дистрибутив Arch Linux.


Какая версия кде?
Ставил из extra или kdemod?

В Xorg.conf в параметры видео не прописан «BackingStore»? (если прописан, то удали)

AX ★★★★★ ()

Вроде такое бывает, если перед логином не был запущен dbus. Стартуй hal перед kdm.

thesis ★★★★★ ()

Как насчет залогиниться в консоли и xinit/kdestart - короче, руками запустить?
Еще в /var/log/kdm.log может чего интересного.
И вообще, хотя б историю какую-нибудь рассказал.

У меня после обновления из kdemod kdm не запускал kde, потому что неправильно удалился/обновился пакет с phonon. То есть пакет удалился, а файлы нет.

metar ★★★ ()

Может стоит посмотреть логи иксов и кдм?

staseg ★★★★★ ()
Ответ на: комментарий от AX

Версия кед 4.4, собственно после обновления такая ерунда и началась, сначала отвалилась мышь, с клавиатурой, вылечил, теперь вот не могу залогиниться.

Valoo ()

X.Org X Server 1.7.4.901 (1.7.5 RC 1) Release Date: 2010-01-23 X Protocol Version 11, Revision 0 Build Operating System: Linux 2.6.32-ARCH x86_64 Current Operating System: Linux arch 2.6.32-ARCH #1 SMP PREEMPT Tue Feb 9 15:12:10 CET 2010 x86_64 Kernel command line: root=/dev/sda3 vga=775 ro Build Date: 31 January 2010 11:34:27AM Current version of pixman: 0.16.4    Before reporting problems, check http://wiki.x.org    to make sure that you have the latest version. Markers: (--) probed, (**) from config file, (==) default setting,    (++) from command line, (!!) notice, (II) informational,    (WW) warning, (EE) error, (NI) not implemented, (??) unknown. (==) Log file: «/var/log/Xorg.0.log», Time: Mon Feb 15 22:53:41 2010 (==) Using config file: «/etc/X11/xorg.conf» QFont::fromString: Invalid description 'Serif,20,5,0,50,0' QFont::fromString: Invalid description 'Sans Serif,10,5,0,50,0' QFont::fromString: Invalid description 'Sans Serif,10,5,0,75,0' QThread::wait: Thread tried to wait on itself QThread: Destroyed while thread is still running

Valoo ()
Ответ на: комментарий от madgnu

libgl не установлен, т.к.

:: libgl конфликтует с nvidia-utils. Удалить nvidia-utils? [Y/n]

Valoo ()
Ответ на: комментарий от metar

Да, удается, так я и запускаю. Поставил Slim,прописал в .xinitrc: exec startkde, так и живу пока.

Valoo ()

consolekit-daemon и dbus должны помочь.

Ximen ★★★★ ()

Всем спасибо, добавление dbus в rc.conf помогло.

Valoo ()
Ответ на: комментарий от metar

запуск kde

Здравствуйте! Хотел поинтересоваться как решить проблему с phonon, тоже не запускается кде4.4. Пишет, что Cannot load library /usr/lib/libkdeinit4_ksmserver.so (libphonon.so.4: cannot open shared object: No such file or directory) Всё это произошло после обновления. Спасибо!

Odonkor ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.