LINUX.ORG.RU

обновление RH8->RH9, перекючение раскладки


0

0

Граждане, после обновления RedHat8 до 9-ки раскладка перестала переключаться. В XF86Config сделующее Identifier "Keyboard0" Driver "keyboard" Option "XkbRules" "XFree86" Option "XkbModel" "microsoft" Option "XkbLayout" "ru,us(winkeys)" Option "XkbOptions" "grp:ctrl_shift_toggle" Если выбрать "XkbLayout" "ru" имеем только русскую раскладку в X-ах, если "en" только английскую, как добиться переключния? В восьмерке все настраивалось :((

anonymous

Re: обновление RH8->RH9, перекючение раскладки

Вы хотите сказать, что ваша комбинация (Ctrl+Shift) не переключает раскладки? Странно... У меня стоит

Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"

Как написано, так всё и работает...

wildhoney ()

Re: обновление RH8->RH9, перекючение раскладки

Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "microsoft"
Option "XkbVariant" "winkeys"
Option "XkbLayout" "us,ru"
Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"

kraw ★★★★ ()

Re: Re: обновление RH8->RH9, перекючение раскладки

2 kraw

В Red Hat 9 стоят XFree86 4.3.0, а там несколько изменились правила настройки клавы. В вашем варианте winkeys для русского языка не сработает. Надо писать либо так:

Option "XkbVariant" ",winkeys"
Option "XkbLayout" "us,ru"

Запятая перед winkeys вовсе не случайна - она означает, что для "us" раскладка по умолчанию, а вот для "ru" - как раз именно winkeys. Либо пишите так одной строкой:

Option "XkbLayout" "us,ru(winkeys)"

wildhoney ()

Re: обновление RH8->RH9, перекючение раскладки

У меня тоже была такая проблема. Иксы - 4.3 правда дистрибутив - слакварь 9. Так вот - правка XF86Config не помогала ни в какую - там оказывается есть в директории X11 есть папочка xkb, а в ней файлик X0-config.keyboard, вот в нем то и надо прописать Rules = "xfree86" Model = "microsoftpro" Layout = "us,ru(winkeys)" Options = "grp:ctrl_shift_toggle,grp_led:scroll" после чего все заработало. Так что попробуй.

Nagwal ★★★★ ()

обновление RH8->RH9, перекючение раскладки

Спасибо всем ответившим все удалось исправить заменой
Option "XkbRules" "XFree86"
на
Option "XkbRules" "xfree86"
глупая, однако, ошибка :((

anonymous ()

Re: обновление RH8->RH9, перекючение раскладки

2wildhoney: Воистину "Век живи - век учись". У меня и дома и на работе RH9. Попробую Ваш совет.

kraw ★★★★ ()

Re: обновление RH8->RH9, перекючение раскладки

>У меня тоже была такая проблема. Иксы - 4.3 правда дистрибутив - слакварь 9

неправда, в слаке проблем нет, слака - рулез, рудез - слака!

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.