LINUX.ORG.RU

[Ubuntu 9.04] Не стартуют иксы


0

0

Добрый день.

Обновился до 9.04 и получил неработающие иксы. Nvidia GeForce 6500, драйвера - nvidia-glx-180.

При попытке запустить иксы они падают, при этом утягивая за собой консоль. :) (F1,F2... не помогают - черный экран)

Вот лог Xorg:

Backtrace:
0: /usr/bin/X11/X(xorg_backtrace+0x3b) [0x813518b]
1: /usr/bin/X11/X(xf86SigHandler+0x55) [0x80c7be5]
2: [0xb8031400]
3: /usr/bin/X11/X(ActivateDevice+0x4f) [0x808662f]
4: /usr/bin/X11/X(InitAndStartDevices+0x42) [0x8086732]
5: /usr/bin/X11/X(main+0x36f) [0x807229f]
6: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5) [0xb7bee775]
7: /usr/bin/X11/X [0x80717a1]
Saw signal 11.  Server aborting.
Полная версия: http://narod.ru/disk/8043540000/Xorg.0.log.html

xorg.conf: http://narod.ru/disk/8043642000/xorg.conf.html

Очень надеюсь на вашу помощь. :)


Re: [Ubuntu 9.04] Не стартуют иксы

Сравни версии дров и ядерного модуля. Что-то наподобие "aptitude show nvidia-glx nvidia-kernel-source".

Ну и попробуй обновиться.

1) Загружаешься с liveCD

2) Создаёшь директорию "mkdir /tmp/sda"

3) Смотришь номер раздела "fdisk -l"

4) Монтируешь раздел с Бубнтой "mount /dev/sd<раздел> /tmp/sda"

5) Подключаешь дополнительные ФС "cd /tmp/sda && mount --bind /dev dev/ && mount --bind /sys sys/ && mount --bind /proc proc/"

6) Заходишь в свою систему "chroot ."

7) Обновляешься "aptitude update && aptitude full-upgrade"

З.Ы. Ссылки нерабочие.

wyldrodney ()
Ответ на: Re: [Ubuntu 9.04] Не стартуют иксы от wyldrodney

Re: [Ubuntu 9.04] Не стартуют иксы

С версиями дров вроде все нормально:
dpkg-query -W -f '${Status;25} ${Package}\n' | grep nvidia:
         install ok installed nvidia-173-modaliases
         install ok installed nvidia-177-modaliases
         install ok installed nvidia-180-kernel-source
         install ok installed nvidia-180-libvdpau
         install ok installed nvidia-180-modaliases
         install ok installed nvidia-71-modaliases
         install ok installed nvidia-96-modaliases
         install ok installed nvidia-common
        purge ok config-files nvidia-glx
    deinstall ok config-files nvidia-glx-173
    deinstall ok config-files nvidia-glx-177
         install ok installed nvidia-glx-180
    deinstall ok config-files nvidia-glx-96
        purge ok config-files nvidia-glx-legacy
         install ok installed nvidia-kernel-common
         install ok installed nvidia-settings

Нет, обновления не помогают. К тому же ничего связаного с иксами в них нет:
    The following packages will be upgraded:
      bluetooth bluez bluez-alsa bluez-cups bluez-gstreamer bluez-utils consolekit cups cups-bsd
      cups-client cups-common cupsys cupsys-bsd cupsys-client cupsys-common evince evince-dbg
      evolution-data-server evolution-data-server-common evolution-data-server-dbg firefox firefox-3.0
      firefox-3.0-branding gnome-applets gnome-applets-data gnome-applets-dbg gnome-settings-daemon
      gnome-system-tools libbluetooth3 libcamel1.2-14 libck-connector0 libcups2 libcups2-dev
      libcupsimage2 libcupsys2 libcupsys2-dev libebackend1.2-0 libebook1.2-9 libecal1.2-7
      libedata-book1.2-2 libedata-cal1.2-6 libedataserver1.2-11 libedataserverui1.2-8
      libegroupwise1.2-13 libevdocument1 libevview1 libexchange-storage1.2-3 libgdata-google1.2-1
      libgdata1.2-1 libgweather-common libgweather1 libmjpegtools-1.9 libnautilus-extension1
      libsoup-gnome2.4-1 libsoup2.4-1 nautilus nautilus-data nautilus-dbg notification-daemon
      pidgin-libnotify python-cupshelpers screen-profiles synaptic system-config-printer-common
      system-config-printer-gnome update-manager update-manager-core xulrunner-1.9 xulrunner-1.9-dev
      xulrunner-1.9-gnome-support

riYu ()

Re: [Ubuntu 9.04] Не стартуют иксы

драйвера видео тут вообще не причем
а ошибки сыпятся от ваших хитрых устройств ввода
это фрагмент вашего лога:
(II) Initializing extension GLX
(**) Option "SendCoreEvents"
(**) stylus: always reports core events
(**) stylus device is /dev/wacom
(**) stylus (stylus) is not a pad
(**) stylus is in absolute mode
(**) stylus: forcing TabletPC ISD V4 protocol
(**) WACOM: suppress value is 2
(**) /dev/wacom: Tablet PC buttons are on
(**) Option "BaudRate" "9600"
(**) stylus: serial speed 9600
(II) XINPUT: Adding extended input device "stylus" (type: Wacom Stylus)
(**) Option "Device" "/dev/wacom"
(EE) xf86OpenSerial: Cannot open device /dev/wacom
No such file or directory.
Error opening /dev/wacom : No such file or directory
(II) UnloadModule: "wacom"
(**) Option "SendCoreEvents"
....
ну и все так далее до падения X11

Ну и что там у вас еще прицеплено к компу помимо клавы и мышки ?

elipse ★★★ ()
Ответ на: Re: [Ubuntu 9.04] Не стартуют иксы от novitchok

Re: [Ubuntu 9.04] Не стартуют иксы

>Убунту головного мозга

Шутник?

>Вот объясни, _зачем_ с лайф-сиди грузиться????

Это один из _почти_всегда_ работающих вариантов. Может у него иксы грузятся и вешают намертво переключение терминалов - как он в консоль попадёт? Про отключение сервисов знаю, но не знаю как с этим в Бубунте. И вообще, кому-то от этой инфы плохо стало?

wyldrodney ()

Re: [Ubuntu 9.04] Не стартуют иксы

У тебя очень старый xorg.conf (который видимо достался еще со времён feisty или gutsy), в котором очень много устаревших опций. InputDevices сейчас не прописывают туда, и как уже сказали выше - проблема может быть из-за них. У меня, например, как-то из-за старого xorg.conf (слишком подробного описания мышки) иксы падали из-за нажатия колесиком влево-вправо.
Попробуй стандартный:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
	Driver		"nvidia"
EndSection

Настройки раскладки теперь хранят в /etc/default/console-setup:
# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.
XKBMODEL="pc105"
XKBLAYOUT="us,ru"
XKBVARIANT=","
XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"

winkeys теперь по-умолчанию. Устройства ввода настраиваются правилами hal.

snizovtsev ★★★★ ()
Ответ на: Re: [Ubuntu 9.04] Не стартуют иксы от snizovtsev

Re: [Ubuntu 9.04] Не стартуют иксы

>winkeys теперь по-умолчанию. Устройства ввода настраиваются правилами hal.
огорчу вас
у вас тоже устарелые данные
на свеже установленной убунту 9.04
у меня работает переключение раскладок и индикатор и размер xorg.conf = 0

elipse ★★★ ()
Ответ на: Re: [Ubuntu 9.04] Не стартуют иксы от elipse

Re: [Ubuntu 9.04] Не стартуют иксы

Нулевым размером xorg.conf не удивили. Просто у меня под рукой только Ubuntu 8.04 и 8.10, сочинять правило hal для nvidia вместо nv было лень. Топикстартеру в любом случае нужно чистить xorg.conf.

snizovtsev ★★★★ ()
Ответ на: Re: [Ubuntu 9.04] Не стартуют иксы от wyldrodney

Re: [Ubuntu 9.04] Не стартуют иксы

смешной ты, то у тебя памяти виртуальной > 20 гигов, то ты даже и не слыхивал о том, что можно _вообще_ без иксов грузится, в убунту, ксатя, даже пунктек такой в меню груба есть ;), но советуешь фигню с загрузкой с лайфа и установки пакетов через ..., то пытаешься словом "сервисы" щегольнуть, не понимая о чём говоришь....

novitchok ★★★★★ ()
Ответ на: Re: [Ubuntu 9.04] Не стартуют иксы от snizovtsev

Re: [Ubuntu 9.04] Не стартуют иксы

> У тебя очень старый xorg.conf (который видимо достался еще со времён feisty или gutsy), в котором очень много устаревших опций. InputDevices сейчас не прописывают туда, и как уже сказали выше - проблема может быть из-за них. У меня, например, как-то из-за старого xorg.conf (слишком подробного описания мышки) иксы падали из-за нажатия колесиком влево-вправо.
> Попробуй стандартный:


Огромное спасибо! Заработало. :)

riYu ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.