LINUX.ORG.RU

После запуска иксов экран гаснет


0

0

Обращаюсь за помощью к лоровскому разуму.

На интеле + видюха Nvidia. Gentoo.

К двухголовой видюхе подключены моник ViewSonic и телек черед кабель DVI->HDMI.

После загрузки компа стартуют иксы, появляется лого Nvidia, после чего монитор гаснет и пишет No Signal. Если в это время двинуть мышкой или топнуть по клавише, то картинка появляется, если ничего не делать, то иксы упадут через несколько секунд.

Есть разлогиниться (или не разлогиниваться) и сделать
/etc/init.d/xdm restart [stop, start]
то проблема не проявляется. Таким образом, проблема возникает только при именно загрузке компа с нуля. Телек при загрузке выключен. Поначалу я грешил на это. Но потом выяснил, что
1. если телек включить до загузки, то ничего не меняется
2. на работе - то же самое происходит
И вот тут я понял, что пора посовещаться с лором.

Потому что на работе у меня другая машинка и монитор всего один и видюха Intel встроенная. Но проблема абсолютно такая же (если б свет не вырубили как-то раз, то и не узнал бы, а так пришлось перезагрузиться)

Соответственно, какие могут быть предположения? Не нравится мне дежурить у компа, когда он включается.


Re: После запуска иксов экран гаснет

Some tech Info:

Дома

00:00.0 Host bridge: Intel Corporation DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation PCI Express Root Port (rev 02)
00:03.0 Communication controller: Intel Corporation MEI Controller (rev 02)
00:19.0 Ethernet controller: Intel Corporation 82566DC-2 Gigabit Network Connection (rev 02)
00:1a.0 USB Controller: Intel Corporation USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation PCI Express Port 4 (rev 02)
00:1c.4 PCI bridge: Intel Corporation PCI Express Port 5 (rev 02)
00:1d.0 USB Controller: Intel Corporation USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation LPC Interface Controller (rev 02)
00:1f.2 RAID bus controller: Intel Corporation 82801 SATA RAID Controller (rev 02)
00:1f.3 SMBus: Intel Corporation SMBus Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation Device 0611 (rev a2)
03:00.0 IDE interface: Marvell Technology Group Ltd. 88SE6101 single-port PATA133 interface (rev b2)
07:03.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)



# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (root@mediacenter)  Сбт Сен 13 21:44:42 MSD 2008

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/lib/X11/rgb"
    FontPath        "/usr/share/fonts/misc"
    FontPath        "/usr/share/fonts/75dpi"
    FontPath        "/usr/share/fonts/100dpi"
    FontPath        "/usr/share/fonts/TTF"
    FontPath        "/usr/share/fonts/cyrillic/ttf"
    FontPath        "/usr/share/fonts/Type1"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
### WHERE IS IT FROM??
    Load           "record"
    Load           "xtrap"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

### REALLY NEED?
Section "Extensions"
    Option "Composite" "Enable"
EndSection

Section "InputDevice"
    # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
### PREV xorg.conf HAD IT
#    Option         "Protocol" "ImPS/2"
#    Option         "Device" "/dev/input/mouse0"
#    Option         "Buttons" "5"
#    Option         "Sensitivity" "0.7"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us,ru(winkeys)"
#    Option         "XkbOptions" "grp_led:scroll,grp:rwin_toggle,grp:lwin_switch,grp:ctrl_shift_toggle,grp:alt_s
hift_toggle,grp:menu_toggle,compose:caps"
    Option	"XkbOptions" "grp_led:scroll,grp:win_set"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "ViewSonic VX1962wm"
    HorizSync       30.0 - 82.0
    VertRefresh     50.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: unknown, VertRefresh source: unknown
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Philips"
    HorizSync       0.0 - 0.0
    VertRefresh     0.0
    Option "DPI" "96 x 96"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GT"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Videocard1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GT"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP-0: 1680x1050_60 +0+0" # DFP-0: nvidia-auto-select +0+0"
    Option         "DynamicTwinView" "0"
    SubSection     "Display"
        Depth       24
#	Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Videocard1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP-1: 1280x768_50 +0+0" #"DFP-1: nvidia-auto-select +0+0"
    Option         "DynamicTwinView" "0"
    SubSection     "Display"
        Depth       24
#	Modes      "nvidia-auto-select"
    EndSubSection
EndSection

##############
##############
######!!!!!!!!
##############
##############

name_no ★★ ()

Re: После запуска иксов экран гаснет

После падения иксов монитор включается и появляется приглашение логиниться в консоль.

Ошибок после падения иксов в Xorg.log нет.
Зато есть в kdm.log

(II) Module already built-in
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  113 (X_KillClient)
  Value in failed request:  0x251
  Serial number of failed request:  3672214
  Current serial number in output stream:  3672217
FreeFontPath: FPE "/usr/share/fonts/misc" refcount is 2, should be 1; fixing.


Вот ворнинги из Xorg.log:

(WW) The directory "/usr/share/fonts/cyrillic/ttf" does not exist.

(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)

(WW) NVIDIA(1): The EDID for Philips (DFP-1) contradicts itself: mode
(WW) NVIDIA(1):     "1920x1080" is specified in the EDID; however, the EDID's
(WW) NVIDIA(1):     valid HorizSync range (31.000-80.000 kHz) would exclude
(WW) NVIDIA(1):     this mode's HorizSync (28.1 kHz); ignoring HorizSync check
(WW) NVIDIA(1):     for mode "1920x1080".
(WW) NVIDIA(1): The EDID for Philips (DFP-1) contradicts itself: mode
(WW) NVIDIA(1):     "1920x1080" is specified in the EDID; however, the EDID's
(WW) NVIDIA(1):     valid HorizSync range (31.000-80.000 kHz) would exclude
(WW) NVIDIA(1):     this mode's HorizSync (28.1 kHz); ignoring HorizSync check
(WW) NVIDIA(1):     for mode "1920x1080".
(WW) NVIDIA(1): The EDID for Philips (DFP-1) contradicts itself: mode
(WW) NVIDIA(1):     "1920x1080" is specified in the EDID; however, the EDID's
(WW) NVIDIA(1):     valid HorizSync range (31.000-80.000 kHz) would exclude
(WW) NVIDIA(1):     this mode's HorizSync (28.1 kHz); ignoring HorizSync check
(WW) NVIDIA(1):     for mode "1920x1080".
(WW) NVIDIA(1): The EDID for Philips (DFP-1) contradicts itself: mode
(WW) NVIDIA(1):     "1920x1080" is specified in the EDID; however, the EDID's
(WW) NVIDIA(1):     valid HorizSync range (31.000-80.000 kHz) would exclude
(WW) NVIDIA(1):     this mode's HorizSync (28.1 kHz); ignoring HorizSync check
(WW) NVIDIA(1):     for mode "1920x1080".
(II) NVIDIA(1): Assigned Display Device: DFP-1
(WW) NVIDIA(1): No valid modes for "DFP-1:1280x768_50+0+0"; removing.
(WW) NVIDIA(1):
(WW) NVIDIA(1): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(1):     "nvidia-auto-select".
(WW) NVIDIA(1):

(WW) Option "Protocol" requires an string value


Кстати, версии:

X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: UNKNOWN
Current Operating System: Linux mediacenter 2.6.25-gentoo-r7 #1 SMP Sun Oct 5 19:43:58 MSD 2008 i686
Build Date: 17 June 2008

media-libs/mesa-6.5.2-r1
x11-base/xorg-server-1.3.0.0-r6
x11-base/xorg-x11-7.2

name_no ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.