LINUX.ORG.RU

Неадекватно гаснет экран

 , ,


0

1

Суть проблемы: гаснет экран ноутбука при включении любого проигрывателя (конкретно испробовал smplayer и vlc) после 2-3 секунд воспроизведения видео. если пошевелить мышкой - выводится экран разблокировки, хотя все соответствующие настройки проведены в Менеджере питания. Не всегда успеваю выключить плэйер, так как экран гаснет постоянно. Что делать? Желательно поэтапно.

Отключите блокировку экрана при бездействии, если вы этого ещё не сделали. А так, видимо, либо плееры не умеют сообщать о том, что идёт воспроизведение видео, либо экранная заставка не умеет обрабатывать сигналы от плееров.

В любом случае, ваши действия это написать баг репорт (сообщение об ошибке) на трекер обработки ошибок вашего дистрибутива.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Отключите блокировку экрана при бездействии, если вы этого ещё не сделали. А так, видимо, либо плееры не умеют сообщать о том, что идёт воспроизведение видео, либо экранная заставка не умеет обрабатывать сигналы

Но не через 2-3 секунды же блокировка включаться должна.

Shlyapa ★★ ()
Ответ на: комментарий от Shlyapa

Поздравляю. Значит от прочтёт и ответит. Ну а по факту зачем был написан ваш комментарий ?

Я указал очевидную причину, какие стоят настройки включения экранной заставки, да и просто параметры управления энергосбережения монитора (dpms) ТС не указал, пускай смотрит.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Ну а по факту зачем был написан ваш комментарий ?

потому что «плееры не умеют сообщать о том, что идёт воспроизведение видео, и поэтому через 2-3 секунды вырубается экран» - это ерунда.

Shlyapa ★★ ()
Ответ на: комментарий от kostik87

в настройках отключена блокировка экрана. вообще, от смены настроек зависит больше вот что: вырубается ли экран при видео или вырубается сам по себе сразу после изменения настроек. в плэйере стоит подавление экрана, но толков нет.

Synthez ()
Ответ на: комментарий от Synthez

Я вам уже ответил:

Я указал очевидную причину, какие стоят настройки включения экранной заставки, да и просто параметры управления энергосбережения монитора (dpms) ТС не указал, пускай смотрит.

kostik87 ★★★★★ ()
Ответ на: комментарий от Rudollf

Ну и отключать DPMS не совсем хорошо, тем более на ноутбуке, достаточно написать скрипт, который изменяет интервалы ожидания перед переходом экрана в ждущий режим.

Можно написать скрипт обёртку, выполняющийся вместе с плеером и ждущий пока плеер закроют, после чего возвращющий исходные значения параметров энергосбережения.

kostik87 ★★★★★ ()
Ответ на: комментарий от Rudollf
#------------------------------------------------------------------------------
# Modified Calculate-core 3.1.6
# Processed template files:
# /var/lib/layman/calculate/profiles/templates/3.1/3_ac_install_live/1-live/x11-base/xorg-server/X11/xorg.conf
# For modify this file, create /etc/X11/xorg.conf.clt template.
#------------------------------------------------------------------------------

Section "ServerLayout"
  Identifier "Xorg Configured"
  Screen "Monitor"
EndSection

Section "Files"
  FontPath "/usr/share/fonts/corefonts"
  FontPath "/usr/share/fonts/misc"
  FontPath "/usr/share/fonts/droid"
EndSection

Section "Module"
  Load "dbe" # Double buffer extension
  Load "glx" # OpenGL X protocol interface
  Load "extmod" # Misc. required extension
EndSection

Section "Monitor"
  Identifier "StandardMonitor"
  HorizSync 31.5 - 60.0
  VertRefresh 60-160
  Option "DPMS" "Off"
EndSection

Section "Device"
  Identifier "nvidiaVGA"
  Driver "nvidia"
  Option "RenderAccel" "True"
  Option "AllowGLXWithComposite" "True"
  Option "NoLogo" "True"
  Option "NvAgp" "1"
  Option "DPI" "96x96"
EndSection

Section "Screen"
  Identifier "Monitor"
  Device "nvidiaVGA"
  Monitor "StandardMonitor"
  DefaultDepth 24
  Subsection "Display"
    Viewport 0 0
    Depth 24
    Modes "1366x768"
  EndSubsection
EndSection

Section "Extensions"
  Option "Composite" "Off"
EndSection
Synthez ()
Ответ на: комментарий от Rudollf

Да, эти, только их можно изменять перед запуском плеера, да и вообще отключать dpms скриптом, а затем опять включать.

Всё же на ноутбуке энергосбережение монитора лучше оставить.

kostik87 ★★★★★ ()
Ответ на: комментарий от Rudollf

не всё понятно. в частности, не нахожу у себя в логе параметра

в секцию ServerLayout, измените, как считаете нужным время (в минутах):
Option "StandbyTime" "10"
Option "SuspendTime" "20"
Option "OffTime" "30"

Synthez ()
Ответ на: комментарий от Synthez

А вы xorg-server перезапустили, ну или хотя бы перезагрузили систему ?

Но отключать не стоит, лучше настроить интервалы.

kostik87 ★★★★★ ()
Ответ на: комментарий от Synthez

Попробуйте включить всё же dpms, но изменить указанные интервалы, ну и всё же отключите заставку и блокировку экрана.

Т.к. я не уверез, что приложения, написанные для другого DE (Desktop Envirionment), будут корректно работаь в XFCE в плане взаимодействия с компонентами среды, в том числе и скринсэйвером.

Всё же, что VLC, что smplayer это приложения для KDE.

UPD:
Хотя если вы будете использовать smplayer (mplayer), можете, кстати посмотреть gnome-player, раз уж у вас среда на GTK, то почитайте вот эту статью: https://wiki.archlinux.org/index.php/MPlayer#Configuration

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от Rudollf

добавил скрипт. как я понял, 2 строки надо дописать в конце

# С /usr/local/bin в переменной PATH
display.sh suspend

# Без /usr/local/bin в переменной PATH
/usr/local/bin/display.sh standby
так вот, при включении display.sh off начинается светопреставление, а именно: экран гаснет, при шевелении мышкой снова оживает и снова гаснет. такая ерунда прекращается только при закрытии терминала.

Synthez ()

Попробуйте так:

xset -dpms
xset s off

Wolfram ()
Ответ на: комментарий от Synthez

как я понял, 2 строки надо дописать в конце

Какие две строки, куда ? Этот скрипт:

#!/bin/bash
#
# Small script to set display into standby, suspend or off mode
# 20060301-Joffer
#

XSET=/usr/bin/xset

if [ $1 ]; then
        if [ $1 = "standby" ] || [ $1 = "suspend" ] || [ $1 = "off" ]; then
                $XSET dpms force $1
        else
                echo "Usage: $0 standby|suspend|off"
                exit
        fi
else
        echo "$0 usage: $0 standby|suspend|off"
        exit
fi
в зависимости от переданного параметра включает монитор, переводит его в режим ожидания и выключает.

так вот, при включении display.sh off начинается светопреставление, а именно: экран гаснет, при шевелении мышкой снова оживает и снова гаснет. такая ерунда прекращается только при закрытии терминала.

Так вот всё правильно, параметр off выключает монитор. Вам этот скрипт не нужен, по крайней мере в том виде, в котором он есть.

Вы уж начитесь читать и понимать то, что написано, а не бездумно что-то копировать и выпонять.

Для вас ценными указаниями является внесение в конфигурационный файл xorg-server`а интервалов ожидания:

Добавьте следующие строки в /etc/X11/xorg.conf: в секцию Monitor:

Option "DPMS" "true"

в секцию ServerLayout, измените, как считаете нужным время (в минутах):

Option "StandbyTime" "10"
Option "SuspendTime" "20"
Option "OffTime" "30" 

При использовании smplayer`а (mplayer`а) вы пробовали в его конфигурационном файле указывать отключение screensaver`а ?

В /etc/mplayer/mplayer.conf или ~/.mplayer/config ?

# disable screensaver
heartbeat-cmd=«xscreensaver-command -deactivate &» # stop xscreensaver
stop-xscreensaver=«yes» # stop gnome-screensaver
kostik87 ★★★★★ ()
Ответ на: комментарий от Synthez

А что в других дистрибутивах всё нормально ? И DE такое же ? И плееры ?

kostik87 ★★★★★ ()
Ответ на: комментарий от Synthez

какой пень, какой дистр? Чувак, это линукс. Нет, ты конечно можешь поставить убунту, и там будет все ок, ведь там нет xscreensaver из коробки... Но не проще ли снести xscreensaver и поставить какой нибудь интеллектуальный блокировщик, например от xfce?

comp00 ★★★★ ()
Ответ на: комментарий от comp00

не проще. вчера и так пол-дня угробил. понимаешь, мне есть чем заняться помимо Линукса:)

Synthez ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.