LINUX.ORG.RU

Debian GNU/Linux, kernel 2.6.26-1-686 & vmware6


0

0

Кто собирал vmware6 под ядро kernel 2.6.26-1-686. Я как понел стоит две проблемы.
1. gcc-4.1 ваше ядро собранно с gcc-4.1 ,а у вас gcc-4.3. Но тута можна обмануть.
2. И в заголовочных файлах ядра то есть  находит начинает компилировать и выдает ошибку.
Вот ошибка:
What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.6.26-1-686/build/include]

Extracting the sources of the vmmon module.

Building the vmmon module.

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config1/vmmon-only'
make -C /lib/modules/2.6.26-1-686/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.26-1-686'
/tmp/vmware-config1/vmmon-only/Makefile:90: *** Inappropriate build environment: you wanted to use gcc version 4.3.1 while kernel attempts to use gcc version 4.1.3.
/tmp/vmware-config1/vmmon-only/Makefile:92: *** For proper build you'll have to replace  gcc-4.1 with symbolic link to /usr/bin/gcc.  Останов.
make[1]: *** [_module_/tmp/vmware-config1/vmmon-only] Ошибка 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.26-1-686'
make: *** [vmmon.ko] Ошибка 2
make: Leaving directory `/tmp/vmware-config1/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.

Как бороться с этой проблемой подскажите.
Заранее благодарен за ваш ответ.

Re: Debian GNU/Linux, kernel 2.6.26-1-686 & vmware6

> 1. gcc-4.1 ваше ядро собранно с gcc-4.1 ,а у вас gcc-4.3. Но тута можна обмануть.

не обманешь. Модуль то соберется, но загрузить его не получится

> /tmp/vmware-config1/vmmon-only/Makefile:90: *** Inappropriate build environment: you wanted to use gcc version 4.3.1 while kernel attempts to use gcc version 4.1.3.


Ставь gcc 4.1 и собирай модуль им

JB ★★★★★ ()

Re: Debian GNU/Linux, kernel 2.6.26-1-686 & vmware6

А как такое оказалось, что версии gcc разные?

Deleted ()
Ответ на: Re: Debian GNU/Linux, kernel 2.6.26-1-686 & vmware6 от JB

Re: Debian GNU/Linux, kernel 2.6.26-1-686 & vmware6

Ну хорошо. У меня уже стоит gcc-4.1 & gcc-4.3. Когда начинаеш собирать в ответ выдает тоже самое.

Arman ()

Re: Debian GNU/Linux, kernel 2.6.26-1-686 & vmware6

Насколько я помню, для сборки vmmon на новых ядрах нужен какой-то патч, попробуй загуглить.

Laz ★★★★ ()
Ответ на: Re: Debian GNU/Linux, kernel 2.6.26-1-686 & vmware6 от Arman

Re: Debian GNU/Linux, kernel 2.6.26-1-686 & vmware6

> Ну хорошо. У меня уже стоит gcc-4.1 & gcc-4.3. Когда начинаеш собирать в ответ выдает тоже самое.

export CC=/usr/bin/gcc-4.1 или через update-alternatives

JB ★★★★★ ()
Ответ на: Re: Debian GNU/Linux, kernel 2.6.26-1-686 & vmware6 от Laz

Re: Debian GNU/Linux, kernel 2.6.26-1-686 & vmware6

> Насколько я помню, для сборки vmmon на новых ядрах нужен какой-то патч, попробуй загуглить.

vmware-any-any-update

JB ★★★★★ ()

Re: Debian GNU/Linux, kernel 2.6.26-1-686 & vmware6

У меня это ядро вообще не запустилось)) Че то типа mv_ahci_hack и система виснет, не успев загрузиться. Так что тебе повезло еще))

LokiAs2 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.