LINUX.ORG.RU

не работает VLC


0

0

В общем такая проблема: VLC запускается,но невозможно открыть диалоговые окна любые типа File open и т.п.
В консоли пишет:
sansan88@sansan88:~> vlc
VLC media player 0.8.6d Janus
[00000289] main dialogs provider error: no dialogs provider module matched "any"
[00000286] skins2 interface error: no suitable dialogs provider found (hint: compile the wxWidgets plugin, and make sure it is loaded properly)
[00000286] skins2 interface: skin: VLC Media Player author: JoeTheZombie
[00000482] main dialogs provider error: no dialogs provider module matched "any"
[00000286] skins2 interface error: no suitable dialogs provider found (hint: compile the wxWidgets plugin, and make sure it is loaded properly)
[00000483] main dialogs provider error: no dialogs provider module matched "any"
[00000286] skins2 interface error: no suitable dialogs provider found (hint: compile the wxWidgets plugin, and make sure it is loaded properly)


что такое wxvidgets plugin и где его взять?

Re: не работает VLC

1) поставить wxwidgets с сайта http://www.wxwidgets.org/

2) перекомпилировать vlc

или, если за тебя компилировал кто-то другой, выяснить, куда он положил /usr/lib/vlc/gui/libwxwidgets_plugin.so

AEP ★★★★★ ()
Ответ на: Re: не работает VLC от AEP

Re: не работает VLC

поставил wxX11-2.8.7 с вышеуказаного сайта. поставилось.
плагин лежит по указаному пути как положено, а прога все равно пишет то же самое.

Не могу поставить VLC из исходников, спотыкается при компилировании ffmpeg и вылетает с ошибкой.


if gcc -DHAVE_CONFIG_H -I. -I. -I../../.. -DSYS_LINUX -I../../../include `top_builddir="../../.." ../../../vlc-config --cflags builtin pic ffmpeg` -Wsign-compare -Wall -pipe -MT libffmpeg_a-demux.o -MD -MP -MF ".deps/libffmpeg_a-demux.Tpo" -c -o libffmpeg_a-demux.o `test -f 'demux.c' || echo './'`demux.c; \
then mv -f ".deps/libffmpeg_a-demux.Tpo" ".deps/libffmpeg_a-demux.Po"; else rm -f ".deps/libffmpeg_a-demux.Tpo"; exit 1; fi
demux.c: In function ‘OpenDemux__ffmpeg’:
demux.c:191: warning: comparison between signed and unsigned
if gcc -DHAVE_CONFIG_H -I. -I. -I../../.. -DSYS_LINUX -I../../../include `top_builddir="../../.." ../../../vlc-config --cflags builtin pic ffmpeg` -Wsign-compare -Wall -pipe -MT libffmpeg_a-mux.o -MD -MP -MF ".deps/libffmpeg_a-mux.Tpo" -c -o libffmpeg_a-mux.o `test -f 'mux.c' || echo './'`mux.c; \
then mv -f ".deps/libffmpeg_a-mux.Tpo" ".deps/libffmpeg_a-mux.Po"; else rm -f ".deps/libffmpeg_a-mux.Tpo"; exit 1; fi
mux.c: In function ‘OpenMux__ffmpeg’:
mux.c:136: error: incompatible types in assignment
mux.c: In function ‘CloseMux__ffmpeg’:
mux.c:160: warning: comparison between signed and unsigned
make[6]: *** [libffmpeg_a-mux.o] Error 1
make[6]: Leaving directory `/home/sansan88/1111111111/vlc-0.8.6d/modules/codec/ffmpeg'
make[5]: *** [all-modules] Error 1
make[5]: Leaving directory `/home/sansan88/1111111111/vlc-0.8.6d/modules/codec/ffmpeg'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/sansan88/1111111111/vlc-0.8.6d/modules/codec'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/home/sansan88/1111111111/vlc-0.8.6d/modules/codec'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/sansan88/1111111111/vlc-0.8.6d/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/sansan88/1111111111/vlc-0.8.6d'




при установке rpm пишет что
freefont is needed by vlc-0.8.6d-9.1.i586
libavahi-client.so.3 is needed by vlc-0.8.6d-9.1.i586
libavahi-common.so.3 is needed by vlc-0.8.6d-9.1.i586
libmatroska.so.0 is needed by vlc-0.8.6d-9.1.i586
libvcdinfo.so.0 is needed by vlc-0.8.6d-9.1.i586
libvcdinfo.so.0(VCDINFO_0) is needed by vlc-0.8.6d-9.1.i586


но с --nodeps иставится запускается, вот только интерфейс не работает.

sansan88 ()
Ответ на: Re: не работает VLC от sansan88

Re: не работает VLC

Судя по зависимостям мандрива :) Поставь зависимости :) точнее из вышеуказанного freefont и avahi. И забудь о --nodeps, зависимости не зря придуманы, оно пишет без чего тебе никто не гарантирует работоспособность. Вот оно и не работает.

iRunix ★★★★ ()
Ответ на: Re: не работает VLC от iRunix

Re: не работает VLC

Суся 10.2. Поставлю проверю. Я почти все проги так ставлю, потому что они иногда требуют пакеты, которые им совершенно не нужны и их функциями я не пользуюсь, и все прекрасно работает. а вот этот нет.

Кстати я не могу установить WxGTK, где-то читал, что его тоже надо ставить вместе с WxX11.

sansan88 ()
Ответ на: Re: не работает VLC от sansan88

Re: не работает VLC

> mux.c:136: error: incompatible types in assignment

Это действительно имеет место с новыми версиями ffmpeg. В свое время я так и не нашел хорошего решения (патчить пришлось как VLC, так и ffmpeg). Рекомендую перейти на VLC из trunk - он собирается с новым ffmpeg на ура, но он не на wxGTK, а на Qt4.

AEP ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.