LINUX.ORG.RU

Русские буквы в консоли


0

0

Дистриб : ASPLinux 12.0

Локаль : ru_RU.UTF-8

когда я из иксов перехожу в консоль, ввожу логин, пароль то русские буквы выводятся нормально. Но если после этого перейти в иксы а потом вернутся обратно в консоль, то все русские буквы становятся крокозябрами(и это происходит со всеми активными сеансами). В консоли команда reset не помогает. Но если в консоли запустить еще один bash то буквы опять восстанавливаются. Также помогает logout

как исправить положение?

при переходе из одной консоли в другую ничего подобного не наблюдается

anonymous

Re: Русские буквы в консоли

Обновить драйвера nVidia или делать setsysfont

birdie ★★★★★ ()

Re: Русские буквы в консоли

Драйвера nVidia свежескаченные последней версии. В Xorg прописано nvidia. Не помогает

делать setsysfont каждый раз при переходе на виртуальный терминал? как это автоматизировать?

неужели все дело в кривых дровах от нвидиа?

anonymous ()
Ответ на: Re: Русские буквы в консоли от anonymous

Re: Русские буквы в консоли

У меня проблема как-то сама решилась ... может ещё ядро обновить?

А может я вру - я просто сто лет уже русских букв у себя в консоли не видел.

В крайнем случае можно сделать так: alias a='/sbin/setsysfont' :-)

birdie ★★★★★ ()

Re: Русские буквы в консоли

алиас это конечно круто но все равно что-то надо будет вводить

а какой скрипт/программа выполняется при переходе с одного вирт. терминала на другой? Может туда как-то дописать setsysfont.

Это дрова нвидии виноваты? просто на том же компе стоит OpenSuse 10.2 тоже с дровами от нвидии (там версия дров более старая или такая же) и там русские шрифты в консоли не сбрасываются!

downgrade драйвера делать не хочу.

anonymous ()

Re: Русские буквы в консоли

Не, я хочу чтобы ничего не надо было вводить в консоли. Чтобы вообще не сбрасывались шрифты, или при переходе из иксов на какой-нибуть виртуальный терминал эти шрифты автоматически восстанавливались

наверно прийдется пересобирать ядро...

Только вот мотивации не хватает... вот если бы у меня звук не работал ....

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.