LINUX.ORG.RU

Проблема с Иксами


0

0

Итак рассказываю всю историю. Был рабочий Gentoo Ядро 2.6.23 Не ставились дрова Нвидиа. Причину нашел оказалось требовались новые дрова (100.14.23 на тот момент экспериментальные, а может и сейчас еще)

Потребовалось мне перекомпилить ядро. Но с дуру я забыл сначало удалить дрова. Иксы не пусканулись. И я ПОСТАВИЛ дрова еще раз! И тут началась веселуха!

Итак проблема При старте иксов появляется фон сеточка! и мышка.. И все висим. Варианты дров nv и vesa дают тот же результат. %(

Но и это еще не все!

Беру другой винт ставлю генту с Лайв сиди с её ядром настраиваю УТФ-8 ру и emerge xorg-server Вроде все настроил, но тут у мня выпал глаз! Все тоже самое! Хотя дров на Нвидиа еще не ставил.

И конец этой саги вот в чем. Дергаю свой Гфорс ФХ 5500 (первое что пришло в голову он сдох просто) ставлю 2 мх 400 и что вы думаете? А ничего не меняется!

Скажите что может быть

З.Ы.: Пишу с работы, так что логи сейчас не выкину. Только если вечером.

Ответ на: Re: Проблема с Иксами от Unforgiven

Re: Проблема с Иксами

Ставил через SH, но это в первый раз.

А когда уже с нуля ставил то дрова Нвидиа не ставил еще!!! Иксы даже на vesa не стартуют!!!

Dimantchick ()

Re: Проблема с Иксами

Похоже, что с иксами-то проблемы никакой и нет. Если появляется фон в сеточку и мышка, то получается, что иксы запустились. Может быть не запускается gdm/kdm/или что там у тебя установлено?

sarulezzz ()

Re: Проблема с Иксами

Я перекомпиливал ядро без сноса дров под дебьяном - всё ок, именно пришлось дрова поставить ещё раз потом.

Вот инструкция по инсталлу дров под убунтой:

Остановите X-Server:
sudo /etc/init.d/gdm stop

4. Запустите инсталлятор драйверов (из каталога куда вы их сохранили) от имени root:
sudo -s -H
sh NVIDIA-Linux-XXX-X.X-XXX-pkg1.run
Вместо NVIDIA-Linux-XXX-X.X-XXX-pkg1.run вы указываете точное имя пакета с драйверами, которые вы скачали с официального сайта.
5. Инсталлятор ругнётся на отсутствие precompiled headers для вашего ядра и предложит скачать их с сервера nVidia. Откажитесь. Он предложит скомпилировать их сам - соглашайтесь.

6. Если все прошло успешно, то по окончанию установки вам предложать запустить утилиту nvidia-xonfig. Откажитесь!

7. Сделайте копию конфигурационного файла X-сервера.
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

8. Отредактируйте файл xorg.conf.
sudo gedit /etc/X11/xorg.conf

Найдите строку Section “Device”, а чуть ниже нее строку Driver “nv”. Последнюю измените на Driver “nvidia”. Можете так же добавить в эту же секцию строку Option “NoLogo” “TRUE”, чтобы при загрузке X-сервера не появлялся логотип nVidia (некоторых это раздражает).
В результате эта часть файла должна быть похожа на это:
Section "Device"
Identifier “NVIDIA Corporation NV43 [GeForce 6600 GT]”
Driver “nvidia”
Option “NoLogo” “TRUE”
BusID “PCI:1:0:0″
EndSection

В разделе Section “Module” закомментируйте (или удалите) строки Load “dri” и Load “GLCore”. И добавьте в этот же раздел строку Load “glx”, если она отсутствует.
Эта часть файла должна быть похожа на это:
Section "Module"
Load “i2c”
Load “bitmap”
Load “ddc”
#Load “dri”
Load “extmod”
Load “freetype”
Load “glx”
Load “int10″
Load “type1″
Load “vbe”
EndSection

9. Перезапустите X-сервер:
sudo /etc/init.d/gdm start

Попробуй чтоли перставить ещё разок...

Greshnik ()
Ответ на: Re: Проблема с Иксами от Xellos

Re: Проблема с Иксами

В общем нашел я кое что. Трабл со шрифтами или чем-то подобным. Ради прикола поставил с Лайф сиди. Вместе с иксами. И Чудо! Запустилось! Но. Стоило настроить русскую локаль. Глюк. В общем эт не в системе глюки. Эт я где-то что-то забыл сделать просто походу! Вот на выходных посижу доки внимательно почитаю. Подумаю. Ну и наверное сделаю %) Наверное теперь уже можно ставить не Лайф Сиди инсталляшкой а так %) Нормальную систему...

Всем спасибо.

Dimantchick ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.