LINUX.ORG.RU

fcitx, ацикличное переключение раскладки

 


0

1

Всем привет, у меня 3 раскладки ru, en, chinese. Я настроил чтобы переключение на ru, chinese был отдельные сочетания клавиш. Но как сделать чтобы ctrl+space только на английскую и не переключалась на предыдущую выбранную ru или chinese? Просто если у меня выбрана английская раскладка я машинально прожимаю ctrl+space и получаю не то чего хочу. Это напрягает. Кто знает как это можно реализовать? у меня только Х и awesome wm, а за переключение отвечает сабж.

Спасибо всем за помощь. Давил 4 раскладку, а основную не трогаю костыль, а что делать =)

Тебе поможет LoLo Switcher.

А вот как его конфигурять:

https://webhamster.ru/site/page/index/articles/projectcode/181

Можешь сделать 3 раскладки, и включать их напрямую по нужным тебе конфигурациям клавиш. А можешь сделать переключение «вкруговую», но тебе этого, видимо, не надо.

Xintrea ★★★★★
()
Ответ на: комментарий от token_polyak

Вроде как их мирят:

Как помирить fcitx и переключение раскладки по CapsLock в KDE?

Настройки → Дополнения → ☑Дополнительно → X Keyboard Integration → ☐ Allow to Override System XKB Settings. Перезапустить fcitx при необходимости.

Xintrea ★★★★★
()
Ответ на: комментарий от Xintrea

Хм, у меня работает и без отключения этой опции. Просто в fcitx стоит в качестве дефолта «Keyboard - English», а вторым IME — Mozc для японского. Русский/английский переключаются дефолтной KDE-шной переключалкой, японский — включением IME по Meta+Space. Работает везде, кроме, почему-то, стимовского чата — для него приходится выгружать fcitx при необходимости.

alegz ★★★★
()
31 октября 2022 г.

Решил этот вопрос тем что в Global Conifg -> Hotkey -> Inactive Input Method -> "нужная комбинация. А Trigger Input Method очистить. И будет щастье без дополнительной 4 раскладки =)

SmilePlz
() автор топика
Последнее исправление: SmilePlz (всего исправлений: 1)