LINUX.ORG.RU

Не определяется верный DPI монитора, как исправить?

 ,


1

1

Арч
Крыса
Блоб Нвидии

Выдает бред:
xdpyinfo | grep -B 2 resolution
screen #0:
dimensions: 2560x1440 pixels (677x381 millimeters)
resolution: 96x96 dots per inch

Все мелкое, реальный ж dpi почти 109

И это щ не все, теперь при включении выдает пустой рабочий стол, ничего сделать нельзя, чинится сбросом Иксов. И ведь ничего не менялось, кроме монитора

Хконфига нет, оно «депрекатед», да и толку от него нет, только проблемы

★★

Ответ на: комментарий от Ros

Ну так задай в настройках XFCE 4. Это, правда, затронет только размеры шрифтов, но если сразу после применения денек отдохнуть от монитора, то травма от PPI твоего прошлого монитора должна выветриться. Не 60 же у тебя там было.

t184256 ★★★★★ ()
Ответ на: комментарий от Ros

Не работает ни черта через настройки, только на гуй ГТК распространяется, Кути и сайты внутри Огнелиса в 96 остаются

Ну дык. У кутей и сайтов внутри огнелиса свои крутилки.

Вот было б у тебя 192 PPI, было бы проще. Такая ручка уже много где есть.

t184256 ★★★★★ ()
Ответ на: комментарий от t184256

Установил dpi 109 в Иксы и фонтконфиг - полностью не помогает:

xrdb -query | grep dpi
Xft.dpi: 109

xdpyinfo | grep -B 2 resolution
screen #0:
dimensions: 2560x1440 pixels (677x381 millimeters)
resolution: 96x96 dots per inch

В Лисе на сайтах мелкое всё

Ros ★★ ()
Последнее исправление: Ros (всего исправлений: 1)
Ответ на: комментарий от Ros

У кутей переменную окружения надо выставить с коэффициентом масштабирования. Забыл точно какая переменная, что-то вроде qt_scale но не точно, там в названии вроде три слова, а не два. Думаю нагуглишь

anonymous ()
Ответ на: комментарий от Ros
$ cat /etc/X11/xorg.conf.d/20-monitor.conf
Section "Monitor"
    Identifier "<default monitor>"
    DisplaySize 451 254
EndSection
$ xdpyinfo | grep -B2 resolution
screen #0:
  dimensions:    3840x2160 pixels (451x254 millimeters)
  resolution:    216x216 dots per inch

Также работает и с dpi флагом.

e1nste1n ★★★★★ ()
Ответ на: комментарий от Ros

Если загружаться перестает смотри логи. Также там же:

Note: If you are using the proprietary NVIDIA driver, you may have to put Option «UseEdidDpi» «FALSE» under Device or Screen section to make it take effect.

https://wiki.archlinux.org/index.php/Xorg#Proprietary_NVIDIA_driver

У меня и с нблобом работало, сейчас под рукой нет проверить.

e1nste1n ★★★★★ ()