LINUX.ORG.RU

как поставить mpv с deb-multimedia.org?

 , , ,


0

1

cat /etc/apt/sources.list.d/multimedia.list

# multimedia
deb http://www.deb-multimedia.org buster main non-free

cat /etc/apt/apt.conf.d/99enable-unsecure-repos

# Acquire::Check-Valid-Until "false";
Acquire::AllowInsecureRepositories "true";
# Acquire::AllowDowngradeToInsecureRepositories "true";

apt-get update

apt-get install -t deb-multimedia mpv

Reading package lists... Done
E: The value 'deb-multimedia' is invalid for APT::Default-Release as such a release is not available in the sources
★★★★

apt-get install -t deb-multimedia mpv

Reading package lists... Done E: The value 'deb-multimedia' is invalid for APT::Default-Release as such a release is not available in the sources

Ну правильно. deb-multimedia это не выпуск, а репозиторий. На что apt-get и намекнул.

nebularia ()

Плюс ещё dist-upgrade надо сделать как тут написано. А версии из deb-multimedia сами должны по дефолту подтягиваться... Вроде. Рядом дебиана нет, тем более с такими репами. Посмотри, какую он версию собирается ставить, deb-multimedia имеют приставку dmo.

nebularia ()
Ответ на: комментарий от nebularia

Не знаю, что делает /etc/apt/apt.conf.d/99enable-unsecure-repos, но пакеты должны появиться если прописать репу в sources.list и обновить индексы.

Далее по умолчанию будут использованы те версии, номер версии которых выше. Но у дебианов есть механизм установки приоритетов реп. Не помню как именно называется, но с Acquire::AllowInsecureRepositories «true»; точно никак не связан. Так вот, этот механизм надо нагуглить, примерно понять и выставить приоритет на пакеты из deb-multimedia.org

kirill_rrr ★★★★★ ()

Да, а ещё можно не указывать приоритеты реп, а выбрать версию данного конкретного пакета и зафиксировать. В разных пакетных менеджерах по разному, в synaptic просто из главного меню.

kirill_rrr ★★★★★ ()