LINUX.ORG.RU

Debian как безопасно удалить мета пакет?

 ,


1

1

Решил немного полениться и при установке debian выбрал plasma desktop, думал вычищу все не нужно и будет проще и быстрее, чем ставить все нужное на пустую систему...оказалось что нет. например удаление Akregator тянет за собой kde-standart, который по сути сносит весь kde. Как можно безопасно удалить этот kde-standart и подобные чтобы не мешались?


Ответ на: комментарий от anonymous

пробовал, не помогает

root@debian:~# apt-mark manual akregator
akregator was already set to manually installed.
root@debian:~# apt-get remove akregator
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  ant ant-contrib ant-optional apper apper-data ca-certificates-java coinor-libcbc3 coinor-libcgl1 coinor-libclp1 coinor-libcoinmp1v5 coinor-libcoinutils3v5 coinor-libosi1v5 cups-pk-helper default-jre default-jre-headless espeak-ng-data firebird3.0-common
  firebird3.0-common-doc firebird3.0-server-core firebird3.0-utils fonts-crosextra-caladea fonts-crosextra-carlito fonts-liberation2 fonts-linuxlibertine fonts-opensymbol fonts-sil-gentium fonts-sil-gentium-basic gir1.2-atk-1.0 gir1.2-atspi-2.0 gir1.2-freedesktop
  gir1.2-gdkpixbuf-2.0 gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gtk-3.0 gir1.2-notify-0.7 gir1.2-pango-1.0 gir1.2-polkit-1.0 gir1.2-secret-1 gir1.2-wnck-3.0 hyphen-en-us java-common kaccessible kdeaccessibility kmag kmousetool kmouth libabw-0.1-1
  libactivation-java libao-common libao4 libaopalliance-java libapache-poi-java libapache-pom-java libargs4j-java libasm-java libatinject-jsr330-api-java libatk-adaptor libatk-wrapper-java libatk-wrapper-java-jni libbase-java libbcmail-java libbcpkix-java
  libbcprov-java libboost-date-time1.67.0 libboost-filesystem1.67.0 libboost-locale1.67.0 libbrlapi0.6 libbsh-java libcdi-api-java libcdr-0.1-1 libcglib-java libclucene-contribs1v5 libclucene-core1v5 libcmis-0.5-5v5 libcodemodel-java libcommons-cli-java
  libcommons-codec-java libcommons-collections3-java libcommons-collections4-java libcommons-compress-java libcommons-io-java libcommons-lang3-java libcommons-logging-java libcommons-math3-java libcommons-parent-java libcurvesapi-java libdom4j-java libdotconf0
  libdtd-parser-java libe-book-0.1-1 libehcache-java libel-api-java libeot0 libepubgen-0.1-1 libespeak-ng1 libetonyek-0.1-1 libexttextcat-2.0-0 libexttextcat-data libfastinfoset-java libfbclient2 libflute-java libfonts-java libformula-java libfreehand-0.1-1
  libgeronimo-annotation-1.3-spec-java libgeronimo-interceptor-3.0-spec-java libguava-java libguice-java libharfbuzz-icu0 libhawtjni-runtime-java libhsqldb1.8.0-java libhttpclient-java libhttpcore-java libib-util libicu4j-java libintellij-annotations-java
  libistack-commons-java libitext-java libjansi-java libjansi-native-java libjaxb-api-java libjaxb-java libjaxen-java libjcommon-java libjdom1-java libjetbrains-annotations-java libjsoup-java libjsp-api-java libjsr305-java libkf5syndication5abi1 liblangtag-common
  liblangtag1 liblayout-java libloader-java liblog4j1.2-java liblouis-data liblouis17 libmail-java libmaven-file-management-java libmaven-parent-java libmaven-resolver-java libmaven-shared-io-java libmaven-shared-utils-java libmaven3-core-java libmhash2 libmspub-0.1-1
  libmwaw-0.3-3 libmythes-1.2-0 libneon27-gnutls libnumbertext-1.0-0 libnumbertext-data libodfgen-0.1-1 liborcus-0.14-0 libpagemaker-0.0-0 libpangoxft-1.0-0 libpcaudio0 libpentaho-reporting-flow-engine-java libpixie-java libplexus-archiver-java libplexus-cipher-java
  libplexus-classworlds-java libplexus-component-annotations-java libplexus-interpolation-java libplexus-io-java libplexus-sec-dispatcher-java libplexus-utils2-java libpq5 libqaccessibilityclient-qt5-0 libqxp-0.0-0 libraptor2-0 librasqal3 librdf0
  librelaxng-datatype-java libreoffice libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-help-common libreoffice-help-en-us
  libreoffice-impress libreoffice-java-common libreoffice-kde5 libreoffice-librelogo libreoffice-math libreoffice-nlpsolver libreoffice-report-builder libreoffice-report-builder-bin libreoffice-script-provider-bsh libreoffice-script-provider-js
  libreoffice-script-provider-python libreoffice-sdbc-firebird libreoffice-sdbc-hsqldb libreoffice-sdbc-postgresql libreoffice-style-breeze libreoffice-style-colibre libreoffice-style-tango libreoffice-wiki-publisher libreoffice-writer librepository-java
  librevenge-0.0-0 librngom-java libsac-java libsaxonhe-java libserializer-java libservlet-api-java libservlet3.1-java libsisu-guice-java libsisu-inject-java libsisu-ioc-java libsisu-plexus-java libslf4j-java libsnappy-java libsnappy-jni libsonic0 libspeechd2
  libstaroffice-0.0-0 libstax-ex-java libstreambuffer-java libtxw2-java libvisio-0.1-1 libwagon-http-java libwagon-provider-api-java libwebsocket-api-java libwnck-3-0 libwnck-3-common libwpd-0.10-10 libwpg-0.3-3 libwps-0.4-4 libxerces2-java libxml-commons-external-java
  libxml-commons-resolver1.1-java libxml-java libxmlbeans-java libxmlsec1 libxmlsec1-nss libxom-java libxres1 libxsom-java libxz-java libyajl2 libzmf-0.0-0 lp-solve mythes-en-us node-normalize.css openjdk-11-jre openjdk-11-jre-headless orca polkit-kde-1 python3-brlapi
  python3-cairo python3-cups python3-cupshelpers python3-gst-1.0 python3-louis python3-pyatspi python3-smbc python3-speechd python3-uno python3-xdg sound-icons speech-dispatcher speech-dispatcher-audio-plugins speech-dispatcher-espeak-ng system-config-printer
  system-config-printer-common system-config-printer-udev uno-libs3 ure xbrlapi
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  akregator kde-standard task-kde-desktop
0 upgraded, 0 newly installed, 3 to remove and 44 not upgraded.
After this operation, 6,530 kB disk space will be freed.
Do you want to continue? [Y/n] 

Kolins ()
Последнее исправление: Kolins (всего исправлений: 1)
Ответ на: комментарий от Kolins

apt install ant ant-contrib ant-optional apper apper-data ca-certificates-java coinor-libcbc3 coinor-libcgl1 coinor-libclp1 coinor-libcoinmp1v5 coinor-libcoinutils3v5 coinor-libosi1v5 cups-pk-helper default-jre default-jre-headless espeak-ng-data firebird3.0-common firebird3.0-common-doc firebird3.0-server-core firebird3.0-utils fonts-crosextra-caladea fonts-crosextra-carlito fonts-liberation2 fonts-linuxlibertine fonts-opensymbol fonts-sil-gentium fonts-sil-gentium-basic gir1.2-atk-1.0 gir1.2-atspi-2.0 gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gtk-3.0 gir1.2-notify-0.7 gir1.2-pango-1.0 gir1.2-polkit-1.0 gir1.2-secret-1 gir1.2-wnck-3.0 hyphen-en-us java-common kaccessible kdeaccessibility kmag kmousetool kmouth libabw-0.1-1 libactivation-java libao-common libao4 libaopalliance-java libapache-poi-java libapache-pom-java libargs4j-java libasm-java libatinject-jsr330-api-java libatk-adaptor libatk-wrapper-java libatk-wrapper-java-jni libbase-java libbcmail-java libbcpkix-java libbcprov-java libboost-date-time1.67.0 libboost-filesystem1.67.0 libboost-locale1.67.0 libbrlapi0.6 libbsh-java libcdi-api-java libcdr-0.1-1 libcglib-java libclucene-contribs1v5 libclucene-core1v5 libcmis-0.5-5v5 libcodemodel-java libcommons-cli-java libcommons-codec-java libcommons-collections3-java libcommons-collections4-java libcommons-compress-java libcommons-io-java libcommons-lang3-java libcommons-logging-java libcommons-math3-java libcommons-parent-java libcurvesapi-java libdom4j-java libdotconf0 libdtd-parser-java libe-book-0.1-1 libehcache-java libel-api-java libeot0 libepubgen-0.1-1 libespeak-ng1 libetonyek-0.1-1 libexttextcat-2.0-0 libexttextcat-data libfastinfoset-java libfbclient2 libflute-java libfonts-java libformula-java libfreehand-0.1-1 libgeronimo-annotation-1.3-spec-java libgeronimo-interceptor-3.0-spec-java libguava-java libguice-java libharfbuzz-icu0 libhawtjni-runtime-java libhsqldb1.8.0-java libhttpclient-java libhttpcore-java libib-util libicu4j-java libintellij-annotations-java libistack-commons-java libitext-java libjansi-java libjansi-native-java libjaxb-api-java libjaxb-java libjaxen-java libjcommon-java libjdom1-java libjetbrains-annotations-java libjsoup-java libjsp-api-java libjsr305-java libkf5syndication5abi1 liblangtag-common liblangtag1 liblayout-java libloader-java liblog4j1.2-java liblouis-data liblouis17 libmail-java libmaven-file-management-java libmaven-parent-java libmaven-resolver-java libmaven-shared-io-java libmaven-shared-utils-java libmaven3-core-java libmhash2 libmspub-0.1-1 libmwaw-0.3-3 libmythes-1.2-0 libneon27-gnutls libnumbertext-1.0-0 libnumbertext-data libodfgen-0.1-1 liborcus-0.14-0 libpagemaker-0.0-0 libpangoxft-1.0-0 libpcaudio0 libpentaho-reporting-flow-engine-java libpixie-java libplexus-archiver-java libplexus-cipher-java libplexus-classworlds-java libplexus-component-annotations-java libplexus-interpolation-java libplexus-io-java libplexus-sec-dispatcher-java libplexus-utils2-java libpq5 libqaccessibilityclient-qt5-0 libqxp-0.0-0 libraptor2-0 librasqal3 librdf0 librelaxng-datatype-java libreoffice libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-help-common libreoffice-help-en-us libreoffice-impress libreoffice-java-common libreoffice-kde5 libreoffice-librelogo libreoffice-math libreoffice-nlpsolver libreoffice-report-builder libreoffice-report-builder-bin libreoffice-script-provider-bsh libreoffice-script-provider-js libreoffice-script-provider-python libreoffice-sdbc-firebird libreoffice-sdbc-hsqldb libreoffice-sdbc-postgresql libreoffice-style-breeze libreoffice-style-colibre libreoffice-style-tango libreoffice-wiki-publisher libreoffice-writer librepository-java librevenge-0.0-0 librngom-java libsac-java libsaxonhe-java libserializer-java libservlet-api-java libservlet3.1-java libsisu-guice-java libsisu-inject-java libsisu-ioc-java libsisu-plexus-java libslf4j-java libsnappy-java libsnappy-jni libsonic0 libspeechd2 libstaroffice-0.0-0 libstax-ex-java libstreambuffer-java libtxw2-java libvisio-0.1-1 libwagon-http-java libwagon-provider-api-java libwebsocket-api-java libwnck-3-0 libwnck-3-common libwpd-0.10-10 libwpg-0.3-3 libwps-0.4-4 libxerces2-java libxml-commons-external-java libxml-commons-resolver1.1-java libxml-java libxmlbeans-java libxmlsec1 libxmlsec1-nss libxom-java libxres1 libxsom-java libxz-java libyajl2 libzmf-0.0-0 lp-solve mythes-en-us node-normalize.css openjdk-11-jre openjdk-11-jre-headless orca polkit-kde-1 python3-brlapi python3-cairo python3-cups python3-cupshelpers python3-gst-1.0 python3-louis python3-pyatspi python3-smbc python3-speechd python3-uno python3-xdg sound-icons speech-dispatcher speech-dispatcher-audio-plugins speech-dispatcher-espeak-ng system-config-printer system-config-printer-common system-config-printer-udev uno-libs3 ure xbrlapi

👌😎

stasolog ()
Ответ на: комментарий от stasolog

Ну изврат же, должен быть способ проще. Вот точно помню что давным давно, в debian 5 (была аналогичная ситуация, только с kde 3) ничего такого не было и пакеты входящие в метапакет прекрасно удалялись отдельно.

Kolins ()
Ответ на: комментарий от Cyka

Ты поставил полную систему с кде., чем тебе Akregator мешает? Праздный интерес есличе.

Ну да, но я хочу убрать лишнее. Раньше наоборот ставил minimum, а потом руками нужное из kde, теперь пошел другим путем ради интереса.

Конкретно вместо Akregator использую QuiteRSS , а Thunderbird вместо KMail тут уже вкусовщина.

Kolins ()
Последнее исправление: Kolins (всего исправлений: 1)