LINUX.ORG.RU

Помогите убрать ШГ

 , ,


0

2

Шрифты выглядят так: https://i.postimg.cc/kgDPpdnj/2020-02-10-011833-121668527.png

  1. create /etc/fonts/local.conf
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <match>
        <edit mode="prepend" name="family"><string>Noto Sans</string></edit>
    </match>
    <match target="pattern">
        <test qual="any" name="family"><string>serif</string></test>
        <edit name="family" mode="assign" binding="same"><string>Noto Serif</string></edit>
    </match>
    <match target="pattern">
        <test qual="any" name="family"><string>sans-serif</string></test>
        <edit name="family" mode="assign" binding="same"><string>Noto Sans</string></edit>
    </match>
    <match target="pattern">
        <test qual="any" name="family"><string>monospace</string></test>
        <edit name="family" mode="assign" binding="same"><string>Noto Mono</string></edit>
    </match>
</fontconfig>
  1. create ~/.gtkrc-2.0
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle="hintsfull"
gtk-xft-rgba="rgb"

create ~/.config/gtk-3.0/settings.ini

gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle=hintsfull
gtk-xft-rgba=rgb
  1. ~/.Xresources
Xft.autohint: 1
Xft.antialias: 1
Xft.hinting: true
Xft.hintstyle: hintsfull
Xft.rgba: rgb
Xft.lcdfilter: lcddefault

  1. Делаем симлинк
sudo ln -s /etc/fonts/conf.avail/10-hinting-full.conf /etc/fonts/conf.d/10-hinting-full.conf
★★★★