LINUX.ORG.RU

Winebox

 ,


0

2

Привет!

В связи с некоторыми ломающими переменами на альтернативно-оффтопных осях, отломился и вайн со всякими старыми-добрыми увеселениями.

Чтобы как-то обойти это дерьмо, возникла мысль, что можно паковать нужный софт в образы виртуалбокса с каким-нибудь Puppy Linux и вайном внутри по аналогии с докером - стартуешь виртуалку, а там в иксах сразу запускается нужная софтина. Гасишь софтину - вырубается виртуалка.

И вот собственно вопрос, может такое дерьмо кто-то уже до меня придумал и автоматизировал и самому костылить нет нужды и можно взять готовое? Сходу что-то не нагуглилось, к сожалению.

Ответ на: комментарий от te111011010

Ну вот как-то так вышло, шо третьих героев почему-то пока не портировали:)

УПД. Знаю про vcmi, с ним всё ок, но нужен актуальный HotA, в котором есть нормальный централизованный сетевой режим без сношений с хамачами.

mega_venik ★★★ ()
Последнее исправление: mega_venik (всего исправлений: 1)
Ответ на: комментарий от goingUp

Дуалбут это долго и уныло, и отрыв от налаженного рабочего процесса. Даже просто запускать виртуалку и в ней ещё что-то запускать как-то невесело.

Хочется запускать прозрачно, просто как нативную приложуху, пусть и с вагоном прослоек внутри.

mega_venik ★★★ ()

Чтобы как-то обойти это дерьмо, возникла мысль, что можно паковать нужный софт в образы виртуалбокса с каким-нибудь Puppy Linux и вайном внутри по аналогии с докером - стартуешь виртуалку, а там в иксах сразу запускается нужная софтина. Гасишь софтину - вырубается виртуалка.

А вообще хорошая идея.

torvn77 ★★★★★ ()
Ответ на: комментарий от mega_venik

Могу дать системд юнит, который стартует иксовую прогу

[Unit]
Description=OpenKiosk browser

[Service]
Environment=DISPLAY=:0
User=openkiosk
Group=openkiosk
ExecStart=/usr/bin/xinit /opt/openkiosk/openkiosk

[Install]
WantedBy=multi-user.target

Выключения нет. В /etc/X11/Xwrapper.config должно быть
allowed_users=anybody
needs_root_rights=yes

Это немного костыльный момент, но я не исправлял.

goingUp ★★★★★ ()
Ответ на: комментарий от te111011010

Да вот есть один говнософт прошивочный (UFS Suite, CycloneBox и т.д.), который и под фейлдовсами-то современными не пашет, не то что под мракосью. Пришлось водружать 32-битную ХРень на виртуалбокс. И отключать эту виртуалку от инета. Во избежание.

anonymous ()
Ответ на: комментарий от mega_venik

Ну вот как-то так вышло, шо третьих героев почему-то пока не портировали:)

третьих героев на linux вообще-то портировали ещё когда ты пешком под стол ходил

buratino ★★★★★ ()