LINUX.ORG.RU

Выбор расширения для установки программы в tails

 , ,


0

1

Доброго времени суток, какое расширение нужно скачивать для установки в эту ОС. Из папки с набором версий тру крипта для разных ОС из архива tar.gz вылез нормальный тру крипт. Скачал отсюда https://code-industry.net/free-pdf-editor/#get архив с названием master-pdf-editor-5.4.20-qt5.amd64.tar.gz но то что распаковалось не устанавливается. Через судо апдейт как я понял она не появится, да я хочу чтобы она была всегда под рукой, чтоб апдейт не нужно было делать после запуска тейлс. Мне нужен пдф эдитор хороший, чтобы распознавал шрифты и т.д. Libre Draw не распознал в пдф шрифт, не знаю как шрифт определить и где скачать, решил годную прогу скачать..но..

Несложно догадаться, что master-pdf-editor-5.4.20-qt5.amd64.tar.gz это архив с набором файлов программы, его надо распаковать в /opt (можно в другое место, но тогда придётся править .desktop файл). Примерно так: https://i.ibb.co/SvNTC6h/2019-06-08-10-47-37.png

Далее, если архив распакован в /opt, нужно просто скопировать .desktop файл из директории с программой в /usr/share/applications. Примерно так: https://i.ibb.co/bRDhLvC/2019-06-08-11-01-40.png

rbh-17m ()

Tails же в родстве с debian? Там предлагают скачать пакет deb и его нужно будет устанавливать — «нe, не подходит» ©

Ладно... скачал архив c программой... ну бери и пользуйся... или снова  — «нe, не подходит» ©? Там внутри программа (устанавливать не нужно), «ярлык» для запуска и разное программе необходимое...

Вам бы что-нибудь популярное про линуксы почитать, а Вы сразу Tails «осваиваете» :(

anymouze ★★ ()
Последнее исправление: anymouze (всего исправлений: 1)

Tails же в родстве с debian? Там предлагают скачать пакет deb и его нужно будет устанавливать — «нe, не подходит» ©

Ладно... скачал архив c программой... ну бери и пользуйся... или снова — «нe, не подходит» ©? Там внутри программа (устанавливать не нужно), «ярлык» для запуска и разное программе необходимое...

архив распаковываю, не запускает прога, как выше написал человек, ее оказывается надо в орt закинуть. Для дебиана качал тоже, не устанавливается через рут терминал, как тру крипт. Если поток идей иссяк, мб другие помогут.

Несложно догадаться, что master-pdf-editor-5.4.20-qt5.amd64.tar.gz это архив с набором файлов программы, его надо распаковать в /opt (можно в другое место, но тогда придётся править .desktop файл). Примерно так: https://i.ibb.co/SvNTC6h/2019-06-08-10-47-37.png

Далее, если архив распакован в /opt, нужно просто скопировать .desktop файл из директории с программой в /usr/share/applications. Примерно так: https://i.ibb.co/bRDhLvC/2019-06-08-11-01-40.png

Скопировать в папку opt не получается, это же Tails не дает записать в системную директорию. Даже скриншот не пойму как загрузить, при выборе файла через сайт пишет доступ запрещен.

amnesia@amnesia:~/Загрузки$  sudo tar -xvf master-pdf-editor-5.4.20-qt5.amd64.tar.gz /opt
[sudo] пароль для amnesia: 
tar: /opt: Не найден в архиве
tar: Завершение работы с состоянием неисправности из-за возникших ошибок
root@amnesia:~# ~/Загрузки$  sudo tar -xvf master-pdf-editor-5.4.20-qt5.amd64.tar.gz /opt
bash: /root/Загрузки$: Нет такого файла или каталога

tenpix ()
Ответ на: комментарий от rbh-17m

скопировал но...

после попыток скопировать в папку opt вылезла справка по команде -cp скопировал я эту папку в opt но файлов там нет... это как так. что сделать чтобы уже установить эту прогу. Ну поищу другую какую нибудь, раз эта задача никому не по зубам.

tenpix ()