LINUX.ORG.RU

みんなさん, Востоковеды KDEшники, отзовитесь!

 ,


0

2

С тех пор, как я сменил ubuntu14.04 на manjaro KDE я так и не смог найти альтернативу ibus-anthy для ввода кан и иероглифов на ромадзи с перебором вариантов по пробелу.
Вроде бы в KDE есть вся поддержка, но простое добавление третьего языка jp ничего не даёт - перепробовал все варианты ввода, вводится или латиница, или сразу хирагана без трансформации в кандзи. Не появляется никакого дополнительного значка в лотке для настройки, никакой документации по горячим клавишам, при переходе на jp раскладку с неё уже не уйти по назначенной комбинации клавиш в системе, только стандартной комбинацией от KDE (ctrl~alt~k) или мышью.
По возможности я бы хотел настроить всё в пределах стандартной переключалки, она меня всем устраивает, и городить костыли не хотелось бы.
Если ли тут хотя бы один практик, который настроил всё на кедах?

Настраивал ввод через mozc по первым ссылкам в гугле. По alt-shift переключение ru-en, по win-space распознавание ромадзи в английской раскладке. Японского в списке раскладок у меня нет.

Хардварной клавиатурой с каной ни разу в жизни не пользовался, как её готовить не скажу.

Myau ★★★★ ()
Ответ на: комментарий от hikikomori

я не могу настроить это говно. При запуске fcitx блокируется стандартная переключалка manjaro_kde, по иконке которой достаточно кликнуть для смены языка, без ПКМ и выбора из меню. В fcitx даже выбором из меню никакой другой язык не выбрать. Ни ниппонского, ни русского. Метод ввода mozc добавил, но он не выбирается. Сколько его из контекстного меню не выбирай, остаётся другой выбор. ЧЯДНТ?

hikikomori ★★ ()
Ответ на: комментарий от anonymous

Вы лукавите. В 199% на десктоп мы ставим дистро с DE, а не голую систему. Смена десктопа это переустановка настроенного дистрибутива наголо. Никто не будет вырезать вручную одно DE и ставить другой, и решать все вытекающие глюки.

Метод ввода KDE меня устраивает всем, кроме непонимания с японским. А вы предлагаете менять шило на мыло, чтобы не устраивало всё, кроме японского?

hikikomori ★★ ()
Ответ на: комментарий от anonymous

там выводом чуть не придавило, что grep`ать?

вот например

$ fcitx-diagnose | grep "Не удалось"
    **Не удалось найти модуль метода ввода fcitx для Qt4.**
        **Не удалось найти fcitx в выводе `/usr/bin/gtk-query-immodules-2.0`**
        **Не удалось найти fcitx im модуль для gtk 2.**
        **Не удалось найти fcitx в выводе `/usr/bin/gtk-query-immodules-3.0`**
        **Не удалось найти fcitx im модуль для gtk 3.**
        **Не удалось найти fcitx в immodules-кэше в `/usr/lib/gtk-2.0/2.10.0/immodules.cache`**
        **Не удалось найти im-модуль fcitx для gtk 2 в кэше.**
        **Не удалось найти fcitx в immodules-кэше в `/usr/lib/gtk-3.0/3.0.0/immodules.cache`**
        **Не удалось найти im-модуль fcitx для gtk 3 в кэше.**


пока fcitx запущен, работает только латиница.
И никаким способом не выбрать другой пункт. Выбираю, вхужу в меню снова - выбор прежний..
https://pp.userapi.com/c849032/v849032451/1a48c3/o8lJ50Tij8g.jpg

hikikomori ★★ ()
Последнее исправление: hikikomori (всего исправлений: 1)
Ответ на: комментарий от hikikomori

Лучше глазами прочесть вывод, особенно начиная с секции Frontends setup. Не так уж и много там всего, и ошибки сразу хорошо видны — вывод цветной же.

И сами эти модули вообще установлены? https://wiki.archlinux.org/index.php/Fcitx#Input_method_module

anonymous ()
Ответ на: комментарий от anonymous

Установлены. Пробовал по-разному, но ничего как описал выше в методах ввода не выбрать.

Сейчас так:

fcitx-diagnose | grep "Не удалось"
    **Не удалось найти xim_server в окне суперпользователя.**
    **Не удалось найти модуль метода ввода fcitx для Qt4.**

$ yaourt -S fcitx-qt4
ошибка: не найдена цель: fcitx-qt4

$ yaourt -S fcitx-qt5
предупреждение: fcitx-qt5-1.2.3-7 не устарел -- переустанавливается

hikikomori ★★ ()
Последнее исправление: hikikomori (всего исправлений: 1)
Ответ на: комментарий от hikikomori

Во-первых, прекрати истерить. Во-вторых, fcitx переключает метод ввода только если курсор стоит в каком-либо поле ввода. В-третьих, проверь что стоит в system settings - personalization - regional settings - input method - global config - hotkey - trigger input method.

Log_in ()
Ответ на: комментарий от Log_in

Не вижу, где тут вам истерика показалась. И незачем держать за дебила, все тесты проводились в активном поле ввода.

В regional settings у меня НЕТ input method, только Languagge Formats SpellCheck и Date&Time.

hikikomori ★★ ()
Ответ на: комментарий от CryNet

Товарищи, без японского ввода я как гайдзин на ромадзи вынужен писать( Проблема обычная, просто рукожопая переключалка ввода иероглифических языков в кедах по дефолту.

hikikomori ★★ ()
Ответ на: комментарий от hikikomori

падежный указатель

Интересная формулировка.

проблема с методом ввода

Когда очень надо, но метода ввода нет, можно использовать google translate. Там у них своя реализация на скриптах.

i-rinat ★★★★★ ()
Последнее исправление: i-rinat (всего исправлений: 1)
Ответ на: комментарий от hikikomori

почему кандзями не пишите?

Потому что не знаю. Очевидно же.

или как настроить метод ввода в kde?

Без понятия, к сожалению. Несколько лет назад мне надо было тестить методы ввода в приложении, и я ставил разные, uim, fcitx и ibus. Ради интереса пробовал настроить их так, чтобы было три языка ввода, в том числе русский и английский. Но толком так и не осилил. Можно было переключаться CapsLock’ом между русским и английским, и Alt-Space’ом между английским и японским. Жесть, в общем. Но мне не надо было на постоянной основе, так что до конца не довёл.

Мне кажется, что для настройки нужно убрать все языки ввода в DE, и настраивать их только в методе ввода. Если я правильно помню, ближайшее к юзабельному у меня получилось на IBus + Anthy.

i-rinat ★★★★★ ()
Ответ на: комментарий от hikikomori

Если нет input method, значит не установлен модуль kde-config-fcitx (или как он там в манжаро называется). Значит смотри настройки в том fcitx-ui, который у тебя установлен. УМВР в kubuntu 18.04. Да, должны быть прописаны переменные окружения

export XMODIFIERS="@im=fcitx"
export QT_IM_MODULE=fcitx
export GTK_IM_MODULE=fcitx
export XIM=fcitx
Log_in ()
Ответ на: комментарий от Log_in


Я ранее ставил пакеты fcitx-mozc и kcm-fcitx, но пункт не появлялся. Разбегаются глаза, сколько всего, и что выбрать теперь?

yaourt -Ss fcitx |grep community/
community/fcitx 4.2.9.6-2 (fcitx-im)
community/fcitx-anthy 0.2.3-1
community/fcitx-chewing 0.2.3-2
community/fcitx-cloudpinyin 0.3.6-2
community/fcitx-configtool 0.4.10-3
community/fcitx-googlepinyin 0.1.6-6
community/fcitx-gtk2 4.2.9.6-2 (fcitx-im)
community/fcitx-gtk3 4.2.9.6-2 (fcitx-im)
community/fcitx-hangul 0.3.1-2
community/fcitx-kkc 0.1.4-1
community/fcitx-libpinyin 0.5.3-2
community/fcitx-m17n 0.2.4-1
community/fcitx-mozc 2.23.2815.102-3
community/fcitx-qt5 1.2.3-7 (fcitx-im)
community/fcitx-rime 0.3.2-2
community/fcitx-sayura 0.1.2-1
community/fcitx-skk 0.1.4-1
community/fcitx-sunpinyin 0.4.2-1
community/fcitx-table-extra 0.3.8-1
community/fcitx-table-other 0.2.4-1
community/fcitx-ui-light 0.1.3-4
community/fcitx-unikey 0.2.7-2
community/fcitx5 0.0.0.20181128-1
community/fcitx5-chinese-addons 0.0.0.20181104-1
community/fcitx5-gtk 0.0.0.20180920-1
community/fcitx5-qt 0.0.0.20181104-1
community/kcm-fcitx 0.5.5-2



grepнул, потому что в aur ещё всякого дофига.


p.s. А переменные зачем, без них не аллё?

hikikomori ★★ ()
Ответ на: комментарий от i-rinat

Мне кажется, что для настройки нужно убрать все языки ввода в DE, и настраивать их только в методе ввода.



Вот это как раз не нравится.. Всем устраивает стандартная переключалка, там есть японский, почему он не работает? Возможно его можно настроить, а не менять ноги на высокотехнологические протезы?

Если я правильно помню, ближайшее к юзабельному у меня получилось на IBus + Anthy.



Так я и настраивал в убунту1404. А тут что-то не очень получается.

hikikomori ★★ ()
Ответ на: комментарий от hikikomori

Я спросил у гугуру-сан, и он сказал, что нужно поставить fcitx fcitx-mozc kde-config-fcitx, и тогда настройки появятся: http://www.ubuntubuzz.com/2017/09/kubuntu-writing-japanese-kanji-hiragana.html

Даже попробовал в свежей виртуалке накатить (debian testing), но как-то криво получилось опять. en-ru переключаются по capslock, но метод ввода нужно включать по ctrl-shift.

i-rinat ★★★★★ ()
Последнее исправление: i-rinat (всего исправлений: 1)
Ответ на: комментарий от i-rinat

Это решение для дебиан стайл дистро...
Вот интересно, откуда такой бестиарий вариантов и зачем?

Пока поставил:

yaourt -Ss fcitx |grep installed
community/fcitx 4.2.9.6-2 (fcitx-im) [installed]
community/fcitx-anthy 0.2.3-1 [installed]
community/fcitx-configtool 0.4.10-3 [installed]
community/fcitx-mozc 2.23.2815.102-3 [installed]


В regional settings по-прежнему НЕТ input method, только Languagge Formats SpellCheck и Date&Time.

hikikomori ★★ ()
Последнее исправление: hikikomori (всего исправлений: 2)
Ответ на: комментарий от hikikomori

В regional settings по-прежнему НЕТ input method

Там kde’шные компоненты нужны, в дебиан-лайк это kde-config-fcitx. Пакет исходного кода называется kcm-fcitx, у тебя же такой есть?

i-rinat ★★★★★ ()
Последнее исправление: i-rinat (всего исправлений: 1)
Ответ на: комментарий от i-rinat

Я пока даже метода ввода не вижу в системе...

А насчёт jp, то у меня в бубунте было три раскладки, на jp латиницей вводил ромадзи и конвертировал их в кандзи. Просто на латинице такое не работало.

hikikomori ★★ ()
Ответ на: комментарий от hikikomori

Попробовал я это твоё Manjaro KDE поставить в виртуалке. Это какая-то жесть. Какие-то затупы, мышь как в желе двигается. Не думал, что меня может выбесить интерфейс, но вот оказалось, что может. И да, метод ввода включить не получилось.

i-rinat ★★★★★ ()