LINUX.ORG.RU

Процессор на ноутбуке не хочет в максимальную частоту

 , ,


1

1

Процессор:
https://www.notebook-center.ru/processor_614.html
https://pastebin.com/QNvws2wu

выставил профиль performance.
cpufreq-set -g performance -c 0
915 sudo cpufreq-set -g performance -c 1
и т.д. для всех ядер.
тоже не помогло. ну тут логично, сколько сказал sudo cpufreq-info, столько и ставит.
это специфика турбобуста, только для него проц может поднимать частоту до 3.2, в реале только 2.3 что ли?

Ответ на: комментарий от anonymous

кстати, в биосе даже настроек для турбобуста и процессора нет. асус, мать его.

darkenshvein ★★★★★ ()

Во-первых, «В связи с выходом ядер версии 3.5 и выше, cpufrequtils устарели и больше не используются», используй cpupower frequency-info, она умеет показывать boost states.

Во-вторых, ты не написал свою систему. TurboCore включили в ядрах с 3.16, а тебя кто ж знает, может ты на Ubuntu 14.04 сидишь, а там 3.13.

gremlin_the_red ★★★★★ ()

Как бы с чего ты взял, что у тебя BAPM включен? На твоей железки не будет никакого буста. Либо он может глючить. у тебя ж вроде модуль radeon на видяхе? radeon.bapm=1 для amdgpu amdgpu.bapm=1

Вообще lspci -k мне интересно посмотреть что там интеграшка. МОжет помочь такая конструкция: radeon.si=0 radeon.cik=0 amdgpu.si=1 amdgpu.cik=1

как бы там HSA и старые процессоры не очень допилили.

Deleted ()

Я наоборот отключаю турбобуст на своем ноуте (меньше шума).

Делаю по такой схеме:

sudo apt install msr-tools sudo nano /usr/local/bin/turboff.sh

#!/bin/bash modprobe msr echo "0" | tee /sys/devices/system/cpu/cpufreq/boost

sudo chmod +x /usr/local/bin/turboff.sh

Подгружаю с помошью systemd сервиса. Если подставите в echo «1» , возможно получите обратный эффект.

ne-on ()
Ответ на: комментарий от ne-on

Я наоборот отключаю турбобуст на своем ноуте (меньше шума).

ну я бы рад, но ска, браузеры зело жирные и им явно не хватает даже 2.3 ггц, отзывчивость уеба2.0 плохая

darkenshvein ★★★★★ ()
Ответ на: комментарий от darkenshvein

Balanced Automatic Power Management - переброс мощности между видео и процом. Это ж APU и там HSA. Грубо говоря, если ты грузишь видяху - проц уходит в троттлинг, чтоб не вылезти за теплопакет.

Deleted ()
Ответ на: комментарий от darkenshvein

Ты что-то не так делаешь. У меня на 1.5-1.8 ГГц нормально бегает по полста вкладок.

Deleted ()
Ответ на: комментарий от Deleted

Да, посмотрел что за проц. Был у меня такой, там VLIW в APU, так что amdgpu мимо. radeon.bapm=1 и работать будет коряво.

Deleted ()
Ответ на: комментарий от ne-on

На самом деле, у AMD ещё интереснее в MSR. Там можно частоты для каждого P-STATE задать и напряжения, и в некоторых случаях они ни хреново так гонятся. А чаще всего интерес представляет андервольтинг (в ноутах даёт не хилое понижение температуры, а значит, и буст чаще и дольше).

Deleted ()
Ответ на: комментарий от Deleted

Вообще lspci -k мне интересно посмотреть что там интеграшка

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Trinity [Radeon HD 7660G]
Subsystem: ASUSTeK Computer Inc. Trinity [Radeon HD 7660G]
Kernel driver in use: radeon
Kernel modules: radeon


01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series] (rev ff)
Kernel driver in use: radeon
Kernel modules: radeon

darkenshvein ★★★★★ ()
Ответ на: комментарий от gremlin_the_red

тоже 2.3

susdeb:~$ cpupower frequency-info
analyzing CPU 0:
driver: acpi-cpufreq
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: 4.0 us
hardware limits: 1.40 GHz - 2.30 GHz
available frequency steps: 2.30 GHz, 2.00 GHz, 1.80 GHz, 1.60 GHz, 1.40 GHz
available cpufreq governors: conservative userspace powersave ondemand performance schedutil
current policy: frequency should be within 1.84 GHz and 2.00 GHz.
The governor «performance» may decide which speed to use
within this range.
current CPU frequency: Unable to call hardware
current CPU frequency: 2.00 GHz (asserted by call to kernel)
boost state support:
Supported: yes
Active: yes

darkenshvein ★★★★★ ()
Ответ на: комментарий от darkenshvein

ты заставил меня гуглить какого то монобрового мальчика. нет, кара как наказание.

chenbr0 ()
Ответ на: комментарий от Deleted

прописал в параметрах граб. то же самое. а не. субъективно шуметь больше стал.
А cpupower frequency-info такая же строчка после перезагрузки.
Процессор на ноутбуке не хочет в максимальную частоту (комментарий)

darkenshvein ★★★★★ ()
Ответ на: комментарий от darkenshvein

странно, даже в дмесг никакх дополнительно строк и уведомлений кроме как в начале про этот барм

darkenshvein ★★★★★ ()
Ответ на: тоже 2.3 от darkenshvein

Что ты хотел если даже в ядро уже хуанг протащил свой гейворкс. Все адекватные люди уже перешли на свободную haiku.

anonymous ()
Ответ на: тоже 2.3 от darkenshvein

Supported: yes
Active: yes

Ну так работает. Мне только не нравится строчка

current policy: frequency should be within 1.84 GHz and 2.00 GHz.

Это кто такую полиси устраивает? Если лайв последней убунты попробовать, то же будет или как?

gremlin_the_red ★★★★★ ()
Ответ на: комментарий от Thero

ЕМНИП даже если турбобуст и починили

А его ломали?

его индикацию утилитами нет

В посте, на который ты отвечаешь, явно видна успешная индикация утилитами.

gremlin_the_red ★★★★★ ()

In other words, if Turbo Core is disabled in the BIOS, the patched radeon will not turn it on.

похоже, эти пи***ы из асус таким образом решили проблему перегрева. надо попробывать откатить или обновить бивиса.

darkenshvein ★★★★★ ()
Ответ на: комментарий от darkenshvein

Ну они могли и ещё интереснее поступить. В целом AMD на всех архитектурах до Zen искуственно душатся в энергопотреблении. Мне, например, буст оставили, но при некоторых случаях частота падала до 1,5 - чего я избежал модификацией СО.

Deleted ()
Ответ на: комментарий от gremlin_the_red

там нет турбобуста. динамическое изменение частот в пределах штатной частоты не имеет ничего общего с тем что называется турбобуст. и насколько я помню даже когда турбобуст работал cpufreq его не опознавал..

Thero ★★★★★ ()
Ответ на: комментарий от gremlin_the_red

ок. значит отображение пофиксили, а турбокор таки биосом порезан..

Thero ★★★★★ ()
Ответ на: комментарий от Thero

Фантазёра ответ. Фантазёрам хочется, чтобы их воображаемый мир был вместо реальности.

anonymous ()

короче. решил. кака?
типично линуксовым способом - пересобрал ядро:
https://askubuntu.com/questions/459788/how-to-enable-amd-turbo-core-on-ubuntu...
вдруг ссылка того, поэтому опишу подробнее.
скачал свежую ванильку
нашёл там drivers/gpu/drm/radeon/trinity_dpm.c

To enable it, open this file, find this line:

pi->enable_bapm = false;
Change false to true,


поменял все значения со строками false на true. возможно, это неправильно, т.к. там было несколько строк.
ну и собственно, всё. make-kpkg&dpkg -i
никаких bapm и прочего в грабе прописывать не надо.
gkrellm сразу начал показывать сильно выше 2.3 ггц, чем было до этого, да и, собственно, команда cpufreq-aperf тоже приближалась уже к 2.9. уже видно,что работает. Проц греется поболее. 3.2 Не вижу, эх, обман, везде обман.
https://img.izy.cloud/prsp00uy7w.png

darkenshvein ★★★★★ ()
Ответ на: комментарий от darkenshvein

watch cpupower monitor - вот эта команда нихрена не работает, ничего толком не кажет.
ещё поковырялся. возможно с 2.9 помогла до 3 ггц по показателям эта команда. а может и плацебо, дальше ленива ковыряться. энивей, надо пересобирать ядро. для моего а10-4600м точно. ноут асус к55д.
sudo cpupower -c all frequency-set -u 3200MHz

darkenshvein ★★★★★ ()

кстати, на низких частотах рыжая отвратительно себя ведёт, хром гораздо лучше и отзывчивее реагирует.

darkenshvein ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.