LINUX.ORG.RU

Помогите с настройкой локали в Manjaro

 , ,


1

1

Нужна помощь!!! Поставил значит Манджару (установка на русском языке), обновил и установил языковые пакеты. Только теперь у меня пол. системы на англоцком, а половина на русском. запускаю Долфин через

LC_ALL=ru_RU.UTF8 dolphin
весь на русском (стало быть, сама локализация установлена). Пытаюсь установить программку из АУРа, пишет мол

bsdtar не может определить локаль

приходится ставить через терминал, предварительно задав

export LC_ALL=C
уже и в /etc/locale.conf вручную локаль прописывал - ноль эмоций...
LANG=ru_RU.UTF-8
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL="ru_RU.UTF-8"
при запуске sudoedit, в терминале пишет

sonnet.core: No language dictionaries for the language: «ru_RU»

locale

locale: Невозможно установить LC_ALL в локаль по умолчанию.: Нет такого файла или каталога
LANG=ru_KZ.UTF-8
LC_CTYPE=ru_RU.UTF-8
LC_NUMERIC=ru_KZ.UTF-8
LC_TIME=ru_KZ.UTF-8
LC_COLLATE=ru_RU.UTF-8
LC_MONETARY=ru_KZ.UTF-8
LC_MESSAGES=ru_RU.UTF-8
LC_PAPER=ru_RU.UTF-8
LC_NAME=ru_RU.UTF-8
LC_ADDRESS=ru_RU.UTF-8
LC_TELEPHONE=ru_RU.UTF-8
LC_MEASUREMENT=ru_KZ.UTF-8
LC_IDENTIFICATION=ru_RU.UTF-8
LC_ALL=

locale -a

C
en_US.utf8
POSIX
ru_RU.utf8

DE - Plasma5 Уже второй час с этим мучаюсь...

убери из LC_ALL= LC_COLLATE запись. LC_ALL=пустое должно LC_COLLATE=C Правильно

LANG="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE=C
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS=ru_RU.UTF-8
LC_TELEPHONE=ru_RU.UTF-8
LC_MEASUREMENT=ru_RU.UTF-8
LC_IDENTIFICATION=ru_RU.UTF-8
LC_ALL=

в /etc/locale.gen

en_US.UTF-8 UTF-8  
ru_RU.UTF-8 UTF-8

и генерируешь локаль

sudo locale-gen

В настройках DE также выставляешь русский

anonymous ()
Ответ на: комментарий от Kapshibergen

Короче, удалось русифицировать (правда, кое-где еще английский). Удалил ~/.config/plasma-locale-settings.sh и ~/.config/plasma-localerc. После перезагрузки, утилиты показали что локаль не выбрана, соответственно после выбора локали, на этот раз заработало.

Kapshibergen ()