LINUX.ORG.RU

Ошибка при установке VirtualBox-5,2 в Fedora 29

 ,


0

1

При запуске .rpm, скачанного с офсайта открывается центр приложений, нажимаю установить, появляется ошибка «Не удалось установить VirtualBox-5.2: Could not depsolve transaction; 1 problem detected:». Пробовал запустить i386 и amd64 результат одинаковый, в минте виртуалка работает без проблем. В репозиториях VirtualBox не нашёл, подключены RPM Fusion и Russian Fedora кроме тестовых. Подскажите, в чём может быть проблема?

А ты ставь не как обезьяна, а в консоли (rpm -i или как там принято в федоре), если не прокатит скопируй сюда выхлоп.

WitcherGeralt ★★ ()
Последнее исправление: WitcherGeralt (всего исправлений: 1)
Ответ на: комментарий от WitcherGeralt

предупреждение: VirtualBox-5.2-5.2.20_125813_fedora26-1.x86_64.rpm: Заголовок V4 DSA/SHA1 Signature, key ID 98ab5139: NOKEY ошибка: Неудовлетворенные зависимости: libvpx.so.4()(64bit) нужен для VirtualBox-5.2-5.2.20_125813_fedora26-1.x86_64

dr_boogie ()
Ответ на: комментарий от WitcherGeralt

У тебя дебиан олдстейбл, или убунта 12.04, или где там ещё apt не научился ставить пакеты из файла вместе с зависимостями, что надо это руками делать?

gasinvein ★★★ ()
Ответ на: комментарий от gasinvein

Так я не знаю, что выше и написал, как в федоре правильно поставить.

WitcherGeralt ★★ ()
Ответ на: комментарий от gasinvein

Это какая убунта не умела в зависимости? Слака там, очевидно же.

Deleted ()
Ответ на: комментарий от gasinvein

Ищи лучше, VirtualBox в RPM Fusion есть.

Да есть, через терминал установилось, спасибо, но почему-то в результатах поиска в центре приложений нет(( или это нормально для федоры не отображать в результатах поиска приложения из RPM Fusion?

dr_boogie ()
Ответ на: комментарий от dr_boogie

Это нормально для центра приложений гнома. Он показывает только то, для чего есть надлежащие метаданные - видимо, для виртуалбокса rpmfusion их не добавили. Напиши багрепорт, принеси пользу.

gasinvein ★★★ ()
Ответ на: комментарий от gasinvein

apt не научился

А он что, научился? В 16.04 вроде не умел.

Deleted ()
Ответ на: комментарий от MikeWortin

Проверил у себя - отображается в списке «установленные» после установки. Не установленный не находится поиском.

gasinvein ★★★ ()
Ответ на: комментарий от WitcherGeralt

dnf install rpm-package установит пакет с разрешением зависимостей.

anonymous ()

Зачем нужен VirtualBox когда есть virt-manager/kvm?

anonymous ()
Ответ на: комментарий от StellzZz

У тебя ещё ошибка в версии в названии темы

В чём ошибка? Справка - О программе: «Графический интерфейс VirtualBox Версия 5.2.20_RPMFusion r125587» Просто пока не был установлен в поиске его не находило при любом написании, после установки находит с отметкой «установлен».

dr_boogie ()

При запуске .rpm, скачанного с офсайта открывается центр приложений
Пробовал запустить i386 и amd64 результат одинаковый

Зачем тебе федора, мамкин хакер?

В репозиториях VirtualBox не нашёл
подключены RPM Fusion и Russian Fedora

Так в родных репозиториях вообще почти ничего нет, так что повторю вопрос - зачем тебе федора?

rpm -i

Низкоуровневый инструмент, как и dpkg. В убунте gdebi ставит с зависимостями, в федоре хз, погугли.

anonymous ()
Ответ на: комментарий от anonymous

Зачем тебе федора

Чтобы пользоваться! Что не понятно - нагуглю, что не смогу нагуглить тут спрошу, не вижу никакой проблемы в этом.

dr_boogie ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.