LINUX.ORG.RU

Минимальная установка ktorrent в debian 8.8 jessie xfce

 , , , ,


0

1

Как установить ktorrent в debin 8.8 jessie с графическим окружением xfce без установки рекомендуемых и новых пакетов, включая vlc и тд.

Это, мне кажется, мне не нужно:

sudo aptitude install --without-recommends ktorrent
Следующие НОВЫЕ пакеты будут установлены:        
  fonts-freefont-ttf{a} kate-data{a} katepart{a} kde-runtime{a} kde-runtime-data{a} kdelibs-bin{a} kdelibs5-data{a} 
  kdelibs5-plugins{a} kdoctools{a} ktorrent ktorrent-data{a} liba52-0.7.4{a} libattica0.4{a} libbasicusageenvironment0{a} libcddb2{a} 
  libchromaprint0{a} libdbusmenu-qt2{a} libdlrestrictions1{a} libdvbpsi9{a} libebml4{a} libexiv2-13{a} libfam0{a} 
  libfreerdp-cache1.1{a} libfreerdp-client1.1{a} libfreerdp-codec1.1{a} libfreerdp-common1.1.0{a} libfreerdp-core1.1{a} 
  libfreerdp-crypto1.1{a} libfreerdp-gdi1.1{a} libfreerdp-locale1.1{a} libfreerdp-primitives1.1{a} libfreerdp-rail1.1{a} 
  libfreerdp-utils1.1{a} libgles1-mesa{a} libgles2-mesa{a} libgpgme++2{a} libgroupsock1{a} libiodbc2{a} libiso9660-8{a} 
  libkactivities6{a} libkatepartinterfaces4{a} libkcmutils4{a} libkde3support4{a} libkdeclarative5{a} libkdecore5{a} libkdesu5{a} 
  libkdeui5{a} libkdewebkit5{a} libkdnssd4{a} libkemoticons4{a} libkfile4{a} libkhtml5{a} libkio5{a} libkjsapi4{a} libkjsembed4{a} 
  libkmediaplayer4{a} libknewstuff3-4{a} libknotifyconfig4{a} libkntlm4{a} libkparts4{a} libkpty4{a} libkrosscore4{a} 
  libktexteditor4{a} libktorrent-l10n{a} libktorrent5{a} libkworkspace4abi2{a} libkxmlrpcclient4{a} liblivemedia23{a} libmatroska6{a} 
  libmtp-common{a} libmtp9{a} libnepomuk4{a} libnepomukquery4a{a} libnepomukutils4{a} libnl-route-3-200{a} libntrack-qt4-1{a} 
  libntrack0{a} libphonon4{a} libplasma3{a} libpolkit-qt-1-1{a} libpostproc52{a} libproxy-tools{a} libpulse-mainloop-glib0{a} 
  libqca2{a} libqt4-dbus{a} libqt4-declarative{a} libqt4-designer{a} libqt4-opengl{a} libqt4-qt3support{a} libqt4-script{a} 
  libqt4-sql{a} libqt4-svg{a} libqt4-xmlpatterns{a} libqtwebkit4{a} libresid-builder0c2a{a} libsdl-image1.2{a} libsidplay2{a} 
  libsolid4{a} libsoprano4{a} libstreamanalyzer0{a} libstreams0{a} libsyndication4{a} libthreadweaver4{a} libusageenvironment1{a} 
  libvcdinfo0{a} libvlc5{a} libvlccore8{a} libvncclient0{a} libwinpr-crt0.1{a} libwinpr-crypto0.1{a} libwinpr-dsparse0.1{a} 
  libwinpr-environment0.1{a} libwinpr-file0.1{a} libwinpr-handle0.1{a} libwinpr-heap0.1{a} libwinpr-input0.1{a} 
  libwinpr-interlocked0.1{a} libwinpr-library0.1{a} libwinpr-path0.1{a} libwinpr-pool0.1{a} libwinpr-registry0.1{a} 
  libwinpr-rpc0.1{a} libwinpr-sspi0.1{a} libwinpr-synch0.1{a} libwinpr-sysinfo0.1{a} libwinpr-thread0.1{a} libwinpr-utils0.1{a} 
  libxcb-composite0{a} libxcb-keysyms1{a} libxcb-xv0{a} ntrack-module-libnl-0{a} oxygen-icon-theme{a} phonon{a} phonon-backend-vlc{a} 
  plasma-scriptengine-javascript{a} qdbus{a} qtchooser{a} soprano-daemon{a} vlc{a} vlc-data{a} vlc-nox{a} vlc-plugin-pulse{a} 
РЕКОМЕНДУЮТСЯ следующие пакеты, но автоматически они установлены НЕ БУДУТ:
  libkactivities-bin libmtp-runtime libqt4-sql-ibase libqt4-sql-mysql libqt4-sql-odbc libqt4-sql-psql libqt4-sql-sqlite 
  libqt4-sql-sqlite2 vlc-plugin-notify vlc-plugin-samba 
0 пакетов обновлено, 142 установлено новых, 0 пакетов отмечено для удаления, и 2 пакетов не обновлено.
Необходимо получить 87,3 MB/101 MB архивов. После распаковки 295 MB будет занято.

когда хочешь избавиться от лишнего, говори апту --no-install-recommends.
хотя я бы посоветовал qbittorrent.

Deleted ()

Как установить ktorrent в debin 8.8 jessie с графическим окружением xfce без установки рекомендуемых и новых пакетов, включая vlc и тд.

sudo apt-get install transmission-gtk

Это, мне кажется, мне не нужно:

Ты полностью прав. KDE-зависимости не только замедлят запуск системы, но ещё и могут её изнахратить:

http://i.imgur.com/VqlGohX.png

Будь с ними осторожен, не вляпайся в них.

EXL ★★★★★ ()

И да, KTorrent настолько никому не нужен, что в интернете нету AppImage с ним. Так что не советую использовать устаревшую программу. А вот с Transmisson всё есть:

https://bintray.com/probono/AppImages/Transmission#files

Красота. Скачал, запустил. Никаких зависимостей и прочего хлама.

EXL ★★★★★ ()
Последнее исправление: EXL (всего исправлений: 1)
Ответ на: комментарий от Deleted

когда хочешь избавиться от лишнего, говори апту --no-install-recommends.

Мне кажется не работает.

sudo apt-get install --no-install-recommends ktorrent Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Будут установлены следующие дополнительные пакеты: fonts-freefont-ttf kate-data katepart kde-runtime kde-runtime-data kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools ktorrent-data liba52-0.7.4 libattica0.4 libbasicusageenvironment0 libcddb2 libchromaprint0 libdbusmenu-qt2 libdlrestrictions1 libdvbpsi9 libebml4 libexiv2-13 libfam0 libfreerdp-cache1.1 libfreerdp-client1.1 libfreerdp-codec1.1 libfreerdp-common1.1.0 libfreerdp-core1.1 libfreerdp-crypto1.1 libfreerdp-gdi1.1 libfreerdp-locale1.1 libfreerdp-primitives1.1 libfreerdp-rail1.1 libfreerdp-utils1.1 libgles1-mesa libgles2-mesa libgpgme++2 libgroupsock1 libiodbc2 libiso9660-8 libkactivities6 libkatepartinterfaces4 libkcmutils4 libkde3support4 libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkpty4 libkrosscore4 libktexteditor4 libktorrent-l10n libktorrent5 libkworkspace4abi2 libkxmlrpcclient4 liblivemedia23 libmatroska6 libmtp-common libmtp9 libnepomuk4 libnepomukquery4a libnepomukutils4 libnl-route-3-200 libntrack-qt4-1 libntrack0 libphonon4 libplasma3 libpolkit-qt-1-1 libpostproc52 libproxy-tools libpulse-mainloop-glib0 libqca2 libqt4-dbus libqt4-declarative libqt4-designer libqt4-opengl libqt4-qt3support libqt4-script libqt4-sql libqt4-svg libqt4-xmlpatterns libqtwebkit4 libresid-builder0c2a libsdl-image1.2 libsidplay2 libsolid4 libsoprano4 libstreamanalyzer0 libstreams0 libsyndication4 libthreadweaver4 libusageenvironment1 libvcdinfo0 libvlc5 libvlccore8 libvncclient0 libwinpr-crt0.1 libwinpr-crypto0.1 libwinpr-dsparse0.1 libwinpr-environment0.1 libwinpr-file0.1 libwinpr-handle0.1 libwinpr-heap0.1 libwinpr-input0.1 libwinpr-interlocked0.1 libwinpr-library0.1 libwinpr-path0.1 libwinpr-pool0.1 libwinpr-registry0.1 libwinpr-rpc0.1 libwinpr-sspi0.1 libwinpr-synch0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 libwinpr-utils0.1 libxcb-composite0 libxcb-keysyms1 libxcb-xv0 ntrack-module-libnl-0 oxygen-icon-theme phonon phonon-backend-vlc plasma-scriptengine-javascript qdbus qtchooser soprano-daemon vlc vlc-data vlc-nox vlc-plugin-pulse Предлагаемые пакеты: djvulibre-bin finger icoutils libcanberra-pulse sound-theme-freedesktop plasma-widget-ktorrent krosspython libchromaprint-tools python-acoustid exiv2 fam freerdp-x11 iodbc hspell libqca2-plugin-cyrus-sasl libqca2-plugin-gnupg libqca2-plugin-ossl libqt4-declarative-folderlistmodel libqt4-declarative-gestures libqt4-declarative-particles libqt4-declarative-shaders qt4-qmlviewer libqt4-dev media-player-info phonon-backend-gstreamer phonon-backend-mplayer virtuoso-minimal videolan-doc libdvdcss2 Рекомендуемые пакеты: fonts-dejavu libkactivities-bin gnupg libmtp-runtime udev ca-certificates libqt4-sql-mysql libqt4-sql-odbc libqt4-sql-psql libqt4-sql-sqlite libqt4-sql-sqlite2 libqt4-sql-ibase udisks2 upower vlc-plugin-notify vlc-plugin-samba xdg-utils НОВЫЕ пакеты, которые будут установлены: fonts-freefont-ttf kate-data katepart kde-runtime kde-runtime-data kdelibs-bin kdelibs5-data kdelibs5-plugins kdoctools ktorrent ktorrent-data liba52-0.7.4 libattica0.4 libbasicusageenvironment0 libcddb2 libchromaprint0 libdbusmenu-qt2 libdlrestrictions1 libdvbpsi9 libebml4 libexiv2-13 libfam0 libfreerdp-cache1.1 libfreerdp-client1.1 libfreerdp-codec1.1 libfreerdp-common1.1.0 libfreerdp-core1.1 libfreerdp-crypto1.1 libfreerdp-gdi1.1 libfreerdp-locale1.1 libfreerdp-primitives1.1 libfreerdp-rail1.1 libfreerdp-utils1.1 libgles1-mesa libgles2-mesa libgpgme++2 libgroupsock1 libiodbc2 libiso9660-8 libkactivities6 libkatepartinterfaces4 libkcmutils4 libkde3support4 libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkfile4 libkhtml5 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkpty4 libkrosscore4 libktexteditor4 libktorrent-l10n libktorrent5 libkworkspace4abi2 libkxmlrpcclient4 liblivemedia23 libmatroska6 libmtp-common libmtp9 libnepomuk4 libnepomukquery4a libnepomukutils4 libnl-route-3-200 libntrack-qt4-1 libntrack0 libphonon4 libplasma3 libpolkit-qt-1-1 libpostproc52 libproxy-tools libpulse-mainloop-glib0 libqca2 libqt4-dbus libqt4-declarative libqt4-designer libqt4-opengl libqt4-qt3support libqt4-script libqt4-sql libqt4-svg libqt4-xmlpatterns libqtwebkit4 libresid-builder0c2a libsdl-image1.2 libsidplay2 libsolid4 libsoprano4 libstreamanalyzer0 libstreams0 libsyndication4 libthreadweaver4 libusageenvironment1 libvcdinfo0 libvlc5 libvlccore8 libvncclient0 libwinpr-crt0.1 libwinpr-crypto0.1 libwinpr-dsparse0.1 libwinpr-environment0.1 libwinpr-file0.1 libwinpr-handle0.1 libwinpr-heap0.1 libwinpr-input0.1 libwinpr-interlocked0.1 libwinpr-library0.1 libwinpr-path0.1 libwinpr-pool0.1 libwinpr-registry0.1 libwinpr-rpc0.1 libwinpr-sspi0.1 libwinpr-synch0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 libwinpr-utils0.1 libxcb-composite0 libxcb-keysyms1 libxcb-xv0 ntrack-module-libnl-0 oxygen-icon-theme phonon phonon-backend-vlc plasma-scriptengine-javascript qdbus qtchooser soprano-daemon vlc vlc-data vlc-nox vlc-plugin-pulse обновлено 0, установлено 142 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено. Необходимо скачать 87,3 MB/101 MB архивов. После данной операции, объём занятого дискового пространства возрастёт на 295 MB. Хотите продолжить? [Д/н] n

just_a_brake ()
Ответ на: комментарий от EXL

А вот с Transmisson красота.

А в нём можно смотреть видео при скачивании и управлять загрузкой/раздачей? Можно ли в Transmission создать очередь, ограничить скорость загрузки/раздачи для конкретного файла? Transmisson может автоматически начинать загрузку/раздачу в конкретные промежутки времени и выключать компьютер при завершении загрузки/раздачи?

just_a_brake ()

Используйте нормальные дистры, типа gentoo. Там это всё отключается.

RazrFalcon ★★★★★ ()
Ответ на: комментарий от RazrFalcon

Используйте нормальные дистры, типа gentoo. Там это всё отключается.

Хорошо

just_a_brake ()
Ответ на: комментарий от RazrFalcon

Лучше доставить гору зависимостей, чем осваивать генту. Имеет смысл возиться с генту, если интересно/много времени/есть желание всё очень заоптимизировать (экономить на спичках).

Deleted ()
Ответ на: комментарий от Deleted

Я хз, есть ли у ТС время. Я ему предлагаю решение.

экономить на спичках

Пруфца бы.

RazrFalcon ★★★★★ ()
Ответ на: комментарий от RazrFalcon

Пруфца бы.

основной пожиратель ресурсов на десктопе браузер, что-то я не видал историй успеха, заставляющих браузер жрать хотяб на 10% памяти с помощью пересборки сорцов и без потери стабильности.

Deleted ()

так не ставь ktorrent, если у тебя не кде

xmikex ★★★ ()
Ответ на: комментарий от xmikex

так не ставь ktorrent, если у тебя не кде

С xfce по умолчанию установлен ktorrent и он мне нравится.

just_a_brake ()
Ответ на: комментарий от xmikex

может не в xfce, а в твоем дистрибутиве?

В моём дистрибутиве (debian jessie ~8-8.8 xfce) ktorrent был установлен по умолчанию и после удаления vlc удалились значки, digikam, KCalc и ещё более ста пакетов. Дистрибутив был установлен через псевдографический интерфейс со звёздочкой напротив «стандартных программ», или чего-то подобного.

just_a_brake ()
Ответ на: комментарий от xmikex

может не в xfce, а в твоем дистрибутиве?

Возможно ktorrent был установлен мною, но мне кажется он был установлен по умолчанию. В любом случае, почему после удаления vlc удалились более ста пакетов, тот же digikam, KCalc?

just_a_brake ()
Ответ на: комментарий от just_a_brake

возможно ты неправильно удаляешь
ты уверен что удалял только vlc или vlc со всеми его зависимостями?

xmikex ★★★ ()
Ответ на: комментарий от xmikex

возможно ты неправильно удаляешь

ты уверен что удалял только vlc или vlc со всеми его зависимостями?

Vlc был удалён с помощью apt-get remove/purge, а потом мне apt предложил удалить «неиспользуемые» пакеты с помощью autoremove и уже после autoremove удалились эти 100 с лишним пакетов.

just_a_brake ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.