LINUX.ORG.RU

debian sid. сломался гном и гдм.

 , ,


0

1

полный dmesg

http://pastebin.com/fUMUNs5G

собственно, в конце ошибка

gnome-session-f[5034]: segfault at 0 ip 00007fe4f69f8a29 sp 00007fff36c153f0 error 4 in libgtk-3.so.0.2200.4[7fe4f6716000+6f7000]

debian sid x86_64, gnome 3.22

после чего такое случилось, точно сказать не могу, то ли мелкие обновления (mutter, libgtk-3), то ли потому что я захотел попробовать rt ядро собственно, ядро давно откатил на ванильное, mutter и libgtk-3 откатывал на предыдущую версию, менялся только адрес ошибки gmd3 совсем не стартует, а lightdm нормально, через него гном без верхней панели, у окон тоже нету панели с кнопками (закрыть, свернуть, развернуть)

драйвер нвидиа блоб 375.20, который тоже пробовал переустанавливать

примечательно, что с дровами из реп этой же версии графика не запускается, а вот через sgfxi, которым я обычно пользуюсь, хоть как-то

подскажите, в каком направлении копать? могло ли rt ядро так все подпортить? при том, что я его давно снес

с rt еще в dmesg постоянно что-то сыпало (чет не додумался сохранить)


Это ж gtk3. У меня (в debian stretch) приложения с gtk3 крашаться (eclipse, dia). Поэтому запускаю их, включая принудительно gtk2.

Zomba444ok ()
Ответ на: комментарий от milka

попробовал игру в стиме запустить, запустилась в маленьком окошке, а вокруг черный фон

milka ()
Ответ на: комментарий от dima1981

помочь ничем не могу, но с умным видом что-то ляпнуть обязан?

срачи иди устраивай где-нибудь в другом месте, а мне не до этого

milka ()
Ответ на: комментарий от milka

и еще вот

# dpkg-reconfigure gdm3
gdm.service is not active, cannot reload.
invoke-rc.d: initscript gdm3, action "reload" failed.
milka ()

что за странность такая? через lightdm gnome-shell без панелей (нереально пользоваться)

через gdm3 черный фон с мышкой, но стоило включить автовход и все работает как надо

milka ()

Рекомендую обратить внимание на stretch, там и софт местами поновее и постабильней должно быть.

Deleted ()
Ответ на: комментарий от Zomba444ok

Ничего не знаю, в том числе и dia на gnome3 в stretch работают нормально. Проверяй aptitude search '?obsolete' и вообще apt autoremove сделай и конфиги удалённых пакетов почисти(purge).

los_nikos ★★★★★ ()

А зачем именно debian sid? Это ведь сродни минному полю. На testing справляться с проблемами надо опыт иметь, а чтобы как в бункере чисто своими делами заниматься - это в stable. Но stretch уже сейчас прекрасен.

los_nikos ★★★★★ ()
Ответ на: комментарий от los_nikos

сид, потому что хочу более свежих пакетов, люблю новенький гном. а где-то в вики дебиана видел, что гном лучше тянуть с сида.

по поводу стабильности: очевидно, в сиде багов больше,но и сид живее, обновляется чаще, соответственно баги быстрее исправляются. я не утверждаю, что он стабилен, но в нем быстрее на баги реагируют, нежели в сиде

да и это 1й критический баг у меня на сиде (года 1.5 - 2 на нем), который, возможно, появился по моей вине. до этого только незначительные припоминаю.

если есть кто тут на сиде с гномом, любопытно было бы сверить ситуацию.

milka ()

только что проверил, libgtk-3 обновили, но проверять не хочу, лень)

milka ()
Ответ на: комментарий от milka

Уже написали ведь несколько команд

deborphan --show-priority
aptitude search '?obsolete' 
apt autoremove

По каждой команде смотри необходимые для системы пакеты, ищи им в репозиториях новую версию и удаляй старую, например вместо libreadline6 libreadline7. Или вообще удали ненужные программы.

los_nikos ★★★★★ ()

libmosjs обновили, поломали и уже починили. sid

kwinto ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.