LINUX.ORG.RU

Firefox 48.0 - Your connection is not secure

 ,


0

1

Мое предположение что возможно проблема в том что мой Debian Testing нуждается в апгрейде - я не обновлял его уже больше года с половиной может быть - не помню, новая версия Firefox хочет какое-то новое обновление для корректного функционирования. В общем как и в прошлый раз я использовал unstable репозиторий чтобы установить из него Firefox 48.0 в мой Testing и проблема с Firefox 48.0 в том что что он выдает «Your connection is not secure» когда я пытаюсь зайти на некоторые сайты - не просто некоторые сайты - Google, Youtube, Wikipedia и т.д. Однако без проблем получается зайти на многи е другие сайты как например на этот сайт/форум, Яндекс, и т.д. Мне интересно кто-нибудь сталкивался с этим, пробовал решить, или это отдельно проблема моей системы. Я особенно не видел в сети чтобы люди жаловались на такое.

Есть два варианта решения проблемы.

1) На странице about:config установи параметр network.http.spdy.enabled.http2 в false.

2) Обнови пакет libnss3 до версии 2:3.26-1. Такая версия сейчас в unstable.

Работает любой из двух вариантов, оба сразу использовать не обязательно.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Да, спасибо, первый способ сработал для меня тоже. Но я наверное лучше буду использовать второй. Хотя меня смутило предложение aptitude удалить libnss3-1d, xulrunner-10.0, чтобы разрешить «невстреченные» зависимости. Но все таки второй вариант мне нравится больше потому что он всего лишь обновление уже существующего пакета, в то время как первый - изменение заводских настроек. Нужно больше будет почитать про что делает network.http.spdy.enabled.http2 ведь неспроста же он мог быть true.

В новой версии Firefox конечно сделали неудобно как теперь показывается история самых часто посещаемых сайтов в адресной строке. Лучше бы я все что жду чтобы сделали чтобы поиск в менеджере закладок искал не только закладки но и папки, потому что Awesome Search Extension слишком неудобное решение, что для меня важно потому что нужно находить и проверять существует ли папка которая я хочу создать уже или нет, а то создаю дубли папок потому что лень проверять существует ли уже. Мне кажется не очень сложная функция чтобы сделать. Совместить поиск закладок и папок.

SamFisu ()
Ответ на: комментарий от SamFisu

Нужно больше будет почитать про что делает network.http.spdy.enabled.http2 ведь неспроста же он мог быть true.

По названию видно же: опция управляет HTTP/2.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Ну это я тоже заметил что это что-то связанное с наверно новым протоколом HTTP/2, но все равно это не дает мне понять что это делает эта настройка что она отключает, какая ее функция - наверно не прогрессивно отключать новый протокол, его функцию. Но я знаете что сейчас сделал как неразумный пользователь Linux я сделал full-upgrade двух гигабайт накопившихся обновлений в результате чего при загрузке система пишет что какой-то модуль ядра failed, но система все равно загрузилась. Да, я был не прав в первом посте апгрейд не помог - буду пользоваться каким-то из двух ваших способов значит.

SamFisu ()

Такое часто бывает, когда часы несинхронны с сетевым временем. Если год не обновлялся, возникает подозрение в том, что хост не работал, и ntp-клиент не лазил в сеть.

Infra_HDC ★★★★★ ()
Ответ на: комментарий от Infra_HDC

Вы имеете ввиду Firefox выдает «Your connection is not secure» потому что часы стали несинхронны с сетевым временем и что хост не работал, и ntp-клиент не лазил в сеть? То есть это может быть также потому что я например живя в России но желая установить себе англоязычную версию Debian вместо локального репозитория выбрал американский и вместо Россия ставил страна США при установке системы? Потом в вручную просто поставил московское время которое идет теперь по типу pm am. Хотя сейчас я думаю это наверно все равно конечно было, то есть такую же англоязычную версию можно было бы установить и поставив локальный репозиторий и свою страну и только язык по умолчанию и раскладку поставить английский и не думаю что установилось бы что-то более русифицированное при установке систему. Но я как-то сомневаюсь что-то от этого могут быть серьезные конфликты в системе.

SamFisu ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.