LINUX.ORG.RU

Написано же, шланг тестовой ветки включил, а llvm нет. У той либы в требованиях >=sys-devel/llvm-3.7, вот и предлагает его. Обнови llvm до версии шланга.

anonymous ()

Анон всё верно пишет, clang надо обновлять вместе с llvm.

Stil ★★★★★ ()

К слову, sys-devel/clang тупо пустышка.

% equery f clang
 * Searching for clang ...
 * Contents of sys-devel/clang-3.5.0-r100:

Как вы его неверно «собрали» - не понятно.

RazrFalcon ★★★★★ ()
Ответ на: комментарий от anonymous
#eix -I llvm
[I] sys-devel/llvm
     Доступные версии:      ~3.4.2(0/3.4) 3.5.0(0/3.5) ~3.5.2(0/3.5) ~3.6.2(0/3.6) ~3.7.1-r2(0/3.7.1) (~)3.8.0-r2(0/3.8.0) **9999(0/9999) {clang cmake debug (+)doc gold libedit +libffi lldb multitarget ncurses ocaml python +static-analyzer test udis86 xml ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" KERNEL="Darwin FreeBSD" PYTHON_TARGETS="pypy python2_7" VIDEO_CARDS="radeon"}
     Установленные версии:  3.8.0-r2(10:30:20 16.06.2016)(clang libffi ncurses static-analyzer xml -debug -doc -gold -libedit -lldb -multitarget -ocaml -python -test ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32" KERNEL="-Darwin -FreeBSD" PYTHON_TARGETS="python2_7" VIDEO_CARDS="-radeon")
     Домашняя страница:     http://llvm.org/
     Описание:              Low Level Virtual Machine

# eix -I clang
[I] sys-devel/clang
     Доступные версии:      (~)3.4.2-r100(0/3.4) 3.5.0-r100(0/3.5) (~)3.5.2-r100(0/3.5) (~)3.6.2-r100(0/3.6) (~)3.7.1-r100(0/3.7) (~)3.8.0-r100(0/3.8) **9999-r100(0/9999) {debug multitarget python +static-analyzer ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Установленные версии:  3.8.0-r100(10:30:41 16.06.2016)(static-analyzer -debug -multitarget -python ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32")
     Домашняя страница:     http://clang.llvm.org/
     Описание:              C language family frontend for LLVM (meta-ebuild)
SmilePlz ()
Ответ на: комментарий от Stil

вопрос в том почему он понижает версию clang с 3.8 на 3.7, если зависимости разрешены...

SmilePlz ()
Ответ на: комментарий от SmilePlz

Теперь обнови мир. Ты часом не удалял пакеты без разрешения зависимостей (-C у emerge?).

anonymous ()
Ответ на: комментарий от SmilePlz

Там написано, что media-libs/mesa у тебя из стабильной ветки. Это — разрешены?

anonymous ()

emerge -1O mesa, и снова пробуй обновить мир

Pinkbyte ★★★★★ ()
Ответ на: комментарий от anonymous

Там зависимость >= у clang, но мысль правильная - из-за dynamic-deps расчет slot-operator-а происходит неверно.

Так что в общем случае поможет либо пересборка текущей версии mesa, либо - апгрейд до тестовой. В пользу второго варианта говорит отсутствие граблей при разрешении зависимостей в будущем. В пользу первого - отсутствие граблей в работе тестовой mesa.

Pinkbyte ★★★★★ ()
Ответ на: комментарий от anonymous

если смотреть на equery g media-libs/mesa-11.0.6 и

`-- sys-devel/clang-3.8.0-r100 (>=sys-devel/clang-3.4.2) ~amd64 [abi_x86_32(-)? abi_x86_64(-)? abi_x86_x32(-)? abi_mips_n32(-)? abi_mips_n64(-)? abi_mips_o32(-)? abi_ppc_32(-)? abi_ppc_64(-)? abi_s390_32(-)? abi_s390_64(-)?]

вроде как да.

SmilePlz ()
Ответ на: комментарий от SmilePlz
(sys-devel/llvm-3.5.2:0/3.5::gentoo, ebuild scheduled for merge) pulled in by
    <sys-devel/llvm-3.6 required by (dev-libs/libclc-0.0.1_pre20141027:0/0::gentoo, installed)

Сейчас у тебя установлен libclc который требует старый llvm

Pinkbyte ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.