LINUX.ORG.RU

Почему нет русской раскладки в LXDE (Debian) ?

 , ,


0

2

Пробую сейчас легковесную среду LXDE. И обнаружил, что в ней нет графической настройки раскладки клавиатуры.

Весь интерфейс русскоязычный. Но русские буквы вводить не могу. Пробовал настраивать через:

dpkg-reconfigure keyboard-configuration


Все настраивается, но русской раскладки в LXDE не появляется.

Содержимое файла /etc/default/keyboard:

# KEYBOARD CONFIGURATION FILE
# Consult the keyboard(5) manual page.
XKBMODEL="pc101"
XKBLAYOUT="us,ru"
XKBVARIANT=","
XKBOPTIONS="grp:ctrl_shift_toggle,grp_led:scroll"
BACKSPACE="guess"


Вроде как две раскладки есть, но по Ctrl+Shift не переключаются.

Стандартный аплет переключения раскладки показыват только раскладку US, вот скриншот:

http://i.piccy.info/i9/871908d0abfacc7993d1b38887ea83d4/1464776745/73855/1007...

Что еще где надо крутить, чтоб было две раскладки и они переключались?

★★★★★

Ответ на: комментарий от mandala

Еще. Смотрел тут один лайф-сиди на базе 8-ки. Так там dpkg-reconfigure keyboard-configuration ни чего не делал. Согрешил на криворуких велосипедостроителей.

В фёдоре/арче (lxde) настраивал переключение через иксы, почему не помню.

mandala ★★★★ ()

Чтобы настройки /etc/default/keyboard применились может потребоваться udevadm trigger --subsystem-match=input --action=change

annulen ★★★★★ ()
Ответ на: комментарий от Xintrea

Нет, у меня же умвр. Со скрином обманул, такое же (только что проверил). Видать попутал со «свежатиной» из арча/фёдоры.

P.S. И почему не обновишься?

mandala ★★★★ ()
Ответ на: комментарий от annulen

Это один раз делать или куда в автозагрузку пихать?

Xintrea ★★★★★ ()

мучся своим линуксом, в FreeBSD, NetBSD LXDE уже пару лет как нету такой проблемы

anonymous ()

У меня проблемы в XFCE с раскладкой были, а в lxde - всю жизнь сразу из коробки работало. Просто панелька lxde, добавляешь апплет «Keyboard layout handler», появляется нормальная переключалка клавиатуры (что у тебя на скрине - я вообще впервые вижу, удали это). Нажимаешь Preferences и кнопкой «+» прибавляешь сколько нужно раскладок, и там же любые способы переключения. Пакет xxkb вроде отвечает за клавиатуру. И ставлю numlockx ещё обычно, чтобы с его состоянием не мучаться.

fehhner ★★★★★ ()

Все работает без лишних телодвижений

Belen ★★ ()
Ответ на: комментарий от fehhner

LXPanel 0.5.10

Я уже писал. Это дебиан 7, остаётся только страдать :).

mandala ★★★★ ()
Ответ на: комментарий от mandala

Заработало через команду

@setxkbmap -option grp:switch,grp:alt_shift_toggle us,ru

прописанную в пользовательский файл ~/.config/lxsession/LXDE/autostart.

Но эта настройка слетает, когда восстанавливается сессия в x2go (я сижу с винды через терминал Неправильная кодировка в X2GO при копировании текста через буфер обмена из Linux в Windows).

Приходится эту команду каждый раз запускать ручками при реконнекте.

Ну и да, сейчас споткнулся о неправильную кодировку, передаваемую в буфере обмена от Linux в Windows (из винды в линух усё нормально).

Xintrea ★★★★★ ()
Последнее исправление: Xintrea (всего исправлений: 1)
Ответ на: комментарий от Xintrea

У меня LXPanel 0.5.10

Ух, старенькая. У меня 0.8.х.
Ты попробовал xxkb поставить? В независимости от версии панели, переключалка одной версии на все Дебианы: https://packages.debian.org/search?searchon=sourcenames&keywords=xxkb, на скриншоте она. И работала на голом опенбоксе с тинтом, вообще без lxde.
Я думаю - это то, что тебе нужно.
Он даже может для разных окон разные раскладки помнить и в тайтле отображать.

fehhner ★★★★★ ()
Последнее исправление: fehhner (всего исправлений: 3)
Ответ на: комментарий от Xintrea

Попробуй добавить в .bashrc или .profile

setxkbmap -layout us,ru -option grp:alt_shift_toggle,grp_led:caps,ctrl:nocaps
(опции на твоё усмотрение)

S_Paul ★★★★ ()
Ответ на: комментарий от Xintrea

Не знаю, не пробовал. Это просто настройки для раскладки. x2go не использовал, но тестировал связку xpra+Xephyr.

S_Paul ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.