LINUX.ORG.RU

Вайфай не работает с конкретной точкой

 , , ,


0

2

На синькпаде установлена gentoo. К телефонному wi-fi отлично подключается со следующими настройками:

# cat /etc/wpa_supplicant//wpa_supplicant.conf 
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=wheel
update_config=1

cp /usr/share/dhcpcd/hooks/10-wpa_supplicant /lib/dhcpcd/dhcpcd-hooks
#cat /etc/conf.d/net
modules_wlp3s0="wpa_supplicant"
config_wlp3s0=="dhcp"

Однако, когда подключаюсь к микротику тем же образом, возникают проблемы. А именно делаю в wpa_cli:

scan
scan_results
add_network
set_network 0 ssid "britneywifi"
set_network 0 psk "example"
enable_network 0

И получаю:

<3>SME: Trying to authenticate with d4:**:**:**:**:** (SSID='britneywifi' freq=2427 MHz)
<3>Trying to associate with d4:**:**:**:**:* (SSID='btitneywifi' freq=2427 MHz)
<3>CTRL-EVENT-ASSOC-REJECT bssid=d4:**:**:**:**:** status_code=12
<3>SME: Deauth request to the driver failed
<3>CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="britneywifi" auth_failures=3 duration=46
reason=CONN_FAILED
<3>CTRL-EVENT-SCAN-STARTED 
<3>CTRL-EVENT-SCAN-RESULTS

На микротике этот ноут разрешен, так как раньше уже подключался к нему, когда на ноуте стоял дебиан. В логах микротика никакой активности не наблюдается.

Если что, настройки gentoo брал отсюда, а команды wpa_cli отсюда

В чем проблема? Почему могу подключиться к wi-fi, раздаваемому андроидом, а вот к микротику не получается?

nm не предлагать.

Deleted

синькпаде

От слова «Синька»? :)

Порекомендую просто установить network-manager и не выносить себе и окружающим мозг на всю эту тему.

А судя по https://w1.fi/wpa_supplicant/devel/ieee802__11__defs_8h_source.html - это нормальный DEAUTH. Пароль неправильно ввел? Если у тебя пароль - слово, то в файле, который сделал с помощью wpa_passphrase попробуй закомментировать HEX и раскомментировать psk.

pztrn ★★★★
()
Ответ на: комментарий от pztrn

Пароль специально для теста выставлен простенький, цифры. Результат — тот же самый абсолютно.

До этого подключался к вайфаю, раздаваемому планшетом. А так же к вайфаю от обычного тп-линка. Всё работало прекрасно.

NM не предлагать. Это нелогично, так как проблема не в wpa_cli, ведь wpa_cli можно использовать для подключения в других случаях, кроме этого конкретного.

Я подключаюсь, вводя команды в командной строке так, как показано выше. И это принципиально единственный способ подключения, который я использую. Если этот способ неправильный, то критикуй конкретную последовательность указанных действий, которые указаны в приведённых руководствах gentoo и arch.

Но замена на NM — это не решение данной проблемы.

Deleted
()
Последнее исправление: Deleted (всего исправлений: 3)

полный расклад настроек с микротика относящихся к вайфаю в студию. Включая preamble, beacon interval и прочее

Pinkbyte ★★★★★
()
Ответ на: комментарий от Deleted

security-profile=default

И его настройки тоже, пожалуйста - тип WPA, тип ключа(CCMP/TKIP, гибридный). Пока навскидку могу посоветовать покрутить значение proprietary-extensions(которое у тебя post-2.9.25). У меня старый КПК от HP(на нём 802.11b) не хотел цепляться к точке, пока я не покрутил ему настройки шифрования и расширения. При том, что более новые девайсы цеплялись и не жужжали.

Pinkbyte ★★★★★
()
Ответ на: комментарий от Pinkbyte

default

а так же настройки доступа для конкретного ноутбука interface wireless access-list print detail

вот

Вот, собственно, всё, что там есть по поводу wireless.

Deleted
()
Ответ на: комментарий от Pinkbyte

покрутить значение proprietary-extensions

ок, спасибо. А насколько его крутить?

Deleted
()
Ответ на: комментарий от Deleted

unicast-ciphers=aes-ccm group-ciphers=aes-ccm

tkip как менее безопасный выключен, возможно проблема в этом

Pinkbyte ★★★★★
()

Был недавно у меня глюк, похожий по описанию, но совершенно абсурдный. ВИФИ принтер, готов был подключаться к чему угодно - к вайфай точке раздаваемой телефоном или ноутом, к старому маршрутизатору, к открытой точке соседей - но только не к новому маршрутизатору TPLink Archer C2. При этом вся другая техника к TPLink подключалась на ура - те же телефоны, ноутбуки и тд. После того как я перекопал дофига всего, выяснилось, что во всем виновата НАСТРОЙКА СТРАНЫ по чьим стандартам работать, соответственно в принтере и в TPLink. В одном стояло США, а в другом Россия. И дружить они не хотели. Поменяв на одинаковые, тут же все соединилось. При этом другая техника вообще не заметила изменений. Может поможет :)

petrosha ★★★★★
()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.