LINUX.ORG.RU

Шум в наушниках

 , ,


0

2

В наушниках, подкюченных к ноуту, при отсутствии воспроизведения постоянно слышится какой-то шум\треск. Во время воспроизведения и в течение пары секунд после остановки воспроизведения такого не наблюдается, также такого эффекта нет при открытом окне pavucontrol - таким образом делаю вывод что что-то суспендит мою звуковуху во время простоя. Всякие laptop-mode-tools и pm-* пробовал крутить - ничего не меняется. Как это настраивается в пшшшаудио не нашел, нагуглить тоже не получается - все жалуются на шелчки в любое время, а вот такого эффекта не нахожу. А, да, шум не зависит от того, подключен ли ноут к сети или нет.

$ pulseaudio --version
pulseaudio 7.1

$ lspci -vk | grep Audio -A 5
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
	Subsystem: Dell Device 0651
	Flags: bus master, fast devsel, latency 0, IRQ 43
	Memory at f7e14000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel
--
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
	Subsystem: Dell Device 0651
	Flags: bus master, fast devsel, latency 0, IRQ 46
	Memory at f7e10000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel

Какую еще информацию предоставить даже не знаю (не часто с таким сталкиваюсь), буду рад любой помощи.

Ответ на: комментарий от alozovskoy

Посмотри в менюшках, если у тебя действительно есть шум, то pavucontrol покажет что его издаёт.

Очень полезная софтина.

lexxus-lex ★★★ ()
Ответ на: комментарий от lexxus-lex

Там я смотрел уже, ничего не увидел. Он, на сколько я понимаю, только приложения показывает, а мне кажется что это - сорт аппаратной проблемы.

alozovskoy ★★★★★ ()
Ответ на: комментарий от lexxus-lex

который слышал как у него работает wi-fi

Я слышал работу USB порта - обычное дело, когда ничего не экранировано и как попало.

fornlr ★★★★★ ()
Ответ на: комментарий от alozovskoy

В настройках выбрано правильное устройство?

Попробуй заткнуть пальцем линейный вход (где микрофон)

и вот, что нашел: https://askubuntu.com/questions/150887/sound-from-both-headphones-and-speakers

Вообще проблему я с наушниками решил при помощи pavucontrol, не понимаю, где ты там потерялся в настройках

lexxus-lex ★★★ ()
Последнее исправление: lexxus-lex (всего исправлений: 4)
Ответ на: комментарий от lexxus-lex

В настройках выбрано правильное устройство?

У меня там hdmi (выключен) и «Аналоговый стерео дуплекс» на «Встроенном аудио» (пробовал только «аналоговый стерео выход» - ничего не меняется). Других вариантов нет.

Попробуй заткнуть пальцем линейный вход (где микрофон)

У меня нет такого, на вкладке с «устройствами ввода» есть только монитор встроенного аудио, он замьючен.

и вот, что нашел: https://askubuntu.com/questions/150887/sound-from-both-headphones-and-speakers

Не, совсем не то.

Вообще проблему я с наушниками решил при помощи pavucontrol, не понимаю, где ты там потерялся в настройках

Да там настроек то - уровни да какие-то задержки, ничего не сконфигурить нормально, все равно всегда в конфиги лезть советуют.

alozovskoy ★★★★★ ()
Ответ на: комментарий от alozovskoy

Так, говоришь, при открытом окне pavucontrol не шипит. А если открыть alsamixer? Тогда будет шуметь? И не включен ли там монитор микрофона, или ещё что?

Deleted ()
Ответ на: комментарий от Deleted

при открытом окне pavucontrol не шипит.

Да.

А если открыть alsamixer?

Шум есть (открываю в терминале, об этом же речь?).

И не включен ли там монитор микрофона, или ещё что?

Все, что хоть как-то связано с микрофоном замьючено\отключено, где такой возможности нет - уровень убран в 0 (как в пульсе, так и в alsamixer'е)

alozovskoy ★★★★★ ()
Ответ на: комментарий от alozovskoy

У меня нет такого, на вкладке с «устройствами ввода» есть только монитор встроенного аудио, он замьючен

Но сам-то вход есть? Вот он и шипит, больше там шипеть нечему.

no-such-file ★★★★★ ()
Ответ на: комментарий от alozovskoy

Если при алсамиксере шум остаётся, то это не энергосбородение, о котором ты думал.

Покрути все регуляторы и режимы в alsamixer. Ну не может быть такого! И не понастроено там в пульсе каких модулей дополнительных?

Что может быть: включено что-то в алсе или в пульсе. Всё! Больше нечему. Проверь ещё сто раз. Все пункты и крутилки.

Deleted ()
Ответ на: комментарий от Deleted

Если при алсамиксере шум остаётся, то это не энергосбородение, о котором ты думал.

Спорное утверждение (на мой взгляд) - может алса не «открывает аудиовыход на запись» (не знаю как там это правильно называется, но, думаю, смысл понятен).

И не понастроено там в пульсе каких модулей дополнительных?

Все «ванильное», ничего не настраивал дополнительно.

alozovskoy ★★★★★ ()
Ответ на: комментарий от no-such-file

Почему не шипит при воспроизведении? Почему не шипит пару секунд после окончания воспроизведения? Почему нет шума в динамиках?

alozovskoy ★★★★★ ()
Ответ на: комментарий от alozovskoy

попробуй посмотреть powertop на предмет энергосбережения звуковухи, когда есть шипение и когда его нет.

feofan ★★★★★ ()
Ответ на: комментарий от feofan

Смотрел, у меня там все энергосбережение отключено, кроме

Good          Enable Audio codec power management

но оно и не отключается никак. Плюс шипение есть и от сети, и от батареи, разве тут никак это не детектится?

Пробовал писать N в /sys/module/snd_hda_intel/parameters/power_save_controller - ничего не дает, но на увеличение числа в /sys/module/snd_hda_intel/parameters/power_save реагирует, значит таки энергосбережение.

alozovskoy ★★★★★ ()
Последнее исправление: alozovskoy (всего исправлений: 1)
Ответ на: комментарий от alozovskoy

тогда читай документацию модуля ядра, наверняка ему можно передать параметры при загрузке.

feofan ★★★★★ ()

Если поможет попробуй

Я столкнулся с такой же проблемой. Мне помог метод научного тыка - в микшере подтянул рычаг «Headphone Mic» и шум пропал.
Скрин

bat ~ $ uname -a
Linux linux 4.8.11-1-ARCH #1 SMP PREEMPT Sun Nov 27 09:26:14 CET 2016 x86_64 GNU/Linux
bat ~ $ pulseaudio --version
pulseaudio 9.0
bat ~ $ 
dreadnought ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.