LINUX.ORG.RU

Пересобрал мир. Начало глючить Qt приложение

 ,


0

1

Есть софт такой houdini. Использует Qt для юи. Qt либы свои (не системные). Раньше всё было нормально. Пересобрал мир, и начало ругаться на невозможность отображения курсора. Битмап он не понимает

Qt Warn: QCursor: Cannot create bitmap cursor; invalid bitmap(s)

Куда рыть?


Qt либы свои (не системные).

Но наверняка использует либы-зависимости Qt из системы. Смотри выхлоп ld.

r3lgar ★★★★★ ()
Ответ на: комментарий от r3lgar

Но понял что Qt плагины, которые за загрузку форматов изображений отвечают, не видят свои Qt либы.

Спасибо за наводку.

vux ()
Ответ на: комментарий от vux

Все зависимости в норме

А зависимости зависимостей (плагинов)?

Но понял что Qt плагины, которые за загрузку форматов изображений отвечают, не видят свои Qt либы.

Вот и проблема. Теперь ищи её решение. Посмотри, какую версию требуют, установи в директорию приложения, напиши скрипт-обёртку с LD_LIBRARY_PATH.

r3lgar ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.