LINUX.ORG.RU

Dropbox падает

 , , ,


0

1

Решил попробовать Dropbox. Установил RPM-пакет отсюда: https://www.dropbox.com/install?os=lnx Уверен что в DEB-пакете то же самое.

Пакет имеет размер 97 Кб, зависимость от nautilus-extensions >= 2.16.0 (что подразумевает в том числе и третий GNOME: там есть /usr/lib64/nautilus/extensions-2.0/ и /usr/lib64/nautilus/extensions-3.0/) и содержит /usr/bin/dropbox и расширение для GNOME.

Выполняю из консоли dropbox, получаю:

$ dropbox
Dropbox command-line interface

commands:

Note: use dropbox help <command> to view usage for a specific command.

 status       get current status of the dropboxd
 help         provide help
 puburl       get public url of a file in your dropbox
 stop         stop dropboxd
 running      return whether dropbox is running
 start        start dropboxd
 filestatus   get current sync status of one or more files
 ls           list directory contents with current sync status
 autostart    automatically start dropbox at login
 exclude      ignores/excludes a directory from syncing
 lansync      enables or disables LAN sync

Переключаюсь на GNOME и запускаю Nautilus. В контекстном меню в «Копировать в...» и «Переместить в...» нет Dropbox. Так значит программа - всего лишь синхронизатор с облачным хранилищем, как Яндекс.Диск? А значит бесполезна для меня. И я забыл о ней.

Сегодня зашёл в главное меню и увидел это: http://i.imgur.com/jmTC7hF.png

При нажатии запустилось вполне себе GUI-шное окно: http://i.imgur.com/5WNmEGd.png (рамки окна нет, потому что Emerald)

В главном меню опять появилось приложение Dropbox. Оно запускается и работает, но только 5 секунд. Зашёл в ~/.dropbox-dist/dropbox-lnx.x86_64-3.8.9/ и выполняю "./dropbox". Спустя 5 секунд получаю такую ошибку:

$ ./dropbox
1   0x7fd6f752fed7 /usr/lib64/libQt5WebKit.so.5(WTFCrash+0x17) [0x7fd6f752fed7]
2   0x7fd6f7575ec5 /usr/lib64/libQt5WebKit.so.5(_ZN3WTF11OSAllocator18reserveUncommittedEmNS0_5UsageEbbb+0x65) [0x7fd6f7575ec5]
3   0x7fd6f734b4a3 /usr/lib64/libQt5WebKit.so.5(+0x19be4a3) [0x7fd6f734b4a3]
4   0x7fd6f747bef4 /usr/lib64/libQt5WebKit.so.5(_ZN3JSC19initializeThreadingEv+0x44) [0x7fd6f747bef4]
5   0x7fd6f60428d9 /usr/lib64/libQt5WebKit.so.5(+0x6b58d9) [0x7fd6f60428d9]
6   0x7fd6f5e4de2d /usr/lib64/libQt5WebKit.so.5(_ZN7WebCore19initializeWebCoreQtEv+0x1d) [0x7fd6f5e4de2d]
7   0x7fd6f272dcc1 /usr/lib64/libQt5WebKitWidgets.so.5(+0x26cc1) [0x7fd6f272dcc1]
8   0x7fd6f2730ad4 /usr/lib64/libQt5WebKitWidgets.so.5(_ZN8QWebPageC2EP7QObject+0x44) [0x7fd6f2730ad4]
9   0x7fd6f297b269 /home/zenitur/.dropbox-dist/dropbox-lnx.x86_64-3.8.9/PyQt5.QtWebKitWidgets.so(+0x2e269) [0x7fd6f297b269]
10  0x7fd6f297b324 /home/zenitur/.dropbox-dist/dropbox-lnx.x86_64-3.8.9/PyQt5.QtWebKitWidgets.so(+0x2e324) [0x7fd6f297b324]
11  0x7fd7054dbb3b /home/zenitur/.dropbox-dist/dropbox-lnx.x86_64-3.8.9/sip.so(+0x9b3b) [0x7fd7054dbb3b]
12  0x4751ea ./dropbox() [0x4751ea]
13  0x5cec3a ./dropbox(PyObject_Call+0x3a) [0x5cec3a]
14  0x4a5232 ./dropbox(PyEval_EvalFrameEx+0x2382) [0x4a5232]
15  0x4a9458 ./dropbox(PyEval_EvalCodeEx+0x7f8) [0x4a9458]
16  0x603eaf ./dropbox() [0x603eaf]
17  0x5cec3a ./dropbox(PyObject_Call+0x3a) [0x5cec3a]
18  0x5dea85 ./dropbox() [0x5dea85]
19  0x5cec3a ./dropbox(PyObject_Call+0x3a) [0x5cec3a]
20  0x477d0f ./dropbox() [0x477d0f]
21  0x4751ea ./dropbox() [0x4751ea]
22  0x5cec3a ./dropbox(PyObject_Call+0x3a) [0x5cec3a]
23  0x4a5232 ./dropbox(PyEval_EvalFrameEx+0x2382) [0x4a5232]
24  0x4a9458 ./dropbox(PyEval_EvalCodeEx+0x7f8) [0x4a9458]
25  0x603de0 ./dropbox() [0x603de0]
26  0x5cec3a ./dropbox(PyObject_Call+0x3a) [0x5cec3a]
27  0x5dea85 ./dropbox() [0x5dea85]
28  0x5cec3a ./dropbox(PyObject_Call+0x3a) [0x5cec3a]
29  0x477d0f ./dropbox() [0x477d0f]
30  0x4751ea ./dropbox() [0x4751ea]
31  0x5cec3a ./dropbox(PyObject_Call+0x3a) [0x5cec3a]
Сигнал таймера

Первое что я подумал: в той же директории находятся файлы Qt5, включая Qt5WebKit. Удалил их, чтобы использовались системные (предварительно узнав с помощью string, что программа собрана с Qt 5.4.1. А у меня 5.4.2). Запустил программу снова - ошибка не изменилась. Выше - как раз ошибка с системным Qt5.

Вопросы:

  • Кто-нибудь встречал эту проблему? Решал?
  • За 5 секунд работы программы я успеваю вызвать настройки: http://i.imgur.com/xFrDdxF.png В настройках сказано что программа использует открытый код. Так код открыт, и я могу пересобрать конкретно под свою систему? Или нет? Ссылка, кстати, ведёт сюда: https://www.dropbox.com/help/1366
  • Допустим, нет. А баг трекер у них имеется? Гуглением не нашёл.

пистон уронили азаз

anonymous ()

В настройках сказано что программа использует открытый код.

Это может значить что она линкуется с opensource-ными библиотеками, лицензии которых это позволяют. И по ссылке на сайт дропбокса, что ты кинул именно об этом и написано

Pinkbyte ★★★★★ ()

Ну так скомпиль, не трогая этих криворуков

Reedych ★☆ ()
Ответ на: комментарий от Reedych

В репозитории лежит SRPM-ка python3-qt5, а у меня Python 2.7. Не подходит она мне... Начал скачивать python-qt5. После сотого мегабайта остановил скачивание. Что за фигня?!

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.