LINUX.ORG.RU

Автозапуск в Arch

 ,


0

1

У меня есть скрипт который по запуску система надо запускать. Я его добавил в Autostart через настройки и выставил аттрибут «Run On» на «Startup», но не помогает. Так же создавал сервис который будет запускать скрипт, тоже не помогло. Как можно заставить арч запустить этот скрипт?


Если не от рута, то в .xinitrc или в настройках DE. Если нужен рут, кури арчевскую вики.

sudopacman ★★★★★ ()

Я его добавил в Autostart через настройки и выставил аттрибут «Run On» на «Startup»

А где такие настройки? Openbox?

lexazloy ()

Создай файл /etc/systemd/system/myservice.service со следующим содержимым (заменяя строки в угловых скобках):

[Unit]
Description=<описание сервиса>
After=multi-user.target

[Service]
Type=simple
ExecStart=<путь к твоему скрипту>

[Install]
WantedBy=multi-user.target


После чего скомандуй
sudo systemctl enable myservice

m0rph ★★★★★ ()
Ответ на: комментарий от Neic

Говорил же что пробовал сервис делать.

Вышеприведенное решение у меня прекрасно работает больше года, очевидно руки. Скрипт-то у тебя хоть исполняемый? Раздел, где он находится смонтирован без опции noexec?

m0rph ★★★★★ ()
Ответ на: комментарий от unikum

Если я правильно понимаю документацию, при указании oneshot systemd будет ждать завершения запускаемого процесса, что бывает нужно реже, чем не нужно.

m0rph ★★★★★ ()
Последнее исправление: m0rph (всего исправлений: 1)
Ответ на: комментарий от m0rph

Всё ок, твоё решение заработало, спасибо. У меня сервис имел такое же тело, только без пары строчек типа «After=multi-user.target». Теперь всё работает, а то задолбался каждый раз вручную запускать.

Neic ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.