LINUX.ORG.RU

Черный фон у значка megasync в системном трее

 , , ,


0

1

Всем здрасьте!

Система: Arch Linux (uname -srom: Linux 4.1.2-2-ARCH i686 GNU/Linux), DE/WM: Openbox 3.6.1-1, DM: SLiM 1.3.6-5. Комп собран из пыльного железа из закромов, посему видеокарта GeForce 2 MX/MX 400 с проприетарными дровами nvidia-96xx-dkms 96.43.23-4 из AUR.

В системном трее xfce4-panel значок megasync (клиент облачного сервиса mega.co.nz) отображается на черном фоне:

http://i.imgur.com/o1BuOXC.png

Остальные значки с прозрачностью отображаются нормально.

Перерыл все варианты, до которых смог додуматься: обновил кэш значков у всех тем, скопировал значки megasync всех размеров из темы Hicolor в другие темы, попробовал разные панели (xfce4-panel, lxpanel), переустановил пакеты, просмотрел выводы lsof и strace - бесполезно.

Помогите, пжлст, а то мой внутренний перфекционист противно хнычет и топчет ножками.

Ответ на: комментарий от z0mb1e_kgd

У меня были такие приколы, пока не перестал использовать композитник. Потом все стало хорошо.

pztrn ★★★★ ()

Проблема решилась сносом проприетарных дров и установкой Nouveau. Подозреваю, что дело в устаревшем xorg-server 1.12, которого требует nvidia-96xx-dkms.

Однако выяснилось, что Нуво не умеет аппаратное ускорение на этом ископаемом (хотя офсайт утверждает обратное), поэтому пришлось откатиться обратно на проприетарные дрова и просто забить на этот черный фон у иконки.

z0mb1e_kgd ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.