LINUX.ORG.RU

Починить Scroll Lock

 , ,


0

2

Помогало добавить в autostart, но недавно я заметил, что если сменить раскладку, то Scroll Lock снова деактивируется. (судя по всему потому-то layout сбрасывается, когда меняется layout, и Scroll Lock так как его нету в обоих layout'ах вновь деактивируется)

xmodmap -e 'add mod3 = Scroll_Lock'
Пробовал https://askubuntu.com/a/597757 но, у меня не заработало. Или я все-таки умудрился ставить в нету секцию, тогда когда пробовал. (маловероятно) Так как можно починить Scroll Lock, чтобы он работал после без костылей? Кажется что вопрос простой, но видимо, не все так просто как кажется на первый взгляд. Спрашиваю потому-то наверняка кто-то уже сталкивался и решил данную проблемку. Алсо, судя (по информации из google) по всему проблема затрагивает Ubuntu, Debian, Arch и даже RHEL.

Вроде модификаторы не связаны с лэйаутами.

Или я все-таки умудрился ставить в нету секцию, тогда когда пробовал.

Это можно проверить простым вызовом xmodmap без параметров же.

Запили команду для добавления в mod3 в ~/.Xmodmap или в автостарт своего DE. Или я тебя не правильно понял?

P.S. Я пытался Menu повесить как mod3, и у меня что-то ничего не вышло - то в mod4 добавится, то «из вне» этого модификатора не видно, в общем бросил, так что подписался на тред.

alozovskoy ★★★★★ ()
Ответ на: комментарий от alozovskoy

запили команду для добавления в mod3 в ~/.Xmodmap

Так не работает, причем я попробовал что создавать файл x/Xmodmap и в /etc/X11 и .x/Xmodmap в ~.

автостарт своего DE

Так у меня и было, но когда я переключаю язык, то scroll lock отваливается, и потом если снова переключить на английский, то scroll lock опять же не работает, пока не сделать:

xmodmap -e 'add mod3 = Scroll_Lock'
Т.е. scroll lock работает после данной команды, до того моменты, пока я не сменю раскладку на любую.

anonymous_sama ★★★★★ ()

It turns out, in my case, that gnome-settings-daemon was overriding my ~/.Xmodmap settings.

Теперь понятно кто сбрасывает xmodmap

anonymous_sama ★★★★★ ()
Последнее исправление: anonymous_sama (всего исправлений: 2)

Включил плагин keyboard gnome-settings-daemon обратно. Отредактировал layout'ы следующим образом:

xkb_symbols "basic" {

    name[Group1]= "English (US)";
    ...
    key <BKSL> {	[ backslash,         bar	]	};
    modifier_map Mod3   { Scroll_Lock };
};
xkb_symbols "winkeys" {
    include "ru(common)"

    name[Group1]= "Russian";
    ...
    key <BKSL> {        [       backslash,           slash      ]       };
    modifier_map Mod3   { Scroll_Lock };
};
Теперь Scroll Lock работает как и должен работать.

anonymous_sama ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.