LINUX.ORG.RU

Не запоминается громкость системных звуков

 , , ,


0

1

В общем логика такая, если я выставляю громкость системных звуков не равную 100% в kmix, то они всеравно останутся на максимальной громкости и вернут ползунок назад при первом воспроизведение.

Кто-нибудь сталкивался с подобным?

★★★★★

На Fedora проверил - все работает.

Но недалекие люди продолжают шутить про глюкавость pulseaudio.

awesomenickname ★★★★★ ()

В недрах systemsettings есть настройка громкости системных звуков.

ss_ash ★★★ ()
Ответ на: комментарий от deterok

А вы хам, сударь. С таким отношением помогать вам нет никакого желания. Более того — добро пожаловать в игнор-лист.

haku ★★★★★ ()
Ответ на: комментарий от deterok

Кстати присоединяюсь к вопросу. Как там сейчас с блютусом и гарнитурой? По-прежнему без пульсы не обойтись?

ashot ★★★★ ()
Ответ на: комментарий от Alyssa

Ты не понял, у меня проблема в том, что громкость не выставляется, она тупо всегда на максимуме. Т.е. я выставлю в 0%, но стоит произойти звуковому системному событию и оно прозвучит с максимальной громкостью, а громкость событий восстановиться в kmix на максимум.

deterok ★★★★★ ()
Ответ на: комментарий от ashot

Жопа...

Единственный, кто на это обратил внимание - Ленарт.

deterok ★★★★★ ()

1. Так было всегда или только сегодня так стало?
2. Что за аудио-карта?
3. Установлено ли пульсаудио?

Deleted ()
Последнее исправление: Lifun (всего исправлений: 1)
Ответ на: комментарий от Deleted

1) Да, так было всегда.
2)

Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
        Subsystem: Lenovo 7 Series/C210 Series Chipset Family High Definition Audio Controller
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 28
        Region 0: Memory at d3710000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
                Address: 00000000feeff00c  Data: 418a
        Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0
                        ExtTag- RBE-
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
                        MaxPayload 128 bytes, MaxReadReq 128 bytes
                DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
        Capabilities: [100 v1] Virtual Channel
                Caps:   LPEVC=0 RefClk=100ns PATEntryBits=1
                Arb:    Fixed- WRR32- WRR64- WRR128-
                Ctrl:   ArbSelect=Fixed
                Status: InProgress-
                VC0:    Caps:   PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
                        Arb:    Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
                        Ctrl:   Enable+ ID=0 ArbSelect=Fixed TC/VC=01
                        Status: NegoPending- InProgress-
                VC1:    Caps:   PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
                        Arb:    Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
                        Ctrl:   Enable+ ID=1 ArbSelect=Fixed TC/VC=22
                        Status: NegoPending- InProgress-
        Capabilities: [130 v1] Root Complex Link
                Desc:   PortNumber=0f ComponentID=00 EltType=Config
                Link0:  Desc:   TargetPort=00 TargetComponent=00 AssocRCRB- LinkType=MemMapped LinkValid+
                        Addr:   00000000fed1c000
        Kernel driver in use: snd_hda_intel



3) Да, pulseaudio установлен.
deterok ★★★★★ ()
Ответ на: комментарий от deterok

Поковыряй alsamixer, меняется ли в нём громкость. Посмотри, правильный ли ты выбрал в kmix устройство.

Deleted ()
Ответ на: комментарий от Deleted

Да вот в том-то и дело, что меняется. А как только происходит первое звучание, то тут же возвращается на максимум. И так только с системными звуками.

deterok ★★★★★ ()
Ответ на: комментарий от Deleted

Хотя нет, постой, у меня в миксере вообще нет ползунка отвечающего за системные звуки.

Вот кстати на всякий еще раз проверил, выставил в KMix системные звуки в ноль. Запустил плеер, звучит как положено, на уровне мастер, завершаю kmail и тут «пум-бум» с максимальной громкостью.

При том никакие другие уровни не изменяются...

deterok ★★★★★ ()
Последнее исправление: deterok (всего исправлений: 1)
Ответ на: комментарий от deterok

попробуй в конфиге пульсы /etc/pulse/daemon.conf параметр flat-volumes выставить в no. ребутни пульсаудио, ну и покрути ползунок в кмиксе на нужный уровень.

KJIayC ()
Ответ на: комментарий от deterok

Да в системсеттингс надо крутить настройку звука уведомлений, а не в кмикс. В кмиксе не настроить. Это или баг такой, или фишка

ss_ash ★★★ ()
Ответ на: комментарий от KJIayC

Не работает, а вот от ss_ash в своем комментарии ниже про ksystemsettings работает, но хотелось бы рулить из KMix'а...

deterok ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.