LINUX.ORG.RU

Установка дров ATI под Debian Wheezy

 ,


0

1

Суть: обновился со Squeeze до Wheezy, по традиции отвалились все дрова. Восстановил всё, кроме видео: те дрова, что были в ядре, лагали. Например, при прокрутке страницы в браузере перерисовывается вся страница, и на это уходит больше секунды времени. Одним словом, «вроде работает», но неудобно. Такое уже случалось раньше после обновлений, и лечилось установкой дров с сайта ATI. Но в этот раз этот вариант не сработал: после установки дров иксы не стартуют вообще. При запуске kdm система намертво повисает (чёрный экран, Num Lock на клавиатуре не включается). Такое, в общем, раньше тоже бывало, и опять же лечилось установкой дров от производителя.

Пробовал сносить fglrx, ставить fglrx, сносить xorg, ставить xorg. Установщик дров от ATI ругался на отсутствие хидеров под ядро 3.7 - поставил ему ядро 3.13 (3.7 в бэкпортах нет), перестал ругаться.

Переустанавливал дрова ATI полностью:

# sh /usr/share/ati/fglrx-uninstall.sh

# apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

# (install driver)

# aticonfig --initial

Пробовал поставить дрова из репов по факу: https://wiki.debian.org/ru/ATIProprietary

Результат всё тот же - чёрный экран.

Содержимое xorg.conf: http://pastebin.com/qDcJc8nv

Система - Debian Wheezy 7.6, ядро 3.14 bpo и 3.13 bpo (пробовал под обеими версиями), KDE, видеокарта PowerColor Radeon 6670.

Скажите, какую ещё диагностическую информацию предоставить.

Попробуй подключить этот репозиторий deb http://backports.debian.org/debian-backports squeeze-backports main non-free и поставить дрова оттуда. sudo aptitude -r -t squeeze-backports install fglrx-driver

w1nner ★★★★★ ()
Последнее исправление: w1nner (всего исправлений: 1 )

Radeon 6670

Я бы предложил обновиться на тестинг, который скоро заморозят, и использовать свободный драйвер без всякой головной боли. Энергосбережение, OpenGL 3.3, VDPAU — всё это отлично работает (у меня интегрированная в процессор HD 8570D).

Gotf ★★★ ()
Ответ на: комментарий от w1nner

Попытался сделать так, но при попытке удалить предыдущую версию драйвера ещё и apt поломался. При попытке установить или удалить жалуется на:

subprocess installed post-removal script returned error exit status 20

При apt-get -f install - ошибка та же, но код 128.

avialaynen ()
Ответ на: комментарий от avialaynen

Ну не знаю, я на свой 4870 без проблем ставил на Debian Wheezy проприетарный fglrx-legacy из wheezy-backports, правда там ядро было 3.2.04

w1nner ★★★★★ ()

У меня такое ощущение, что Wheezy говно сам по себе. Всё, что в сквизе нормально работало, в вхизи отваливается и не ставится. Поставил вхизи с нуля на другой раздел - сразу из коробки сетевухи (atheros) нет, звука нет. Видео, правда, есть, но широкоэкранные разрешения отсутствуют как класс (по-моему, на дворе не 90-е), при попытке запустить видео экран предварительно мигнёт чёрным. Пробовал поставить дрова на сетевуху от производителя (эти дрова на сквизе переустанавливал при каждом обновлении) - так хидеров не хватает, а их без сети, естественно, не скачать. С одной стороны вроде бы утверждается, что в новых ядрах появилась наконец поддержка искаропки дров на железо, которое у меня уже два года (и на момент покупки тоже было не самым новым), с другой - от этого всё наоборот перестало работать. Жаль, что по тестинг-ветке нет iso-образа - попробовал бы поставить новую ветку с новыми ядрами.

avialaynen ()
Ответ на: комментарий от avialaynen

У меня такое ощущение, что Wheezy говно сам по себе. Всё, что в сквизе нормально работало, в вхизи отваливается и не ставится. Поставил вхизи с нуля на другой раздел - сразу из коробки сетевухи (atheros) нет, звука нет. Видео, правда, есть, но широкоэкранные разрешения отсутствуют как класс (по-моему, на дворе не 90-е), при попытке запустить видео экран предварительно мигнёт чёрным. Пробовал поставить дрова на сетевуху от производителя (эти дрова на сквизе переустанавливал при каждом обновлении) - так хидеров не хватает, а их без сети, естественно, не скачать. С одной стороны вроде бы утверждается, что в новых ядрах появилась наконец поддержка искаропки дров на железо, которое у меня уже два года (и на момент покупки тоже было не самым новым), с другой - от этого всё наоборот перестало работать. Жаль, что по тестинг-ветке нет iso-образа - попробовал бы поставить новую ветку с новыми ядрами.

...че принял?

Google_Play ()
Ответ на: комментарий от Gotf

Обновился на jessie - теперь иксы вообще не стартуют.

FATAL: module fglrx not found

unable to connect to X server: connection refused

И отправляет читать лог Xorg.0.log. Содержимое: http://pastebin.com/fSLnPRws

fglrx обновлял: apt-get install fglrx* apt-get install xorg aticonfig --initial

avialaynen ()
Ответ на: комментарий от Gotf

Уже установлена самая новая версия xserver-xorg-video-radeon.

Снёс fglrx, при старте иксов система снова виснет, как и раньше. Я что-то ещё не сделал?

avialaynen ()
Ответ на: комментарий от avialaynen

Точно пусто в Xorg.log? Это может означать, что X-сервер даже не пытается запуститься. Сложно гадать на кофейной гуще. Попробуй live Ubuntu 14.04 или 14.10 (любой, не принципиально) для уверенности, что с картой всё нормально. Ну или Kubuntu, не суть важно.

Gotf ★★★ ()
Ответ на: комментарий от Gotf

Сейчас с этой карты под виндой сижу. Плюс на другой раздел пробовал ставить wheezy с нуля, там видео работает (но дефолтные дрова не знают разрешения кроме 4:3 и ещё немного проблем по мелочи). Дело точно в дровах. И раньше при обновлениях такое уже было (виснет при запуске kdm), тогда лечилось установкой проприетарных дров от amd. Теперь не сработало.

avialaynen ()
Ответ на: комментарий от Gotf

Забавное замечание насчёт прямых рук, с учётом того, что я делаю только то, что мне говорите вы...

Кстати, в jessie из коробки работает звук Realtek. Так, просто наблюдение.

avialaynen ()
Ответ на: комментарий от avialaynen

Кстати, в jessie из коробки работает звук Realtek.

А он и в предыдущем Дебиане работал. Так, просто замечание.

Deleted ()

KDE, видеокарта PowerColor Radeon 6670.

На относительно новую железку не очень хорошая идея ставить Wheezy.

У меня на родных драйверах тоже было низкое разрешение, для исправления этого, достаточно было обновить ядро, иксы и месу из бэкпортов. Но т.к. я любитель относительной свежатины, то обычно ставил Sid.

Deleted ()
Последнее исправление: Deleted (всего исправлений: 2 )
Ответ на: комментарий от avialaynen

Иксовый конфиг созданный командой aticonfig --initial удаляли? Он требуется только fglrx.

Deleted ()
Ответ на: комментарий от avialaynen

Забавное замечание насчёт прямых рук, с учётом того, что я делаю только то, что мне говорите вы...

Оно было бы забавным, если бы я тебе давал точные инструкции, а не указания общего плана. В таких условиях можно лишь догадываться, как и в какой степени сломана твоя система.

Кстати, в jessie из коробки работает звук Realtek.

Ну хоть что-то хорошее. Кодеков Realtek, к слову, миллион и маленькая тележка.

Gotf ★★★ ()
Ответ на: комментарий от Deleted

А он и в предыдущем Дебиане работал

Из коробки - нет. Каждый раз отваливалось, приходилось ставить вручную ту же версию, что в прошлый раз.

На относительно новую железку не очень хорошая идея ставить Wheezy

Три года - по меркам дебиана не срок? Впрочем, да, не срок.

avialaynen ()
Ответ на: комментарий от avialaynen

Каждый раз отваливалось, приходилось ставить вручную ту же версию, что в прошлый раз.

Версию чего?

У меня вот ALC883 Realtek - ничего не отваливалось ни в сквизе, ни в виззи. Может всё-таки карма и руки?

Deleted ()

Такое уже случалось раньше после обновлений, и лечилось установкой дров с сайта ATI.

Молодец, засрал себе систему установкой блоба не из пакета и теперь мучаешься.

maloi ★★★★★ ()
Последнее исправление: maloi (всего исправлений: 1 )
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.