LINUX.ORG.RU

Сбрасывает настройки мониторов Linux Mint 17 KDE

 , , ,


1

2

Стоит на компе Linux Mint 17 KDE. Два монитора. Настраиваем оба, все работает. При перезагрузке сбрасывает все и видит только один монитор. Настраиваю через Параметры системы - Экран. Что сделать, чтобы оставлял оба работающих монитора?

P.S. да я совсем нуб Т_Т

Создать соответствующие настройки в файле /etc/X11/xorg.conf или сделать скрипт с использованием xrandr, который будет настраивать второй монитор.

Какая у вас видео карта и какой видео драйвер вы используете?

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

OpenGL vendor string: X.Org R300 Project OpenGL renderer string: Gallium 0.4 on ATI RV570 OpenGL version string: 2.1 Mesa 10.1.0

в /ect/X11 нет ничего с названием xorg.conf, зато есть в /usr/share/X11.

Madgoddess ()
Ответ на: комментарий от Madgoddess

Поищите в параметрах монитора должна быть кнопка «Save as Default» или сохранить по умолчанию. Нажмите на неё.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Это в Параметры системы-экраны ? там нет такой кнопки,ну или я не вижу. Есть просто сохранить, но каждый раз при перезагрузке остается один монитор.

Попробуем порыться в /usr/share/X11/xorg.conf

Madgoddess ()
Ответ на: комментарий от Madgoddess

Попробуем порыться в /usr/share/X11/xorg.conf

Там не надо уже.

kostik87 ★★★★★ ()
Ответ на: комментарий от Madgoddess

там нет такой кнопки,ну или я не вижу.

Там есть такая кнопка, вы чертовски невнимательны.

Вот скриншоты: http://postimg.org/gallery/2ts6kogvq/

Делаете настройки, нажимаете применить, а потом раскрываете указанный список и выбираете «Сохранить как значение по умолчанию», ну или если у вас английский интерфейс «Save as Default».

kostik87 ★★★★★ ()
Ответ на: комментарий от Madgoddess

Вы хоть на копку «По умолчанию» пробовали нажимать после изменения настроек? Должно появиться примерно такое окно же окно как на моём втором скриншоте, которое сообщит, что настройки сохранены.

В таком случае на экране ввода имени пользователя и пароля настройки останутся такими как и были, а после авторизации при запуске KDE будут применяться сохранённые настройки?

Ну либо создавайте файл xorg.conf, для этого остановите xorg-server, затем сгенерируйте конфигурационный файл:

X -configure
затем скопируйте его:
cp /root/xorg.conf.new /etc/X11/xorg.conf
Внесите в него соответствующие правки, готово.

Или изучите xrandr, напишите скрипт, который будет активировать второй DVI разъём и выставлять на мониторе, который к нему подключен соответствующее разрешение, затем сделайте скрипт исполняемым и добавьте его в запуск средствами KDE.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от kostik87

При нажатии на эту самую кнопку не происходит ничего. абсолютно ничего. При перезагрузке все как обычно. один монитор.

Разбираемся дальше.

Madgoddess ()
Ответ на: комментарий от petyanamlt

В kde-4.14.2 настройки нормально сохраняются под пользователем, по факту сохраняются вызовы xrandr в файле ~/.kde/share/config/krandrrc и затем они будут применяться при входе пользователя в систему.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от kostik87

В общем то проблема решилась вот с помощью этого:

https://forums.opensuse.org/showthread.php/493985-SOLUTION-FOR-KSCREEN-NOT-SAVING-DUAL-MONITOR-CONFIGURATION-IN-OPENSUSE-13-1/

1. Download and install arandr and make sure that xrandr is also installed along with its libraries (it should already be.)

2. Open terminal and run arandr as user, not as su. It will open a configuration screen similar to the one used by Kscreen. Place your monitors as per your needs and save the configuration. Name it aranadr.conf. The program will save the configuration file in a shell script in a hidden folder in /home/username/.screenlayout/arandr.conf.sh.

3. Open Configure Desktop > Startup and Shutdown > Autostart > Add Script Provide the complete path for your arandr.conf.sh script, i.e.

/home/username/.screenlayout/arandr.conf.sh

and make sure to enable it at Startup. Apply this change.

That's it. Now when you logout or reboot, your KDE will open momentarily with the old screwed up configuration, but almost immediately after that the script will correct it to the way you want.

Enjoy!

Просто и быстро.

Madgoddess ()
Ответ на: комментарий от Madgoddess

Просто и быстро.

Ну я рад, что вы нашли костыль для решения вашей проблемы. Но в kde 4.14.2 этой проблемы нет, там можно изменить настройки мониторов как надо, затем сохранить их и они сохранятся в указанном файле как вызовы xrandr.

Вы могли просто написать скрипт с вызовами xrandr в ручную и добавить его в автозапуск.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Ты ему не разжевал что делать
switch to console mode: Alt+Ctrl+F1
kill x server: sudo service kdm stop
generate new xorg.conf file: sudo X -configure — this will create xorg.conf.new file in your current dir
от себя, в твоем хомяке будет лежать конфиг, а то вдруг не понятно
rename and move: sudo mv xorg.conf.new /etc/X11/xorg.conf
return to GUI: sudo start kdm
а вообще это бага обновления, притом описанная, помеченная как решенная, но сука я смотрю, появляются все новые страдальцы с удаленным ксоргкнофигом

anonymous ()
Ответ на: комментарий от kostik87

Просто пока не имею знаний в написании скриптов, так как совсем неумелый пользователь. Но так хоть какое-то решение найдено. Будем развиваться.

Madgoddess ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.