LINUX.ORG.RU

Ищи фрактала, он наверняка уже попробовал

feofan ★★★★★ ()

Я пробовал, ебилды давно есть

У меня не вышло. Приложения из KDE5 сыпали XCB ошибками, через раз отрисовывали значки, не уважали настройки Qt. Плазмой пользоваться было не возможно, а ещё в ней часы на час вперед шли.

Правда было это уже относительно давно, да и может дело было в плохой дружбе xcb с блобом nvidia. Собирается через сеты в одну команду. К сожалению иметь одновременно сессии KDE4 и KDE5 не получилось, но весь кдешный софт сносить тоже не надо.

Gary ★★★★★ ()
Ответ на: комментарий от Deleted


Плазма еще не релизнулась, а уже падает.


Да это-то как раз нормально. Было бы грустно, если б она падала после релиза.

blackst0ne ★★★★★ ()

Кто пробовал собрать KDE5 в Gentoo?

Тебе что-то мешает это сделать?

В оверлее kde уже появились пакеты.

Спасибо капитан.

init_6 ★★★★★ ()
Ответ на: комментарий от init_6

как уже бесят такие вот персонажи
человек просто оповестил нас всех о kde5 в оверлее kde, зачем так кидаться на него? спасибо бы сказал ему

ubuntuawp ★★ ()
Ответ на: комментарий от anonymous8

Конфликты с пакетами KDE4, в результате кучу софта нужно удалить, а порта ещё нет.

В chroot разверни stage3 с теми же USE флагами собери там kde5 в бинпакеты из которых обнови основную систему и профит?

init_6 ★★★★★ ()
Ответ на: комментарий от ubuntuawp

спасибо бы сказал ему

За что? Кому нужно, сам узнал бы. Здесь вам не убунта, люди поди читать умеют.

iVS ★★★★★ ()
Ответ на: комментарий от iVS

но в тоже время подписались 8 человек. Кому то интересно...

snaf ★★★★★ ()

Алло, это тут аниме под фрибзд патчат ?
:) пардон, не смог удержаться.

handbrake ★★★ ()

Пробовал. Всё ещё пользуюсь, но считаю, что в общем случае использовать пока рано.

Разработчики предлагают использовать новую плазму со старыми (KDE4) приложениями, но в Gentoo это затруднительно из-за множества блокировок и коллизий. Например: новая плазма просит новый KActivities, а KDE4 пакетам нужен старый KActivities.

В общем, пользуюсь пустой, еле-рабочей системой (DE) с konqueror'ом из KDE4, но без dolphin'a. Сделал пакеты для kate/kwrite, но остальное из kde-baseapps разработчики (gentoo) пока не принимают, потому что ожидают изменений в системе сборки.

В данный момент meta-пакеты (например, все приложения из kde-baseapps) собираются методом вырезания из CMake-файла информации обо всём, кроме собираемого пакета и нескольких общих файлов. Метод плох тем, что после каждого изменения набора общих файлов, приходится исправлять ebuild/eclass. Ожидаемое изменение позволит вместо редактирования файла конфигурации передавать CMake всего два параметра: запрет сборки всего опционального И разрешение сборки нужного пакета.

kaffeine ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.