LINUX.ORG.RU

xbmc backports debian

 , ,


0

1

Добрый вечер. Стоит lxde debian 7.4, подключены wheezy-backports, ядро 3.13-0.bpo.1-686-pae. Пытаюсь установить xbmc из backports:

sudo aptitude -t wheezy-backports install xbmc
Следующие НОВЫЕ пакеты будут установлены:        
  libavcodec54{ab} libavfilter3{a} libavformat54{a} libavresample1{a} 
  libavutil52{a} libswscale2{a} xbmc{b} xbmc-bin{ab} 
РЕКОМЕНДУЮТСЯ следующие пакеты, но автоматически они установлены НЕ БУДУТ:
  libvdpau1 
0 пакетов обновлено, 8 установлено новых, 0 пакетов отмечено для удаления, и 32 пакетов не обновлено.
Необходимо получить 34,7 MB архивов. После распаковки 78,0 MB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
 xbmc-bin : Зависит: libglew1.7 (>= 1.7.0) который является виртуальным пакетом.
            Зависит: liblzo2-2 но его установка не запланирована.
            Зависит: libmicrohttpd10 который является виртуальным пакетом.
            Зависит: libmysqlclient18 (>= 5.5.24+dfsg-1) но его установка не запланирована.
            Зависит: libpcrecpp0 (>= 7.7) но его установка не запланирована.
            Зависит: libpostproc52 (>= 5:0.git20120217~) но его установка не запланирована.
            Зависит: libpython2.7 (>= 2.7) но его установка не запланирована.
            Зависит: libsidplay2 но его установка не запланирована.
            Зависит: libssh-4 (>= 0.3.91) но его установка не запланирована.
            Зависит: libtag1c2a (>= 1.8) но установлен 1.6.3-1 и удерживается.
            Зависит: libtinyxml2.6.2 который является виртуальным пакетом.
            Зависит: libva-glx1 который является виртуальным пакетом.
            Зависит: libva1 (> 1.0.15~) но его установка не запланирована.
 xbmc : Зависит: fonts-liberation который является виртуальным пакетом.
        Зависит: python-imaging но его установка не запланирована.
 libavcodec54 : Зависит: libmp3lame0 который является виртуальным пакетом.
                Зависит: libopus0 (>= 1.1~beta) но его установка не запланирована.
                Зависит: libva1 (> 1.0.15~) но его установка не запланирована.
                Зависит: libx264-123 который является виртуальным пакетом.
                Зависит: libxvidcore4 (>= 1.2.2) который является виртуальным пакетом.
Следующие действия разрешат зависимости:

     Сохранить для следующих пакетов их текущие версии:
1)     libavcodec54 [Не установлен]                    
2)     libavfilter3 [Не установлен]                    
3)     libavformat54 [Не установлен]                   
4)     xbmc [Не установлен]                            
5)     xbmc-bin [Не установлен]                        



Принять данное решение? [Y/n/q/?] Y
Ни одного пакета не будет установлено, обновлено или удалено.
0 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 32 пакетов не обновлено.
Необходимо получить 0 B архивов. После распаковки 0 B будет занято.
Вот такая ошибка. Следовательно вопрос, как исправить зависимости и установить xbmc? Может есть более простые способы?


Принять данное решение? [Y/n/q/?]

Скажи N, будут предложены варианты скорее всего обновить что-нибудь и тогда сможешь поставить xbmc.

И, да, используй, пожалуйста, разметку в своих постах, читать же не удобно.

alozovskoy ★★★★★ ()
Последнее исправление: alozovskoy (всего исправлений: 1)
Ответ на: комментарий от kky

То есть когда «N» отвечаешь говорит что нет других вариантов? А, ну да. А почему из бэкпортов именно?

alozovskoy ★★★★★ ()
Ответ на: комментарий от alozovskoy

Принять данное решение? [Y/n/q/?] n

*** Больше решений нет ***

Проще всего, как я понял скоро выйдет xbmc 13 версия stable, и она по идее должна будет автоматом накатиться.

kky ()
Ответ на: комментарий от kky
aptitude-create-state-bundle /tmp/aptbundle 

Скинь файл на «почитать»

bkarm ()
Ответ на: комментарий от MyTrooName
#Debian-Russia
deb http://ftp.ru.debian.org/debian/ squeeze main non-free contrib 
deb-src http://ftp.ru.debian.org/debian/ squeeze main non-free contrib 
#GoogleChrome
deb http://dl.google.com/linux/chrome/deb/ stable main 
#Wheezy-backports
deb http://ftp.debian.org/debian wheezy-backports main contrib non-free
# Line commented out by installer because it failed to verify:
deb http://security.debian.org/ wheezy/updates main  
# Line commented out by installer because it failed to verify:
deb-src http://security.debian.org/ wheezy/updates main

Кажется я понял в чем косяк почему-то последние две ветки активны -_-

kky ()

Знаю про альтернативу, add-apt-repository http://blog.anantshri.info/howto-add-ppa-in-debian/. Но честно все-же хотелось решить встроенными функциями. Странно что нет в stable ветке xbmc, читал в новостях, что должно быть. Есть у кого какие идеи?

kky ()
Ответ на: комментарий от bkarm
aptitude update
aptitude upgrade
aptitude purge ~c

да сорри, я реально дурак, день сегодня такой. В стейбле есть 11 версия, в backports 12.3. оффтоп: в 12.3 не работает ни 1 плагин погоды, щас буду разбираться. Спасибо всем кто отписался.

kky ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.