LINUX.ORG.RU

vsftpd творит странное

 ,


0

2

Создал каталог для vsftpd внутри своего домашнего каталога. Структура- /home/sergey/FTP. Права на каталог:

drwxrw-rw- 2 sergey sergey 4096 марта 18 21:18 FTP

При этом, если я захожу на 127.0.0.1/внешний айпи по FTP, то оказываюсь не в сабжевом каталоге, а в своем домашнем! Конфиг vsftpd (что изменил, тут все для своих, безопасности нет):

write_enable=YES
local_enable=YES
anon_upload_enable=YES
listen_port=21
/etc/passwd:

ftp:x:117:125:ftp daemon,,,:/home/sergey/FTP:/bin/false

Что за хрень и как вылечить?

★★

Ответ на: комментарий от mky

Если каталог принадлежит sergey:sergey, то под anonymous (без ввода данных либо же с вводом anonymous) меня не пускает. Если принадлежит ftp:ftp, то авторизация не требуется, но в обоих случаях меня пускает в домашний каталог sergey.

Valdor ★★ ()
Ответ на: комментарий от Valdor

под anonymous

ИМХО надо написать в конфиге ещё

anon_root=/home/sergey/FTP
anonymous_enable=YES
ну и возможно, чтобы анонимус мог создавать каталоги
anon_mkdir_write_enable=YES

OldManClone ★★ ()
Ответ на: комментарий от Valdor

Конечно, я не большой спец в этом деле, но попадал в ситуацию, когда настройки для входа анонимом и для входа юзером мешали друг другу... Пришёл к тому, что написал в конфиге только нужные опции и выкинул весь мусор (хотя это и не канонiчно)... Короче, вот весь мой конфиг (и УМВР):

anon_root=/home/ftp
anonymous_enable=YES
write_enable=YES
anon_upload_enable=YES
anon_mkdir_write_enable=YES
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
chown_uploads=YES
chown_username=ftp
ftpd_banner=Welcome to FTP service.
listen=YES

OldManClone ★★ ()
Последнее исправление: OldManClone (всего исправлений: 2)

Изменение домашней директории пользователя ftp влияет только на анонимного пользователя. Т.е. vsftpd в любом случае считает начальной (но не корневой) директорией домашнюю для конкретного пользователя.

ValdikSS ★★★★★ ()
Ответ на: комментарий от ValdikSS

Хомяк для ftp сменил сразу при установке и перезапускал многоразово.

sergey@localhost ~ $ sudo service vsftpd restart
vsftpd stop/waiting
vsftpd start/running, process 10585
sergey@localhost ~ $ cat /etc/passwd | grep ftp
ftp:x:117:125:ftp daemon,,,:/home/sergey/FTP:/bin/false
sergey@localhost ~ $ ls -la /home/sergey/ | grep FTP
drwxrw-rw-  2 ftp    ftp         4096 марта 18 21:18 FTP
sergey@localhost ~ $
При этом без лога/пасса не пускает, при вводе лога/пасса root не пускает, при вводе лога/пасса sergey пускает в хомяк sergey.

Valdor ★★ ()
Ответ на: комментарий от OldManClone

С такими настройками просит авторизацию, но не пускает вообще никак. Перезапускал сервер. Какие у вас выставлены права?

Valdor ★★ ()
Ответ на: комментарий от ValdikSS

На данный момент (с конфигом от оратора OldManClone выше + local_enable=YES):

Ответ:	220 Welcome to FTP service.
Команда:	USER anonymous
Ответ:	331 Please specify the password.
Команда:	PASS **************
Ответ:	500 OOPS: vsftpd: refusing to run with writable root inside chroot()
При анонимусе. За Юзера пускает в хомяк юзера и там можно что угодно делать (всё закономерно). Права на /home/sergey/FTP: чтение и запись всем, ftp:ftp. Мне хотелось бы доступ анонимусу дать, + чтобы пускало не в хомяк, а в FTP. В /etc/passwd указан /home/sergey/FTP как хомяк ftp.

Valdor ★★ ()
Ответ на: комментарий от Valdor

Какие у вас выставлены права?

andrey@x40:/$ ls -la home | grep ftp
drwxr-xr-x  5 root   root   4096 Apr  7  2012 ftp

В /etc/passwd указан /home/sergey/FTP как хомяк ftp.

На вход анонимом это не влияет. А man vsftpd.conf говорит, что:

anon_root
This option represents a directory which vsftpd will try to change into after an anonymous login. Failure is silently ignored.
Default: (none)

Больше версий нет, sorry.

OldManClone ★★ ()
Ответ на: комментарий от Valdor

Эх, печаль беда.

Да ладно, пусть не получается с vsftpd, так что, других ftp-серверов нет, что ли? Попробуйте что-то ещё...

OldManClone ★★ ()
Ответ на: комментарий от Valdor

Ну вам же он явно говорит, что refusing to run with writable root inside chroot(). Либо выставляйте chmod -w /home/sergey (или /home/sergey/FTP, не уверен), либо выключайте chroot, но тогда можно будет по всей ФС ходить.

ValdikSS ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.