LINUX.ORG.RU

Проблема с shutdown.


0

1

При попытке выключения:

sudo shutdown now
Вылетает вот такая ошибка:
Welcome to rescure mode! Type "systemctl default" or ^D to enter default mode.
Type "journalctl -xb" to view system logs. Type "systemctl reboot" to reboot.
Give root password for maintenance
При этом при использовании halt и «shutdown -r now» подобных проблем не возникает. Как можно исправить?


Ed man, man ed!

shutdown does its job by signalling the init process, asking it to change the runlevel. Runlevel 0 is used to halt the system, runlevel 6 is used to reboot the system, and runlevel 1 is used to put to system into a state where administrative tasks can be performed; this is the default if neither the -h or -r flag is given to shutdown.

beastie ★★★★★ ()
Ответ на: комментарий от batekman
-- Unit user.slice has finished shutting down.
Jan 29 18:19:34 localhost systemd[10207]: Failed at step EXEC spawning /bin/plym
-- Subject: Process /bin/plymouth could not be executed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: http://www.freedesktop.org/wiki/Software/systemd/catalog/64125
-- 
-- The process /bin/plymouth could not be executed and failed.
-- 
Selat ()

С halt тоже проблема:

WARNING: could not determine runlevel - doing soft halt
  (it's better to use shutdown instead of halt from the command line)

Broadcast message from root@localhost (pts/2) (Wed Jan 29 18:28:08 2014):

The system is going down for system halt NOW!
shutdown: timeout opening/writing control channel /dev/initctl
init: timeout opening/writing control channel /dev/initctl


Selat ()
Ответ на: комментарий от batekman
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda1       /boot   ext2    defaults,noatime        0 2
/dev/sda2       none    swap    sw                      0 0
/dev/sda1       /       ext4    noatime                 0 1
proc            /proc   proc    defaults                0 0

По-моему где-то там вместо sda1 должно быть sda3. Проблема возникла после нескольких неудачных попыток заставить запускаться dwm (т.е. я правил только конфиги systemd). Странно, что до этого ничего не падало с таким конфигом.

Selat ()
Ответ на: комментарий от emulek

если честно - хз, но сам везде ставлю на всякий случай, а то иной раз подумаешь «я тут самый умный, поудаляю-ка я что мне не нравится» - и сидишь потом ночью всё переделываешь, не высыпаешься и злишься на весь мир

batekman ★★★ ()
Ответ на: комментарий от batekman

если честно - хз

AFAIK в мане написано, что defaults только если все опции по дефолту. Если хоть одна задана, то её и достаточно. Просто поле из НЕпробелов должно быть по синтаксису. Т.е. хоть что-то туда вписать надо. Defaults это затычка.

PS: и да, noatime это зло. Давно уже есть relatime, и оно в дефолте.

emulek ()
Ответ на: комментарий от Selat

Конечно, работает. У вас на самом деле всё правильно работает согласно документации, которую вы не читали.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.