LINUX.ORG.RU
ФорумAdmin

lightsquid index.cgi


0

1

Доброго времени суток.
debian7, squid3, lightsquid.
все файлы lightsquid располагаются в /var/www/lightsquid, *.cgi, *.pl получили разрешение на исполнение, chek-setup.pl отрабатывает нормально, lightparser.pl тоже, с debug=1 показывает какое кол-во строк отпарсил, файла httpd.conf после установки apache2 не существовало, создал, содержимое:


Alias /lightsquid /var/www/lightsquid
[br]<Directory "/var/www/lightsquid">
   [br]Options ExecCGI
   [br]AddHandler cgi-script .cgi .pl
   [br]AllowOverride All
[br]</Directory>

т.е. разрешение на исполнение cgi есть, cgi-script определены. [vr]на каталог /var/www/lightsquid владельцем установлен www-data рекурсивно, единственно после создания статистики в /var/www/lightsquid/report владельцем репорта является root.


Проблема: при переходе по http://имя_машины/lightsquid или http://имя_машины/lightsquid/index.cgi отображается содержимое файла index.cgi, а не веб лицо лайтсквида.

Ответ на: комментарий от Eddy_Em

Да, права 755.
Сделал AllowOverride None, ничего не изменилось. А смысл в этом, у меня в /var/www/lightsquid/.htaccess :

Options FollowSymLinks ExecCGI
[br]DirectoryIndex index.cgi

nokogerra ()
Ответ на: комментарий от nokogerra

DirectoryIndex index.cgi

С этим оно тебе должно скрипт выполнять при переходе просто по http://имя_машины/lightsquid. Кстати, а почему не http://имя_машины?

Может, ты просто ссылочку неправильно пишешь, вот оно тебе вместо запуска CGI и фигачит содержимое? Корневая директория какая?

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от Eddy_Em

Извиняюсь, тут не совсем понял.
.htaccess лежит в /var/www/lightsquid/, там же лежат все скрипты cgi, pl, и в том числе index.cgi, я так и написал в первом посте что при переходе по http://имя_машины/lightsquid выдает просто содержимое, как и при переходе на http://имя_машины/lightsquid/index.cgi (т.е. и то, и то попробовал).
Просто http://имя_машины не использую, т.к. апач еще используется режиком, да и мне более наглядным кажется именно http://имя_машины/lightsquid, но разницы-то в общем нет.
p.s. самое интересное в том, что я делал точно также на другой машине, конфиги httpd.conf, ligthsquid.cgf 1в1, на сабжевой машине я даже добавил Options ExecCGI, на первой и без этой опции все работает о_О я в недоумении. Может такое быть из-за того что создал руками httpd.conf? Хотя в init скриптах апача на обоих машинах в разделе httpd разницы нет.

nokogerra ()
Ответ на: комментарий от nokogerra

Решено: в debian 7 в apache2.conf отсутствует строка «Include httpd.conf», включил - работает.

nokogerra ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.