LINUX.ORG.RU
ФорумAdmin

Шлюз на Debian режет скорость

 , ,


0

1

Имеется шлюз на свежеустановленном Debian stable: eth0 - провайдер (ethernet, белый ip), eth1 - внутренняя сеть. канал 125/125 Мбит, однако speedtest у пользователей показывает не больше 45 мбит. Шейперов никаких нет, лишних правил в iptables тоже. В это же время с сервера speedtest показывает стабильно 125/125 Мбит. В чем может быть проблема, подскажите в какую сторону копать || по какому запросу идти в гугл? Проблемы с eth1, я так полагаю?

ifconfig:

eth0      Link encap:Ethernet  HWaddr *:*:*:*:*:*
          inet addr:*.*.*.*  Bcast:*.*.*.*  Mask:*.*.*.*
          inet6 addr: fe80::96de:80ff:fe6b:d255/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:42253960 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33768221 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:37437383219 (34.8 GiB)  TX bytes:14956391525 (13.9 GiB)
          Interrupt:20 Memory:f0500000-f0520000

eth1      Link encap:Ethernet  HWaddr *:*:*:*:*:*
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::cad3:a3ff:fe83:ced3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:33906032 errors:0 dropped:0 overruns:0 frame:0
          TX packets:38023937 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:14416444324 (13.4 GiB)  TX bytes:36896172667 (34.3 GiB)
          Interrupt:19 Base address:0xe000

ethtool:

Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 2
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: on
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes

Settings for eth1:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        MDI-X: Unknown
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes


lspci | grep Ethernet:

00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-V (rev 04)
03:00.0 Ethernet controller: D-Link System Inc DGE-528T Gigabit Ethernet Adapter (rev 10)
Intel - eth0, D-Link - eth1


iperf-ом в локалке не пробовал скорость проверять ? Нет ли в локалке каких-то проблем ?

Клиенты разные (win/lin) ?

vel ★★★★★ ()
Ответ на: комментарий от vel

проблемы с локалкой исключаю, ибо раньше интернет раздавал windows server 2008 - все было в порядке. После перехода на Debian появилась такая проблема

blrk ()

speedtest-ом мерять скорость - это сильно :)

iperf в руки :)

P.S. libastral подсказывает что «виновником торжества» будет ISP

black_13 ()
Ответ на: комментарий от black_13

Кстати довольно честно показывает, погрешность - не более 10%.

invokercd ★★★★ ()

А может clamp mtu mss?

anonymous ()
Ответ на: комментарий от blrk

Я бы посмотрел и отключил на сетевушках шлюза всякие tso и lro. А iperf все же есть смысл запустить.

vel ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.