LINUX.ORG.RU
ФорумAdmin

Помогите настроить OpenWRT.

 , , , ,


0

1

Захотел сделать из точки доступа маршрутизатор, но c OpenWRT пока не справился. Помогите, пожалуйста.

Итак, имеется точка доступа Asus WL-320gE. На ней установлена OpenWRT-10.03.1. Хочу по кабелю подключаться к сети провайдера (Билайн), через PPPoE подключаться к интернетам и раздавать их по WiFi.

Что нужно написать в секции switch файла /etc/config/network? Я вообще не понял о чём она. Нужны ли мне VLAN'ы? Они используются для настройки работы железа, в смысле беспроводной интерфейс в один VLAN, проводной в другой, или для чего-то ещё?

Что будет в секции interfaces? Правильно я понимаю, что у меня будет 3 интерфейса: (примерно с такими названиями) ppp, eth, wlan?

Где в OpenWRT включить сервер DHCP чтобы раздавать IP'шники подключающимся по WiFi?

Где в OpenWRT настраивается WiFi? Всякие SSID, WPA2, passphrase.

★★★★★

поставь luci и настрой через гуй

daemonpnz ★★★★★ ()
/etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option ifname 'eth0.1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.0.1'

config interface 'wan'
	option ifname 'eth0.2'
	option _orig_ifname 'eth0.2'
	option _orig_bridge 'false'
	option proto 'pppoe'
	option username 'нискажу@beltel.by'
	option password 'нискажу'

config switch
	option name 'eth0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'eth0'
	option vlan '1'
	option ports '0t 2 3 4 5'

config switch_vlan
	option device 'eth0'
	option vlan '2'
	option ports '0t 1'

/etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option macaddr 'f8:1a:67:4c:d8:a7'
	option hwmode '11ng'
	option htmode 'HT20'
	list ht_capab 'LDPC'
	list ht_capab 'SHORT-GI-20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'TX-STBC'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option txpower '27'
	option country 'US'

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'PuchuuHome'
	option encryption 'psk2+tkip+ccmp'
	option key 'нискажу'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option macaddr 'f8:1a:67:4c:d8:a8'
	option hwmode '11na'
	option htmode 'HT20'
	list ht_capab 'LDPC'
	list ht_capab 'SHORT-GI-20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'TX-STBC'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option disabled '1'

config wifi-iface
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

punya ★★ ()
Ответ на: комментарий от punya

Разбор.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

Понимаю.

config interface 'lan'
	option ifname 'eth0.1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.0.1'

Это физический интерфейс? Зачем делать его типа bridge?

config interface 'wan'
	option ifname 'eth0.2'
	option _orig_ifname 'eth0.2'
	option _orig_bridge 'false'
	option proto 'pppoe'
	option username 'нискажу@beltel.by'
	option password 'нискажу'

Обязательно писать так, или интерфейс можно назвать ppp?

Я вижу конфигурацию трёх интерфейсов считая lo. Где же конфигурация беспроводной сети?

config switch
	option name 'eth0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'eth0'
	option vlan '1'
	option ports '0t 2 3 4 5'

config switch_vlan
	option device 'eth0'
	option vlan '2'
	option ports '0t 1'
Создание двух VLAN'ов, зачем оно?

В меру моего непонимания мне казалось, что у меня должны быть настройки для четырёх интерфейсов: lo (static 127.0.0.1), eth (dhcp), ppp (pppoe) и wlan (static 192.168.1.1). Ещё в iptables должно быть правило для NAT'а. И настроен сервер DHCP для раздачи адресов на интерфейсе wlan. ЧЯДНТ? Зачем VLAN'ы?

Camel ★★★★★ ()
Ответ на: комментарий от punya

Вдогонку.

В любом случае спасибо вам за поддержку. В диалоге с вами я сам почти понял что делаю.

Camel ★★★★★ ()
Ответ на: Разбор. от Camel

vlan-ы нужны. первый отвечает за wan (1 порт), второй за lan (4 порта). bridge для того, чтобы 4 порта lan работали как мост =) название «wan» можно поменять.

punya ★★ ()
Ответ на: комментарий от punya

VLAN'ы нужны?

vlan-ы нужны. первый отвечает за wan (1 порт), второй за lan (4 порта). bridge для того, чтобы 4 порта lan работали как мост =) название «wan» можно поменять.

У меня только один порт 8P8C (или как их ещё называют RJ-45). Этим портом (я называю его eth) я подключусь к сети провайдера, а дома все устройства подключаются к беспроводной сети.

Camel ★★★★★ ()
Ответ на: комментарий от punya

VLAN'ы нужны.

Похоже VLAN'ы таки нужны.

Specific Configuration

The WL-320gE and WL-320gP have one LAN port only, however it seems to be connected internally as switch port 3. So your switch configuration should look something like this:

config 'switch' 'eth0'
  option 'reset' '1'

config 'switch_vlan' 'eth0_3'
  option 'device' 'eth0'
  option 'vlan' '0'
  option 'ports' '3 5*' 

Можете пояснить что это значит? В какое место подключена сетевуха с разъёмом 8P8C, в какое место подключена вайфайка?

Camel ★★★★★ ()
Ответ на: VLAN'ы нужны. от Camel

ммм. даже не знаю. у моего 3g-шного такого нету

punya ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.