LINUX.ORG.RU
ФорумAdmin

debian dependencies troubles.


0

0

distr debian sarge.
пытаюсь удалить exim4 из системы
#aptitude purge exim4-base
Reading Package Lists... Done
Building Dependency Tree
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
The following packages are unused and will be REMOVED:
exim4-config
The following packages will be automatically REMOVED:
at exim4-daemon-light mailx mutt mysql-server
The following packages will be REMOVED:
at exim4-base exim4-daemon-light mailx mutt mysql-server
0 packages upgraded, 0 newly installed, 7 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 16.2MB will be freed.
Do you want to continue? [Y/n/?]

в зависимости к exim каким-то боком попал mysql-server .

как можно обьяснить aptitude , dpkg ... , что надо удалить только exim и не трогать mysql-server

подскажите плиз. в мануале по aptitude ничего не нашел.

anonymous

Re: debian dependencies troubles.

> в зависимости к exim каким-то боком попал mysql-server

Ну, почту, наверное админу хочет отсылать.

> как можно обьяснить aptitude , dpkg ... , что надо удалить только exim и не трогать mysql-server

Этого делать не надо. В Debian depends - это пакеты, без которых данный _работать_не_будет_. Прочие - в recommends и suggests. Если тебе мешает почтовик, светящий портами наружу, сделай dpkg-reconfigure exim4 и выбери вариант работы Local only.

А вообще, dpkg --force-depends.

watashiwa_daredeska ★★★★ ()
Ответ на: Re: debian dependencies troubles. от anonymous

Re: debian dependencies troubles.

да забыл
>dpkg-reconfigure exim4 не работает , надо так
#dpkg-reconfigure exim4-config.

anonymous ()

Re: debian dependencies troubles.

мэйлер системе нужен. Не хочешь exim, поставь sendmail. Но мэйлер нужен.

Eldhenn ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.