LINUX.ORG.RU
ФорумAdmin

Ломает: initramfs-tools:i386 при попытке поставить ядро 3.9


0

2

дебиан 7 wheezy, amd64

проблемы с ext4 достигли предела - он умер не только с черным экраном, но и с несмолкаемым воем спикера, а кулер раскалился до предела, так что я обжег палец, зажимая кнопку выключения на ноуте

и на экране были все те же ошибки про запись в ext4

решил обновить ядро до 3.9
скачал сорцы, скомпилил, поставил - при загрузке нет инета через wi-fi, видимо ядро не поддерживает карту Atheros AR9285

попробовал поставить из репозитория:

sudo apt-get install linux-image-3.10-rc5-amd64

Пакеты, имеющие неудовлетворённые зависимости:
linux-image-3.10-rc5-amd64 : Ломает: initramfs-tools (< 0.110~) но 0.109.1 будет установлен
Ломает: initramfs-tools:i386 (< 0.110~)
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.



Так я не понимаю, он собирается поставить более старую версию? Почему тогда не ставит? И где вообще логика - для более нового ядра - ставить старый initramfs. Если же наоборот надо обновить - то как?

И почему везде советуют бэкпорты, если это наоборот старьё.

Также, почему пишет initramfs-tools:i386, когда у меня amd64?

UPDATE
решилось установкой ядра 3.10 отсюда:

http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/

в нем есть вай-фай

теперь осталось убедиться что больше не будет адских черных экранов с ошибками ext4

проблемы с ext4 достигли предела - он умер не только с черным экраном, но и с несмолкаемым воем спикера, а кулер раскалился до предела,

Это скорее всего аппаратные проблемы.

vlb ★★★ ()

скомпилил ... нет инета через wi-fi ... видимо ядро не поддерживает карту Atheros AR9285

Как сконфигурировали, так и собрали.

дебиан 7 wheezy, ... попробовал поставить из репозитория ... linux-image-3.10-rc5-amd64

Вы, что из sid ставите ядро ? В стабильной ветке (wheezy) только 3.2.0 http://packages.debian.org/wheezy/linux-image .

И почему везде советуют бэкпорты, если это наоборот старьё.

В «бэкпорты» помещают пакеты, портированные из более новых версий релизов Debian, testing, в частности для более старых релизов, в том числе и текущий stable.

решилось установкой в Debian ядра Ubuntu

Вообще с таким отношением к Debian странно, что он у вас ещё работает.

Это не rolling-release дистрибутив, нет, ветки вы, конечно, смешивать можете, но не бездумно.

Если вам нужен rolling-release дистрибутив, то переходите на Arch Linux или Gentoo.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)

какой-то ад. сорри что неинформативно\неконструктивно, но не смог удержаться.

Bers666 ★★★★★ ()

Так я не понимаю, он собирается поставить более старую версию? Почему тогда не ставит? И где вообще логика - для более нового ядра - ставить старый initramfs.

Пакет с новым ядром хочет новый initramfs-tools. Но выставленные приоритеты не позволяют поставить новый initramfs-tools автоматически. Поэтому будет установлен (или оставлен) старый. При этом пакет с новым ядром окажется «сломанным».

Если же наоборот надо обновить - то как?

Раз ты ставишь ядро из experimental, поставь и initramfs-tools из experimental. Или где там лежит новый initramfs-tools.

Я бы не советовал на stable ставить пакеты из experimental.

i-rinat ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.