LINUX.ORG.RU
ФорумAdmin

Debian. PXE Boot.

 , ,


0

1

Добрый день, уважаемые!

Пытаюсь организовать установку debian по сети через pxe. Все получается, но имеется одна проблемка.

В конфиге dhcpd клиенты разделяются на несколько классов: unknown clients, known и собственно pxeclients. В зависимости от класса - выдаются адреса из различных пулов.

При начальной загрузке pxe клиента ему выдается адрес из соответствующего пула. Здесь все ОК. Начинается начальная загрузка и когда процесс доходит до определения сетевых настроек - клиент получает адрес из другого пула - unknown clients. Вот это меня и не устраивает - я хочу, чтобы адрес был из пула, предназначенного для pxe клиентов. Конечно можно внести конкретные MAC адреса в пул, предназначенный для pxe клиентов, (или при установке вводить настройки сети вручную) но хочется все же автоматизации.

Подскажите как можно выкрутится из этой ситуации?

Спасибо!

★★

А ты их по какому признаку различаешь, пулы-то? От этого и пляши.

anonymous ()
Ответ на: комментарий от anonymous

Различаю вот так:

match if substring (option vendor-class-identifier, 0, 3)="PXE";

Но толку от этого мало. Когда дело доходит до инсталятора дебиана он запрашивает IP уже с другим идентификатором. Хочется сохранить выданный ранее через pxe boot ip-шник.

swarnk ★★ ()
Ответ на: комментарий от swarnk

Ну всё правильно, в начале у тебя IP адрес запрашивает код pxelinux и передаёт соответствующий идентификатор, сообщающий о том, что это PXE. Потом pxelinux загружает ядро и initramfs и передаёт ему управление, затем уже ядро запрашивает IP адрес, естественно это уже не PXE клиент и идентификатор другой.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Да, все так. Я это понимаю. Черт, видимо никак не сделать так, как мне хочется.

swarnk ★★ ()
Последнее исправление: swarnk (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.