LINUX.ORG.RU
ФорумAdmin

ftp


0

0

Всем привет. Требовалось запретить юзеру выходить выше своего каталога. Я в ftpaccess прописал guestuser user1 (у меня wu-ftp). Теперь если коннекчусь из командной строки , то все работает и юзер не выходит выше своего каталога (домашнего).НО! Теперь я немогу подконнектиться ни одним ftp клиентом, даже когда выставляю в клиенте начальную дирректорию == home дирректории юзера , то все-равно почему то ftp-клиент коннектиться к каталогу / , ну и не может получить список файлов . Используемые клиенты - CuteFtp,asona,WindCommander. HELP !

anonymous

Re: ftp

а не надо выставлять ==home ;)
дело в том что при таком раскладе юзер зашедшеий по фтп попадает
в свой home и ничего выше не видит
соответственно и команда ls (чтоб увидеть список файлов) ему тоже не доступна
поэтому надо либо ~/bin/ls ему сделать и разрешить его исполнять
а лучше скомпилить wu-ftpd с --enable-ls

http://www.wu-ftpd.org/HOWTO/guest.HOWTO
тут написано что делать чтоб то что тебе нужно работало

Удачи!

anonymous ()

Re: ftp

где-то я ошибся. делал все как написано в этом howto ,в итоге cuteftp заходит уже не в / а в /user. А вот ls - не хотит. Может я ее неправильно переписал в папку /bin. Кстати - а почему из командной строки все работает , и ls и все остальное. Не работает только в ftp-клиентах всяких. Причем из командной строки все работает даже без всяких chroot. Почему ? И как все-таки сделать чтоб работали ftp-клиенты ? Спасибо.

anonymous ()

Re: ftp

а ты посмотри какую команду говорит твой фтп клиент?
у cuteftp вроде лог есть
мне сдаёться что не ls ;)
а команды типа dir list итп он помоему перестаёт воспринимать если собран --enable-paranoid
но я могу ошибаться давно дело было

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.