LINUX.ORG.RU
ФорумAdmin

Cisco + Microtik + 4Gbps LAG

 , , , ,


0

1

Всем доброе время суток, господа.

Имеем:

1. Cisco 6509 на SUP720-3B, имеет WS-X6516-GBIC и 2 WS-X6148-GE-TX (которые фабрику не умеют, к сожалению)

2. AMD какой-то FX (не помню точно какой) на 6 ядрах, 2ГБ оперативы (1.4 свободно), 2 платы Intel 82580 4-портовых, BGP с FullView на 2 аплинка, лицензия Mikrotik 6го уровня

3. 2 x Intel Xeon E5520 (в сумме 8 ядер, с HT - 16, HT включен), 6ГБ оперативы, Linux 2.6.32, 2 платы Intel 82580 4-портовых. Проводки UTP CAT 6 :)

Для общего понимания - всё это счастье выполняет маршрутизацию, подсчет трафика и некий аккаунтинг с шейпингом, но суть не в этом.

Схема включения следующая: Cisco => Mikrotik => Linux => та же Cisco, на каждом из линков по 4-кабельному 802.3ad (LACP Rate: 1s, Transmit Hash Policy: L2+3), циска Slave в обоих случаях. L2 кольца нет, т.к. на циске всё ессно развиланено :) между Cisco и Mikrotik идут аплинки (напрямую без циски включить не имеем возможности), далее идет локалка. Linux работает прозрачно, br0 из bond*, L3 интерфейсов на магистрали не имеет.

Внимание, вопрос: Сумма проходящего трафика (входящий+исходящий) составляет ~1700 Мбит. Значительных дропов нигде нет, error-ов нет вообще. Заметили, что уже некоторое время входящий трафик не поднимается выше 1100-1200 Мбит, хотя должен как минимум со временем. Вытащили Linux из цепи на профилактику, и чтобы не оставлять её безжизненной, было принято решение пустить внутреннюю часть трафика обратно по тому же LAG-у между Cisco и Microtik, но в другом вилане: 1700 Мбит в каждую сторону, имеющегося LAG-а должно было хватить с головой даже на такое. Перекинули, трафик шел. Но граница - около тех же 1100, держится достаточно ровно, +-10мбит, при этом ессно наблюдается дикое падение скорости и весомые потери, т.к. вместо 1700 проходит только 1100. По возвращению Linux-а в строй точно так же не удалось протянуть скорости выше тех же 1100. Эта цифра, 1100 Мбит, мне уже снится, хотя это явно не граница потребления на данный момент.

Краткое резюме: трафик по 4-портовому LAG-у между Cisco и Microtik не поднимается выше 1100мбит в одну сторону ни при каких условиях, будто там реально не 4 гигабита, а лишь 1.1. Значительных потерь при этом нет, просто тормоза. Циска загружена на <8%, Microtik в сумме <40%. Вроде как когда-то протягивали 1300 в пиках, но это было давно и не правда.

Уважаемые коллеги, ЧЯДНТ?

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configur...

«The WS-X6148-GE-TX and WS-X6148V-GE-TX switching modules do not support more than 1 Gbps of traffic per EtherChannel»

И эт самое... 6148 уже в глубоком EoL, с LDoS-ом в конце 2014. Поменяйте их уже на 6748. А шасси, если не "-E", уже LDoS с ноября 2012.

frob ★★★★★ ()
Последнее исправление: frob (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.