LINUX.ORG.RU
ФорумAdmin

Пропадает сеть Asus RT-N16 + BCM4313 802.11b/g/n

 , , ,


0

1

На ноуте, с гентой на борту и драйвером из ядра для BCM4313, эпизодически блокируется/теряется соединение с роутером Asus RT-N16. Проявляется это когда выкачиваются большие объемы данных будь-то с диска, который подключен к маршрутизатору, или же с инета через торренты. Дисконнект видно по ping,т.е.: был и резко пропал, хотя, что NM, что Wicd говорят об отличном соединении в виду чего напрашивается вывод, что трафик блокируется(или я хз, что там еще может произойти). При этом, на девайсах под андроидом все работает норм.

На других роутерах не проявляется, даже на хитровыдуманных Йотах все работает отлично, единственно где были похожие проблемы это TP-Link, модель которого не помню, но он сам по себе был жутко глючным.

Как побороть эту проблему?

★★★★★

Ответ на: комментарий от Pinkbyte

Ага, еще посмотрел в конфиге ядра, энергосбережение отключено

fang90 ★★★★★ ()

Проблема частично решилась - установил broadcom-sta.Теперь такой вопрос:

ERROR @wl_cfg80211_get_station : Could not get rate (-1)
ERROR @wl_cfg80211_get_station : Could not get rate (-1)
ERROR @wl_cfg80211_get_station : Could not get rate (-1)
ERROR @wl_cfg80211_get_station : Could not get rate (-1)
ERROR @wl_cfg80211_get_station : Could not get rate (-1)
ERROR @wl_cfg80211_get_station : Could not get rate (-1)
ERROR @wl_cfg80211_get_station : Could not get rate (-1)
WTF? И как от этого избавиться?

Кроме wl, все остальные модули отправлены в blacklist. Ядро 3.5.0-gentoo на x86_64.

fang90 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.