LINUX.ORG.RU
ФорумAdmin

Не могу установить rpm 4.2.1


0

0

Red hat 9.0
У меня перестал работать rpm. Тут где-то в сказали, что надо его обновить до 4.2.1
Устанавливаю из исходников
make выдает ошибки:

In file included from digest.c:6:
rpmio_internal.h:12:26: beecrypt.api.h: No such file or directory
rpmio_internal.h:16:22: beecrypt.h: No such file or directory
rpmio_internal.h:17:20: base64.h: No such file or directory
rpmio_internal.h:18:17: dsa.h: No such file or directory
rpmio_internal.h:19:24: endianness.h: No such file or directory
In file included from rpmio_internal.h:20,
                 from digest.c:6:
/usr/include/md5.h:27: parse error before "UINT4"
/usr/include/md5.h:30: parse error before '}' token
/usr/include/md5.h:38: parse error before "PROTO_LIST"
/usr/include/md5.h:39: parse error before "PROTO_LIST"
/usr/include/md5.h:41: parse error before "PROTO_LIST"
/usr/include/md5.h:43: parse error before "PROTO_LIST"
rpmio_internal.h:22:17: rsa.h: No such file or directory
rpmio_internal.h:23:19: rsapk.h: No such file or directory
rpmio_internal.h:24:18: sha1.h: No such file or directory
In file included from digest.c:6:
rpmio_internal.h:80: parse error before "mpbarrett"
rpmio_internal.h:80: warning: no semicolon at end of struct or union
rpmio_internal.h:81: warning: type defaults to `int' in declaration of `q'
rpmio_internal.h:81: warning: data definition has no type or storage class
rpmio_internal.h:82: parse error before "g"
rpmio_internal.h:82: warning: type defaults to `int' in declaration of `g'
rpmio_internal.h:82: warning: data definition has no type or storage class
rpmio_internal.h:83: parse error before "y"
rpmio_internal.h:83: warning: type defaults to `int' in declaration of `y'
rpmio_internal.h:83: warning: data definition has no type or storage class
rpmio_internal.h:84: parse error before "hm"
rpmio_internal.h:84: warning: type defaults to `int' in declaration of `hm'
rpmio_internal.h:84: warning: data definition has no type or storage class
rpmio_internal.h:85: parse error before "r"
rpmio_internal.h:85: warning: type defaults to `int' in declaration of `r'
rpmio_internal.h:85: warning: data definition has no type or storage class
rpmio_internal.h:86: parse error before "s"
rpmio_internal.h:86: warning: type defaults to `int' in declaration of `s'
rpmio_internal.h:86: warning: data definition has no type or storage class
rpmio_internal.h:89: parse error before "rsa_pk"
rpmio_internal.h:89: warning: type defaults to `int' in declaration of `rsa_pk'
rpmio_internal.h:89: warning: data definition has no type or storage class
rpmio_internal.h:90: parse error before "m"
rpmio_internal.h:90: warning: type defaults to `int' in declaration of `m'
rpmio_internal.h:90: warning: data definition has no type or storage class
rpmio_internal.h:91: parse error before "c"
rpmio_internal.h:91: warning: type defaults to `int' in declaration of `c'
rpmio_internal.h:91: warning: data definition has no type or storage class
rpmio_internal.h:92: parse error before "rsahm"
rpmio_internal.h:92: warning: type defaults to `int' in declaration of `rsahm'
rpmio_internal.h:92: warning: data definition has no type or storage class
digest.c: In function `rpmDigestInit':
digest.c:58: `md5Param' undeclared (first use in this function)
digest.c:58: (Each undeclared identifier is reported only once
digest.c:58: for each function it appears in.)
digest.c:62: `md5Reset' undeclared (first use in this function)
digest.c:63: `md5Update' undeclared (first use in this function)
digest.c:64: `md5Digest' undeclared (first use in this function)
digest.c:71: `sha1Param' undeclared (first use in this function)
digest.c:75: `sha1Reset' undeclared (first use in this function)
digest.c:76: `sha1Update' undeclared (first use in this function)
digest.c:77: `sha1Digest' undeclared (first use in this function)
make[2]: *** [digest.lo] Ошибка 1
make[2]: Выход из каталог `/home/vasya/install/rpm/4_2_1/rpm-4.2.1/rpmio'
make[1]: *** [all-recursive] Ошибка 1
make[1]: Выход из каталог `/home/vasya/install/rpm/4_2_1/rpm-4.2.1'
make: *** [all] Ошибка 2
[root@localhost rpm-4.2.1]#

установил beecrypt 2.1.0 - не помогло

Re: Не могу установить rpm 4.2.1

>Устанавливаю из исходников

ССЗБ :)

chucha ★★★☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.