LINUX.ORG.RU
ФорумAdmin

Apache не подключает php?


0

0

Ситуация такова. Собрал Апач 1.3.31 с поддержкой mod_ssl и openssl. Все собралось хорошо. В httpd.conf указываю DocumentRoot на папочку где есть интранетовский сайт. При попытке зайти браузером на сайт получаю код страницы. Прописываю в httpd.conf AddType application/x-httpd-php .php Результат - открывается содержимое корня сайта в виде файлов в браузере и при попытке кликнуть на index.html мне предлагается выбрать что с ним делать: сохранить на диск или открыть любым другим приложением.

Парни, как мне это излечить? Толи php не работает, толи апач не правильно работает с php или, блин еще чего? Короче засада...

★★★

Re: Apache не подключает php?

index.php имел ввиду?

а add_module сделал?

anonymous ()

Re: Apache не подключает php?

Честное слово, за...ли один и тот же вопрос в сотый раз задавать.

chucha ★★★☆ ()
Ответ на: Re: Apache не подключает php? от chucha

Re: Re: Apache не подключает php?

>Честное слово, за...ли один и тот же вопрос в сотый раз задавать.

Прежде, чем задать вопрос - посмотрел поиск. Толи поиск такой, что не нашел мне ничего такого похожего, толи запрос я такой задал, но тем не менее... результат нолевой.

Модули не подключал. На опеннете читал доку ничего такого не написано. Читал книги - написано, что никаких модулей не нужно, просто надо дописать в httpd.conf AddType. После этого обратился уже сюда за помощью. А если его задают сотый раз, то, наверное есть смысл выложить ответ в faq или ответить сто первый раз...

KOPEHb ★★★ ()

Re: Apache не подключает php?

cd php-x.x.x #./configure --prefix=/path/to/php \ --with-apxs=/oath/to/apache/dir/bin/apxs \ --enable-so \ --with-ssl \ попробуй так .. --with-apxs=/oath/to/apache/dir/bin/apxs главная строчка взаимодействия пхп с апачем. не уверен номожет помочь

redmoon ()
Ответ на: Re: Apache не подключает php? от kaN5300

Re: Re: Apache не подключает php?

>Я вас узнал! Про вас писали в FAQ =)))

Про кого и где конкретно? =)

KOPEHb ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.